ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   Orange Crush (http://www.advrider.com/forums/forumdisplay.php?f=34)
-   -   Yes or No, Have you had a fuel pump problem on your 990. (http://www.advrider.com/forums/showthread.php?t=461796)

Gimme 2 05-07-2009 02:24 AM

Yes or No, Have you had a fuel pump problem on your 990.
 
In the interests of understanding more about the 990 efi, please state if you've had a problem with your fuel pump, the circumstances in which it may have occurred eg traffic riding ,freeway riding, ambeint tempreture etc.. and please explain in detail how the problem began to rear its little ugly head. And mention the k's on the bike and the rectification of the prolblem.
It maybe usefull to note your general throttle action eg hard or gentle.

For the record i have a 990 adv s 07 purchased in late 08 and yes the pump packed it in.
The bike had aprox 2500 k's on the clock.

Cheers

danceswithdeer 05-07-2009 02:57 AM

My '08 has 1100 miles and is doing the same thing as yours. As soon as I can get a spare moment, I'll drag it over to the dealer.

fireball5050 05-07-2009 03:04 AM

'07 with 5600 miles, no problems so far. Hard throttle of pavement but don't have cajones to twist it hard on the dirt.

Knackers 05-07-2009 03:44 AM

06 990 25,000km.

NO.

Just you ya whinging crunt :rofl

Vicks 05-07-2009 04:40 AM

'07 990S bought in early '08. 16,000kms+ of hard tarmac & pussy-like dirt riding, live in the middle-east, temps go 40+ DegC most of the year. No problems whatsoever with the bike.

just pulled my fuel pump apart today to give it a good look. everythink is Ok in there. posting pics on another thread.

seems like you either had a bad bike or bad (very) fuel all along.

LC8TY 05-07-2009 04:40 AM

I had blocked fuel filters after a couple of thousand Ks. I refuel from some pretty dodgy (remote) places and thats what caused it.

Get the replacement filter kit, use petroleum jelly to lube the o ring seals when reinstalling the pump and carry a spare kit when going bush.

:thumb

cool dude 05-07-2009 05:06 AM

Nope
 
23000Km on my early 2006 990 Adventure and no fuel pump issues to date.

stimmer6253472 05-07-2009 05:54 AM

no issues
 
10,000 miles and no issues at all with the bike.

I think another question you should ask is how often you run the bike really low on gas. I live near a lot of gas stops and so I rarely go 5-10 miles past when the reserve light comes on.

911racer 05-07-2009 06:33 AM

15,000 miles = no problems :clap

K80JIM 05-07-2009 06:56 AM

07 with 11,900 no problems

BIG-E 05-07-2009 07:20 AM

'07 990"S" 13,000 miles, no problems at all. Ran it waaaay low on gas a few times, no problem. it will actually go 60 miles on "F" trip, I found that out in Death Valley this year. Allthough, I am wondering about it at every oil change, and the water pump.

Take care Brothers, Eric.

MAXVERT 05-07-2009 07:32 AM

No problems yet.
Changed filters at 25,000 miles, with many long hard days in challenging
conditions.
Kyrgyzstan near the Tajik and China borders

http://maxvert.smugmug.com/photos/465102424_HMwiD-M.jpg
http://maxvert.smugmug.com/photos/465102465_SuFGc-M.jpg

Local gas

http://maxvert.smugmug.com/photos/465098191_dQEtU-M.jpg

Twist it, MAX

Dusty 05-07-2009 08:24 AM

17,000 miles no probelemo. Changed filters at 8,000 miles...

07 - 990

Taurkon 05-07-2009 09:49 AM

YES. Around 3500 km and mine died.

New one replaced on warranty, and I am now at 10500 km and beginning to wonder if the new one is bummed! Bike is sputtering, popping, stalls at idle once warm, and sometimes is only running on a single cylinder. Thing is, it does not happen all the time. Dealer can't find the problem... plugs are good, diagnostics comes up clean. I've run a few containers of injection cleaner through, and no luck. Starting to think it may be the pump.

sidestand 05-07-2009 12:21 PM

07 990S , 12000miles pump failed no warning start up from cold 10 sec ride to the fuel pumps start up again into gear clutch out stopped dead . replaced under warranty, no probs with anything else since or before.


Times are GMT -7.   It's 05:13 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014