ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   The Garage (http://www.advrider.com/forums/forumdisplay.php?f=50)
-   -   Need ideas to keep lifting cam in place (http://www.advrider.com/forums/showthread.php?t=829799)

JAB 09-27-2012 02:41 PM

Need ideas to keep lifting cam in place
 
I'm looking for a better way to keep this cam from moving on it's shaft.
http://farm9.staticflickr.com/8036/8...5f01a5f4_c.jpg
This is on a printing machine. The cam lifts the weight of the print head of the machine on a stationary follower. The problem is that the cam is only held in place by 2 set screws (which have held pretty well to this point) and the set screws will loosen and allow the cam to move on the shaft and eventually the cam will start hitting the frame of the press. Loctite does not help. On this type of press this is a common problem. One solution I have seen is to split the mounting boss and make it clamp the shaft. Not impossible, but it requires a lot of downtime and a trip to a machine shop. Thought about drilling a divot in the shaft to catch one of the set screws, but don't want to end up chewing up the shaft if that does not hold. Ideas or suggestions from the collective would be welcome. :ear

Bounder 09-27-2012 03:21 PM

Can you drill straight through the cam and shaft and use a roll pin to stake it?

High Country Herb 09-27-2012 03:24 PM

Do you need to be able to adjust its angle? If not, how about drilling it all the way through, and replacing the 2 set screws with bolt and lock nut? Crude, but effective. If you use a brass or aluminum bolt, it will wear before the important steel parts.

edit: you beat me to it!

kioti 09-27-2012 03:29 PM

Cut a Keyway and be done with it.

MagyarMan 09-27-2012 03:35 PM

Quote:

Originally Posted by Bounder (Post 19694471)
Can you drill straight through the cam and shaft and use a roll pin to stake it?

Yup that's how it's done!

JAB 09-27-2012 04:02 PM

A roll pin might do it. Guessing if it can't move, it may not come loose, but a roll pin won't put up with much shearing force. There is a square key on it already with one of the set screws on top of it to clamp it. I would be wary of drilling the shaft all the way thru because if the shaft or the bolt broke, it could drop the print head on the operators hands.
Thought about drilling and tapping one more hole for a set screw and drilling a matching divot into the shaft for the screw to catch.
Keep it coming.

timsgs 09-27-2012 04:30 PM

Put a small indention in the shaft with the point of a drill bit, then use a pointed short set screw, and then another set screw on top of that one to lock it in place.

MagyarMan 09-27-2012 05:45 PM

I've worked on NC lathes and the ballscrew shafts had drilled and reamed taper pins slotted on the large end and the safety wired to keep it from backing out. These shafts took a lot of shocks and the only time I had a problem was when there was a tremendous wreck (shearing the brass pins on the slide). The taper pins never broke but were a bit bent! Drove them out ,rereamed the hole and put a slightly larger taper pin in. It might be worth a look?

GreaseMonkey 09-28-2012 12:27 AM

If you want to try the simple stuff first, I'd suggest removing those set screws and replace them with proper bolts that you can tighten. Maybe get them long enough to put a nut on, then you can tighten the bolt down and snug the nut down underneath it to keep it from loosening.

Of course there are plenty of other ways, but to me that would be the easiest and fastest thing to try. Next would be to drill a dimple under where the set screw "cough cough bolt...." is and that should keep it from moving. Lastly you could also tap the hole larger and use a heftier bolt.

GreaseMonkey 09-28-2012 12:29 AM

Also, post up some pics of what your machine looks like.

machinebuilder 09-28-2012 09:31 AM

its har to tell much from the picture but

a set screw on top of the key + 1 90degrees from it, is a very common way to do that.

If loctite isn't holding the set screw, CLEAN the hole and screw first, loctite primer helps too.

IF you have room (deep enough hole) double set screw, the top one will lock the bottom one, just make sure the top one is a flat end

you may need to check the linkage alignment. It sounds like you have a problem with some side forces on the cam pushing it side to side. possibly the piece welded on the cam has a crooked hole.



:hide
as a last resort weld it to the shaft

xcflyn 09-28-2012 12:35 PM

-take that gear box apart and send that shaft in and get it splined, then have the cam hub broached ? hopefully timing can be adjusted on input ?
-Go to taper lock hub with key- it wont move- I used to work on 2' cams on 1.500 shafts, heavy load high speed, taper locks rarely failed if ever.
-Also sometimes we look at the problem instead of solution so to speak. Can you counter the cam loading to take some of the strain off the cam hub ? Generally even in high speed applications there is always some type of unloading effect as the cam goes past the high or dwell, this creates the load to be out of balance so to speak.
Just some thoughts. I didnt read too closely so maybe this was covered in past replies.
-I would not drill into the shaft or you may find the next weakest link.

JAB 09-28-2012 01:36 PM

Here is photo of the machine....................
http://farm9.staticflickr.com/8457/8...c4252b73_c.jpg

The whole head hinges at the back. The cam and follower are about a foot in front of the pivot point, so there is a fair amount of weight or twisting force on that cam. Not a lot of speed or impact, but it is constant load/unload. There are 2 smallish set screws holding that cam to the shaft. I like GM's suggestion to replace the screws with bolts. There is a 1/4-20 over the keyway and a 5/16 at 90 degrees of that. Thinking about dropping a couple of brass flat washers in the holes to give the bolts a little more traction on the shaft and lock them in with a lock nut.
The spline shaft idea would totally kill the problem. If were going to build machines like this, that would be the way to go.

Thanks again for the input.

Benesesso 09-28-2012 02:22 PM

Quote:

Originally Posted by JAB (Post 19694210)
Loctite does not help.

Which Loctite and how did you use it? Are the shaft and cam both plain carbon steel?

JAB 09-28-2012 02:49 PM

Used the blue stuff on the set screws. Everything is carbon steel. I don't think the cam was heat treated.


Times are GMT -7.   It's 02:02 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014