ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   The Garage (http://www.advrider.com/forums/forumdisplay.php?f=50)
-   -   Yamaha Generator Troubles (http://www.advrider.com/forums/showthread.php?t=846212)

buickid 12-05-2012 12:57 AM

Yamaha Generator Troubles
 
Just picked up a EF2800i for really cheap today (damn you Craigslist, so addictive), guy said it had been sitting for a couple years and would only run with the choke on. Coming from motorcycles, I pinpointed this as a clogged carb from gas going bad. Guy used to use it to power his food truck, "everyday, for about 3 years". Whew, quite a few hours, but it didn't smoke when we started it up and compression seemed good on the pull starter. Gave him $180 for it and brought it home.

Spent a few hours dusting it off, cleaning out all the dust and cobwebs, adjusted the valves to spec, cleaned out the carb. Put it all back together and fired it up, still hunted without the choke, but held a load just fine (1000W halogen light). Decided to take the carb out and give it a little more cleaning action. The main jet was frozen in the carb and resisted all attempts of removal. Pretty sure its in the permanently now. Cleaned it out as best as possible with multiple passes of carb cleaner and compressed air. Runs pretty well now, only starts bogging at high RPM (manually controlling throttle), which I would expect to clear up as it runs with the Seafoam in the gas.

Although the motor purrs pretty good now, the inverter/throttle control side seems to be acting up (This unit uses an electronic governor, like the Hondas). Even though the RPMs are sufficiently high with no load, the AC pilot light will come on, and flicker a little, then stabilize. Once I plug a load in, the inverter will cut out, turning off the pilot light and the load. If I rev the motor manually, the inverter holds the load just fine. Also, with Eco on, the RPM gets really low and hunts. If it can hold RPM normally with Eco off, its getting plenty of fuel, so I'm guessing its flowing enough fuel.

I suspect there is something wrong with the engine speed control circuitry, but I'm not sure how to proceed. The only part I could economically replace is the stepper motor, about $30. The inverter board and engine control are a single, fully potted unit, about $600. Another symptom: a few times upon shut down, the throttle butterfly did not return to WOT as it should have, however it resumed normal operation after those isolated incidents. Anyone got some insight? If I can't get it to work, I'll probably part it out as any of the major replacement parts would cost far more than I paid for the unit.

Edit: I got the service manual and I'll check the resistance values on the stepper motor when I get the chance. I'm hoping its that!

GreaseMonkey 12-05-2012 01:48 AM

How long has it run since you fixed it? I worked on an Onan genny unit that had sat for a few years and once I got it running reasonably well but not perfect I let it run with a load for an afternoon and it made all the issues disappear.

buickid 12-05-2012 01:58 AM

Its run about 30 minutes or so (picked it up this morning). Its an inverter type generator though, little bit different operation than a conventional generator (output not directly linked to engine speed). I think its an electronic problem, not mechanic. I can always manually work the throttle to make it to run with a load, to get fuel through the carb so the Seafoam can work its magic. I'll probably do that tomorrow after I get home, load it down and let it cook a little.

GreaseMonkey 12-05-2012 10:01 AM

I agree with your thought process, I have just developed the process that any device designed to work, whether electrical or mechanical, needs to actually be worked for a while after a length of inaction.

Then again, anymore when something is broken and it fixes itself most of the time I don't care what happened, I'm just glad it's working again. Obviously you can be more casual about some items than others,but you'll get there too eventually.....


Times are GMT -7.   It's 10:56 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014