ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   Layin' down tracks (http://www.advrider.com/forums/forumdisplay.php?f=37)
-   -   Montana/mac Software porblem - Help! (http://www.advrider.com/forums/showthread.php?t=846247)

Tim 12-05-2012 08:09 AM

Montana/mac Software porblem - Help!
 
I have tried searching for a solution to my problem but can't find anything so would appreciate some help or a pointer in the right direction.

My Mac is an iMac (Intel), running 10.5.8.

My mapping software is City Navigator Europe NT 2012.3

I have previously been able to load these maps to my Montana 600 and everything has worked as it should.

Today when I switched the Montana on I didn't have any of my maps, just the base map (this may be as a result of me doing something wrong previously but it is some time since I used it and I really can't remember). I have checked that it's not just that the maps are switched off but they are not listed, just the base map. I even tried switching profiles to see if they showed up but they are not there.

I then connected the Montana to the iMac in order to go to Garmin.com to check my maps. I got a message from Garmin telling me that I needed to update my Communicator Plug In. I downloaded the update, double clicked on it as instructed and got this message

http://ktim.smugmug.com/Electronics/...ure%201-XL.png

I have tried this three or more times and still get the same message every time. I even did a full computer re-start but still get the same. I also tried it with and without the Montana connected to the iMac.

Being unable to check on my maps through Garmin.com I opened BaseCamp and confirmed that the maps are there

http://ktim.smugmug.com/Electronics/...ure%203-XL.png

So I open MapInstall and get this message

http://ktim.smugmug.com/Electronics/...ure%208-XL.png

Click "Install now" and then get this

http://ktim.smugmug.com/Electronics/...ure%209-XL.png

So, now I see a pattern developing, the "No default application specified" pattern.

I then tried MapInstall again but this time told it to do the upgrade later and when ahead and told it to load the maps to the Montana. I left it doing its thing and then it just stops with this

http://ktim.smugmug.com/Electronics/...ure%206-XL.png

I can leave it like this for as long as you like and nothing further happens and I have to cancel in the end.

As a last resort I tried to re-install the maps onto the iMac from the DVD but couldn't do that either as I again got the "No default application specified" message.

http://ktim.smugmug.com/Electronics/...re%2015-XL.png

So, I suppose that the main question is what is the default application and where can I get it and, come to that why haven't I got it!?

Any help would be most appreciated, thanks.

WoodButcher 12-05-2012 09:13 AM

That's a Mac issue, not a Garmin issue. Usually it is just an association issue. So you need to re-associate the .pkg files with the installer. Here is something I pulled off a google searh:
First right click on the .pkg & select the get info. New window will appear, select the open with, Is there Installer app from the list to chose from?

You can manually open the installer app from:

/System/Library/CoreServices/Installer.app

Is the installer app location there?

Hope that helps.

Tim 12-05-2012 11:23 AM

Thanks for the advice - I didn't realize that it was a Mac problem. The /System/Library/CoreServices/Installer.app worked perfectly for installing the Communicator plugin and Map update, I am now in the process of re-installing my maps and will report back on the result.

Thanks again :thumb


Times are GMT -7.   It's 02:47 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014