ADVrider

ADVrider (http://www.advrider.com/forums/index.php)
-   Thumpers (http://www.advrider.com/forums/forumdisplay.php?f=15)
-   -   KLR Shifting problem (http://www.advrider.com/forums/showthread.php?t=886921)

p_funk 05-13-2013 06:35 PM

KLR Shifting problem
 
This forum has saved my ass (especially with this bike) more than once so in advance, I thank you. I don't claim any mechanical skill, but I can follow directions pretty well and with that, here goes:

I own an '04 KLR that has definitely had a full life. It currently sits with about 26,000 miles and every mod under the sun including an aftermarket doohickey before 17,000mi when I purchased it. I lent it to a friend shortly after he got his mc permit and got a call one day that it had "just stopped working." He told me that he had been shifting into third, when the engine just cut out. He got it towed home, and couldn't get it started. When I took it back, it appeared that the starter solenoid had gone and the engine had locked up. With very little effort I got the engine spinning again and it started up with a quick battery charge. Excited as all hell I took it for a ride. Shifting from 1-N-2 works just as it should, but when I try shifting into 3rd, it just freewheels as if I'm in neutral and I'm met with the resistance you get when looking for a 6th gear. Knowing almost nothing about a motorcycle transmissions, I read up on that common flat spring that enables proper shifting and hoped that was it. Pulled the clutch cover yesterday and found that to be in great shape. While I'm not sure what I'm looking at, the clutch plates look like they're in great shape. I've got a clutch puller-vice grip thing in the mail, so I can't go any farther for a day or two. I checked the oil screen and found the (apparently) usual gasket bits but with some added bonuses: 2 tiny bits of metal and an ~1" piece of what looks like a spring (thin round steel, circular bend). I'm hoping these are parts of the old doo? Anyway I can't seem to find my camera, but I'll get phone pics up as soon as I can. Figured I'd throw myself before the knowledge that is the internet while waiting for a clutch puller. Any ideas?

Kawidad 05-14-2013 08:09 AM

You're going to have to split the cases and take a look at the transmission. It's not overly difficult. :norton

securety10 05-14-2013 09:46 AM

I take it the PO replaced the doo? I only ask because the spring could possibly be from the original doo (unless you know what it looks like and can verify it isn't). DO you know if the original doo broke? The end of the spring broke off in my 04, but luckily I hadn't tried adjusting it. Was a torsion spring installed when the doo was done? If not, there was a thread on KLRforum I believe where a person made the claim some EM (non-torsion) springs broke. Some theorised there may have been a bad batch in regards to heat treating, but I don't think a final determination was ever made. Point being I'd check the doo and spring again also, problems could be related (eg maybe a chunk of spring or doo jamed somewhere in the bottom end). As noted above though, thinking you may be learning how to split cases shortly...

p_funk 05-21-2013 02:19 PM

Update/more questions
 
So I got the bike torn down a little more. Having never seen a bike piston I guess it looks ok? Seems like a small nick on the top-left.
http://i1225.photobucket.com/albums/...ps37642042.jpg
At any rate, I've got a 685 kit on its way so I guess it's a paperweight. The cylinder looked perfect, not even the slightest scratch. When I pulled the jug I noticed this, right by the piston arm.
http://i1225.photobucket.com/albums/...psc89fd970.jpg

Top view:
http://i1225.photobucket.com/albums/...ps2f27dca5.jpg

Here are the bits that came with the oil screen. From what I can tell, they look like the original doo
http://i1225.photobucket.com/albums/...psf33f60ef.jpg

View of the clutch side. I just got a clutch tool in the mail and will attempt to remove that tonight.
http://i1225.photobucket.com/albums/...ps004fe558.jpg

Note the spring is in good shape
http://i1225.photobucket.com/albums/...psc3f6e533.jpg

That's as far as I've gotten. I assume the next step is to pull the engine out and split the cases? I don't have a work bench, but I'll make do...kind of doing all this in a closet. Is there any way I can split the cases without that special tool? I'd love to get right on this and not have to wait for another part in the mail. Hoping to use this bike on a ride in just over 2 weeks so time is getting tight. Also, how concerned should I be about that gouge by the piston? Should I be shopping for a new bottom-end right off the bat? As always, thank you kindly.

RandoCommando 05-21-2013 11:10 PM

Quote:

Originally Posted by p_funk (Post 21459158)
Here are the bits that came with the oil screen. From what I can tell, they look like the original doo
http://i1225.photobucket.com/albums/...psf33f60ef.jpg

That's not even close to the doo/lever. That may possibly be parts of the torsion spring.
If you have one of those telescoping magnets, make sure you go through that whole engine case to find any loose bits that were not in the screen or oil pan.

Beezer 05-22-2013 12:44 AM

the small one looks like the end of the original coil spring. the other big one.... not sure. it kinda looks like a piece of torsion spring

those dink marks in the case.... wtf? somebody or something was inside there & wanged it pretty good. is there any marks on the inside of the piston? just a guess but looks like loose parts got jammed between the piston & case. I wouldn't worry about the damage though, theres a lot of metal there, just clean it up

somebody may want the piston... Gen I rings are no longer made. Gen II rings (and piston) are a slightly different ring design

larryboy 05-22-2013 10:47 AM

You've got a bent valve.

That bigger spring chunk looks like part # 92081B , go look at it on the fiche at ronayers.com or someplace. You say it's ok and post a pic...I can't see the spring in your picture. It could also be a broken Eagle Mike doo torsion spring.

You're gonna have to take the whole thing down to bare cases for inspection. Open up the oil pump and check for scoring...this is where Beezer comes in and says they never fail...I have another bad one sitting here on the bench, it's stupid to do a 685 kit and repair an engine, then leave an old worn out oil pump in the thing.

p_funk 05-22-2013 12:28 PM

Quote:

Originally Posted by Beezer (Post 21463189)
those dink marks in the case.... wtf? somebody or something was inside there & wanged it pretty good. is there any marks on the inside of the piston?

Underside of piston looks normal, no obvious damage anyway

Quote:

Originally Posted by larryboy (Post 21466166)
You've got a bent valve.

That bigger spring chunk looks like part # 92081B , go look at it on the fiche at ronayers.com or someplace. You say it's ok and post a pic...I can't see the spring in your picture. It could also be a broken Eagle Mike doo torsion spring.

The spring I'm saying is ok is that flat one under the shift star. 92081B could be toast for all I know. I'm gonna try to split the cases tomorrow. Careful spreading with some wooden blocks ok, or do I absolutely need something like this? Also, the bent valve is evidenced by that nick in the piston I assume? Is it as simple as remove old-install new or am I missing something entirely? Thanks.

Beezer 05-22-2013 01:37 PM

Larryboy.... yer killin me brother..:rofl I do oil pumps on condition (including dimensional). nothing wrong with replacing a pump to be safe.

ya, I forgot to comment on that on my other post but a bent valve is a real possibility, since the piston hit the valve. the question is why, and why only one. what are the clearances on the valves? check the guides real close for cracks. dimensional inspection of the guide is in order too, especially on the combustion chamber side.

92081... hard to tell from the pix but that could easily be it & that goes along with shifting problems

you have at least 3 anomalies that seem to be unrelated.... yet all at once? I can make up some stories but they get pretty far fetched. I think there is a old lever loose in there somewhere & got to the cam chain and the case. the shifter.... don't know, could be several things

ask your friend for more detail... like what really happened. klrs with a past history of broken doo levers have been known to circulate those parts at a much later date. especially if the bike has been flipped or something.

Unstable Rider 05-22-2013 05:59 PM

So, trying to follow along, has the doo side of the case been investigated yet?

Is it intact, and how is the SPRING?

I have examples of E Mike stock-style springs breaking, but not torsion EM springs.

Some tried to cheat and replaced the doo but not the spring, or the spring and not the doo, etc.

p_funk 05-22-2013 07:02 PM

Bah
 
Quote:

Originally Posted by Beezer (Post 21467604)
ask your friend for more detail... like what really happened. klrs with a past history of broken doo levers have been known to circulate those parts at a much later date. especially if the bike has been flipped or something.

Man, that doesn't sound so fun. I suppose the next step is to split cases, yeah? Can it be done with a good dead blow and some patience/wooden levers? I've asked the friend at length what happened. It was about a year ago and he's been all sorts of useless as far as clues. Apparently it "just stopped" when he was getting into third. I think something bouncing around sounds pretty feasible, I've just got to get them apart I guess.

Quote:

Originally Posted by Unstable Rider (Post 21469745)
So, trying to follow along, has the doo side of the case been investigated yet?

Is it intact, and how is the SPRING?

I have examples of E Mike stock-style springs breaking, but not torsion EM springs.

Some tried to cheat and replaced the doo but not the spring, or the spring and not the doo, etc.

I haven't gotten that side yet. Cover's off, but I need a rotor holder/puller. Any idea if this can be done with basic tools (not the Eagle Mike one)? I'd really like to get at it tomorrow instead of waiting for more mail. Thanks.

larryboy 05-23-2013 10:30 AM

Quote:

Originally Posted by p_funk (Post 21467027)


The spring I'm saying is ok is that flat one under the shift star. 92081B could be toast for all I know. I'm gonna try to split the cases tomorrow. Careful spreading with some wooden blocks ok, or do I absolutely need something like this? Also, the bent valve is evidenced by that nick in the piston I assume? Is it as simple as remove old-install new or am I missing something entirely? Thanks.



No special tools are needed to tear down a KLR engine aside from the rotor puller...assuming you have an impact gun..electric or air. If you're all hand tools, then you'll need a rotor holding tool like Eagle Mike sells and a clutch basket holder tool.

There are spreader tabs on the cases, look for those, get it started with a big screw driver on those tabs, then a dead blow hammer while you slightly hold the engine off the bench by holding up one side of the case. Follow? I like to hit the crank with the dead blow from the rotor side.

http://i8.photobucket.com/albums/a32...e/IM003369.jpg


Let a machine shop replace the valve, needs to have the seat matched up to it. What happens there is that a broken spring part rides the cam chain to the top and jumps the timing...usually just a tooth or two, sometimes you get lucky and don't hit the valves, you didn't get lucky.

Unstable Rider 05-23-2013 10:34 AM

Please post some pics of what you find when you get into the area of the Doo Hickey. I like to have some casual informal stats or "proof" that it is indeed a problem, as some people think still that it is myth, when documentation of broken springs, etc is quite prevalent, even in my own riding group.

Thanks in advance. :evil

larryboy 05-23-2013 10:45 AM

Quote:

Originally Posted by Unstable Rider (Post 21475093)
Please post some pics of what you find when you get into the area of the Doo Hickey. I like to have some casual informal stats or "proof" that it is indeed a problem, as some people think still that it is myth, when documentation of broken springs, etc is quite prevalent, even in my own riding group.

Thanks in advance. :evil


I've seen at least 100 broken springs, 30 odd broken levers and not a single working 2008 > newer balancer lever system, NOT ONE.

My bad oil pump count is going up rapidly, if I had a KLR with more than 20,000 miles I would open up the right side to inspect the oil pump. It's a metal on metal rotor style and I don't think it likes the KLR cheap ass oil we all like to use 15w40 Delo and Rotella.

XpressCS 05-23-2013 11:22 AM

Make sure you take pictures as you pull things apart, and having a service/repair manual that details engine reassembly is always a good idea to have on hand.

While you're at it, have the head pressure tested... That nick in the piston leads me to believe a valve may be bent. Worst case scenario there is you will have to have the valves replaced, I would just have the whole head rebuilt, never a bad idea with a high mileage engine.


Times are GMT -7.   It's 09:52 AM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014