ADVrider

Go Back   ADVrider > Search Forums
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Showing results 1 to 7 of 7
Search took 0.00 seconds.
Search: Posts Made By: OldMadBrit
Forum: Beasts 02-17-2013, 09:56 PM
Replies: 15
Views: 2,487
Posted By OldMadBrit
No it was absolutely pristine and came with a...

No it was absolutely pristine and came with a Givi Top box, Aprilia side cases and hand guards. It had a failed fuel connector but the owner was clueless when it came to mechanical repairs. His...
Forum: Beasts 02-16-2013, 12:26 AM
Replies: 15
Views: 2,487
Posted By OldMadBrit
I have had mine for 18 months and 11,000 hard...

I have had mine for 18 months and 11,000 hard miles. When I got it (for $2K with only 6000 miles on it) I put a set of RICOR intiminators in the forks, threw away the 25lb boat anchor OEM cans (Leo...
Forum: Beasts 12-16-2012, 07:43 PM
Replies: 714
Views: 214,031
Posted By OldMadBrit
Its been raining on an off all weekend and the...

Its been raining on an off all weekend and the local canyon roads are snot slick with mud, leaves and pine oil. So I just did a 70 mile loop of the local twisties along with a short play in a large...
Forum: Beasts 12-15-2012, 12:11 PM
Replies: 714
Views: 214,031
Posted By OldMadBrit
They are fine on pavement on wet and slimy stuff...

They are fine on pavement on wet and slimy stuff and amazing on dry twisty stuff. I wish I had put them on sooner instead of procrastinating. IMHO if the K60 Scouts had been available when the Capo...
Forum: Beasts 12-14-2012, 12:16 PM
Replies: 714
Views: 214,031
Posted By OldMadBrit
I am very pleased with the K60 Scouts - its as if...

I am very pleased with the K60 Scouts - its as if Caponords were made with these tires in mind. The K60 has incredibly stiff sidewalls (almost like a run-flat car tire) this seems to work very well...
Forum: Beasts 12-14-2012, 10:55 AM
Replies: 714
Views: 214,031
Posted By OldMadBrit
I'm a dork and copied the wrong IMG code from...

I'm a dork and copied the wrong IMG code from photobucket - fixed
Forum: Beasts 12-13-2012, 04:20 PM
Replies: 714
Views: 214,031
Posted By OldMadBrit
Here is mine

I purchased my 2003 a little over 18 months ago

http://i1273.photobucket.com/albums/y413/OldMadBrit/Caponord5.jpg

I did all of the mandatory fixes (fuel lines, brown connectors, MOSFET Reg/Rec)...
Showing results 1 to 7 of 7

 
Forum Jump

Times are GMT -7.   It's 05:31 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014