View Single Post
Old 10-06-2011, 09:36 AM   #66
Cat and DR Rider
Quebekers
 
Joined: Oct 2011
Oddometer: 1
Sorry. NO Ballast, but same problem

Suncruiser, I'd like to add a comment.

I just came back from a journey in Utah. 2500 miles from Quebec City, Canada, to Hurricane, Utah, in only 3 days, the Adventure 990 2009 (no fog lamp) sitting in a good trailer all way down.

After a good night, I finally start the engine. My wife and I were smiling and hoping for a wonderful 2 weeks of biking in the backcountry of Utah. 10 miles after, we stopped at a gas station to fill it up. Try to restart: NOTHING, except the 2 codes you encountered.

Hopefully, after 10 minutes of waiting and trying, it started. The nearest dealer was at 350 miles. So we decided to ride the bike but stay on good paved road, and near cities.

The problem happened each day of this travel. And it restarted each time, after we wait. I think the problem in my case is related with the hot temperature.

The journey we planned in the canyons never happened. 5000 miles and all expenses for nothing. 2 vacation weeks completely wasted. And a lot of money too.

Now, we are back here in Canada and my confidence in this motorcycle has gone completely. I will bring it to my dealer and I will see what he has to say about it. Something like "I never saw it".


The motorcycle is completely stock. We really don't need this type of device on what it is supposed to be an adventure bike. Now, I'm sure that adventure means adventure just to own this KTM, not adventure of riding it.

I simply hope that KTM will listen about the too many problems of reliability of this model: oveheating, immobiliser default, and so on.

Again, I think the bike is great when it works, but is it really reliable?
Cat and DR Rider is offline   Reply With Quote