View Single Post
Old 12-16-2011, 12:28 PM   #168
motojunky
Professional Idiot
 
motojunky's Avatar
 
Joined: Oct 2007
Location: North East, MD
Oddometer: 1,065
Quote:
Originally Posted by BikePilot View Post
The clutch really needs the correct oil (elf), else it just won't work quite right. It is sensitive to oil and the correct oil makes a world of difference. Mine drug really bad and had rather iffy engagement feel when I got the bike. Put in the elf oil and it doesn't drag at all, feel is awesome etc. The elf stuff is expensive, but it lasts a long time and you only need half a liter at a time anyway so a $40, 2-liter bottle is good for four changes which should be plenty to last a full year or better for most folks.
Did you try fresh oil of any other brand before you switched to Elf?

When I bought my 314 a while back, the Elf was highly recommended for the same reasons. Being a cheapskate I opted to try something else first. I don't remember for sure but I think it was Silkolene. Anyway, the clutch worked great - no dragging, no funny engagement, etc. Might be worth a shot to run something less expensive and easier to get to see how it works for you. If it doesn't work, then at least you won't feel as bad about spending the coin on the Elf stuff.

Totally unrelated: I rode at White Rose a couple of weeks ago. Remember the big log in section two that we threw ourselves at for 15 minutes or so? It was a complete non issue this time. I was pleased to have a way to prove to myself that I have actually gotten at least a little bit better this year.
motojunky is offline   Reply With Quote