View Single Post
Old 08-29-2012, 06:38 AM   #4
flybitten
n00b
 
Joined: Aug 2012
Oddometer: 1
I had the same problem with my G4. One month old and all of a sudden 1 of the 2 units won't turn on. At first, I charged it for about 3-4 hours thinking the battery died. After the red light went off, I pushed the mobile button but nothing happened. I tried plugging it into the PC to see if it would connect, but only the red light came on and the unit wouldn't turn on. I charged it again for another 3 hours, nothing. I did the reset thing by plugging it in for 10 seconds and unplugging it and tried to turn it on, still nothing.

I let the unit sit for about 2 days getting some paperwork ready to send the unit to Cardo. I tried to turn the unit on again and all of a sudden the blue light flashed! But it wouldn't remain on. I plugged it into the PC, and the unit finally turned on (hold down volume up and mobile for a few seconds). It's alive! So I removed it from the PC and plugged it into the wall to charge for 3 hours. I turned it on, and now it's working again. I don't get it, but happy that it works!
flybitten is offline   Reply With Quote