View Single Post
Old 10-04-2012, 11:15 AM   #1276
syntec4
Beastly Adventurer
 
syntec4's Avatar
 
Joined: Oct 2006
Location: Manchester, UK
Oddometer: 1,223
We'll...

Had to take the Disco back to get the steering box leak fixed. It didn't even make it back to the dealer On the way there I was waiting in traffic on a downhill section, so I pushed it into Park. Just at the time I moved the lever, there was a clunk which I couldn't tell at the time if it was a Missfire or a gearbox clunk. We got moving again and made it another 200 yards or so and it just died on me. No engine at all. It was turning over nice and quick but just not firing. No warning lights on the dash. I called the dealer and they came and rescued me as I was only about 1/2 mile from them at that point. When we got to their workshop they opened the bonnet and poked around. They pushed the fuel cutoff switch and tried it again. Amazingly it started? Although they didn't think the switch had tripped out. Anyway they plugged it in for diagnostics and couldn't see any errors so they took it for a spin with it plugged in. They were gone quite a while.... Turns out it died on them as well. So at least they have seen it fail. They have sent me home in a loan ford fiesta while they try and find the fault although they said they suspected the Crank shaft sensor and/or fuel pump has failed. I hope they find the problem and fix it properly as it's not been a good start.
__________________
My Smugmug
syntec4 is offline   Reply With Quote