View Single Post
Old 11-08-2012, 10:51 AM   #4368
Swarthy_Red_Beard
Gnarly Adventurer
 
Joined: Apr 2007
Location: Humboldt, Nor Cal
Oddometer: 148
Quote:
Originally Posted by RAZR View Post
i'm sticking with the floated rewound stator Javier at Trail Tricks did. me and my buddy are cleaning up at least 30 wires that don't need to be in the headlight bucket.
basically, Trail Tech X2 HID headlight, heated grips, Sicass switch, GPS, Trail Tech Endurance, fan (with a switch)... makes for a lot of wires. but we cleaned it up. i also have a Lithium battery. not the Shorai, but identical. works amazing.



i have a new problem...

my starter whines and doesn't engage in the motor. sometimes it does. but it's engaging less and less. battery shows full charge. kick starting it starts on one kick.

a few months ago i cut the compression release cable because it was crimping/cutting into my wiring harness. i figured i don't use it, so i don't need it. (i'm dumb, i know)

after Googling the whining starter not engaging blah blah blah, some stories of compression is coming up.

before tearing into the motor to see if the starter clutch is gone, or if the teeth are bad, i want to get some feedback.

i am not a great home mechanic, my buddy is. but he owns a 2010 530 and doesn't know RFS motors. but he's willing to help.

what should i do first?


i have a huge ride coming up in 2 weeks, so i'm stressing.

What year bike? I have an 05 so had to deal with the intermediate gear issues from that year. Similar symptoms. Sounded like marbles rattling in a tin can when I hit the starter button. then the next time it would be fine. Got progressively worse until I fixed it. FWIW
Swarthy_Red_Beard is offline   Reply With Quote