ADVrider

Go Back   ADVrider > Bikes > Old's Cool
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-28-2013, 06:31 AM   #1
RT Caldwell OP
n00b
 
RT Caldwell's Avatar
 
Joined: Jan 2013
Location: Prescott AZ
Oddometer: 7
Resurrecting a /5 BMW

Hi y'all,

Newish member, first post, nice to be here.

After a 4-year hiatus, I've dug my '71 BMW out of the pile in back of the shop and have it once again running a bit. It starts right up, idles relatively smoothly and accelerates well. Problem is, when it settles in at a steady RPM with no positive throttle applied, it misses and runs very rough. What I mean by no positive throttle is that it runs smoothly going uphill. I've cleaned and gapped the points, set the timing and checked the wires, plugs, etc. Before parking it, I'd replaced the twin coils with a single Harley-type coil with a 3-ohm rating. Carbs are new 34mm Mikunis, so I doubt this is a fueling issue, it feels very strongly like ignition.

The only thing I can think of is maybe the centrifugal advance unit, so I have some new springs on the way. Any other ideas or thoughts would be greatly appreciated.

Again, it's good to be here,and thanks in advance for your wisdom and advice.
__________________
Cognito Ergo Wrenchum
RT Caldwell is offline   Reply With Quote
Old 01-28-2013, 06:37 AM   #2
RT Caldwell OP
n00b
 
RT Caldwell's Avatar
 
Joined: Jan 2013
Location: Prescott AZ
Oddometer: 7
Damn, wrong parking lot. Thought this was Airheads - sorry gents.
__________________
Cognito Ergo Wrenchum
RT Caldwell is offline   Reply With Quote
Old 01-28-2013, 09:24 AM   #3
bpeckm
Grin!
 
bpeckm's Avatar
 
Joined: Apr 2008
Location: Road Island
Oddometer: 5,657
My first thought was carbs, but you could be right on the ignition advance unit... maybe it's sticking too advanced, but I'm not sure that it would make it run "rough"... more likely it would ping or something? .......does it come back to idle when you blip the throttle? a lot of times a sticking advance will keep the idle speed up 'way high.

....and keep after the carbies, too.... I don't know Mikunis particularly, but the transition from idle/pilot/running jets can get lumpy if one of the jets is partially blocked etc...

Good luck!

__________________
XS650 becomes a VT BackRoadRunner
Loving the 80ST
I love projects that take twice as much effort as should be needed. Should be an Airhead motto. (disston)
__________________
bpeckm is offline   Reply With Quote
Old 01-28-2013, 01:32 PM   #4
Mista Vern
Knows all - tells some.
 
Mista Vern's Avatar
 
Joined: Dec 2005
Location: McMinnville, Oregon
Oddometer: 15,032
Hope this gets moved to airheads, but welcome anyway! Check too for vacuum leaks at teh carbs. Best of luck!
__________________
-
"The turd follows the fart as surely as the rain follows the plow."

Emily Bronte
Mista Vern is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 11:18 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014