ADVrider

Go Back   ADVrider > Bikes > Battle scooters
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-05-2009, 11:47 AM   #1
harleyd3 OP
jhunt
 
Joined: Jun 2008
Location: middle tennessee
Oddometer: 228
vespa help

looking for jets for a weber carb ,the vespa guys only sell the compete carb but no single jets anybody got any ideal of were to look ?thanks
harleyd3 is offline   Reply With Quote
Old 12-07-2009, 07:33 PM   #2
sssevita
n00b
 
Joined: Dec 2009
Oddometer: 1
Weber Carb Jets

You can try 1977mopeds.com in San Fran, or carbparts.com in Ohio.
sssevita is offline   Reply With Quote
Old 12-08-2009, 08:08 AM   #3
Brooktown Geezer
scooter guy
 
Brooktown Geezer's Avatar
 
Joined: Feb 2009
Location: Fallbrook, CA
Oddometer: 481
wouldn't happen to be for a 2001-2002 ET2 by chance?
Brooktown Geezer is offline   Reply With Quote
Old 12-12-2009, 07:56 AM   #4
harleyd3 OP
jhunt
 
Joined: Jun 2008
Location: middle tennessee
Oddometer: 228
vespa help

Quote:
Originally Posted by Brooktown Geezer
wouldn't happen to be for a 2001-2002 ET2 by chance?
yep its 2002 ,,,,,,,,,,i cant get it to run for squat about 12 mph
an i have tried everything that i know to do to get this bike runnin
its been sitting for 7 years,,,,,,,,,so im gonna try new jets
harleyd3 is offline   Reply With Quote
Old 12-12-2009, 08:22 AM   #5
gasandasphalt
Gnarly Adventurer
 
gasandasphalt's Avatar
 
Joined: May 2007
Location: S/W New Mexico
Oddometer: 472
Try, AF-1 Racing, 699 W. San Antonio Street,, New Braunfels, Texas 78130 Ph. 830 626 3966. they are a big Vespa dealer and Aprilla, etc.



You might check for rust or trash in the fuel system, ?????????
__________________
bad CZECH
gasandasphalt is offline   Reply With Quote
Old 12-12-2009, 08:22 AM   #6
Brooktown Geezer
scooter guy
 
Brooktown Geezer's Avatar
 
Joined: Feb 2009
Location: Fallbrook, CA
Oddometer: 481
Quote:
Originally Posted by harleyd3
yep its 2002 ,,,,,,,,,,i cant get it to run for squat about 12 mph
an i have tried everything that i know to do to get this bike runnin
its been sitting for 7 years,,,,,,,,,so im gonna try new jets
I don't know if you have the Weber carb or the Dell'Orto carb, but I'm about to change my carb, they're around $90. I can't find parts for the Weber anywhere, so I'm just going to replace the whole thing.
Brooktown Geezer is offline   Reply With Quote
Old 12-12-2009, 09:48 AM   #7
harleyd3 OP
jhunt
 
Joined: Jun 2008
Location: middle tennessee
Oddometer: 228
vespa help

mine has the weber carb...............i have cleaned it several times i have soaked it for 48 hrs tried everything i know to do from air filter to plug removed muffler,,,,,this thing will run like a raped ape sittin on the centerstand but dies
when you take it off the centerstand an gas it its like your tryin to pull a train
it has 100 miles on it an sat for 7 years with fuel in it .............if the jets dont work anybody got any suggestions?
harleyd3 is offline   Reply With Quote
Old 12-12-2009, 04:23 PM   #8
gasandasphalt
Gnarly Adventurer
 
gasandasphalt's Avatar
 
Joined: May 2007
Location: S/W New Mexico
Oddometer: 472
Perhaps a mouse built a nest in your exhaust system??? also wasps (mud dobbers), like small places to build their nest.. I had the exhaust vent for my waterheater on my motorhome blocked by mud dobbers to the extent it would not work at all...
__________________
bad CZECH
gasandasphalt is offline   Reply With Quote
Old 12-13-2009, 08:45 AM   #9
Game over
Haha
 
Game over's Avatar
 
Joined: Apr 2009
Location: Texas
Oddometer: 137
American Scooter Center has a malossi packaged Dellorto 17.5mm carb upgrade that will go on your et2.

try them out
1 (800) 97-VESPA
Game over is offline   Reply With Quote
Old 12-13-2009, 09:27 AM   #10
harleyd3 OP
jhunt
 
Joined: Jun 2008
Location: middle tennessee
Oddometer: 228
vespa help

Quote:
Originally Posted by gasandasphalt
Perhaps a mouse built a nest in your exhaust system??? also wasps (mud dobbers), like small places to build their nest.. I had the exhaust vent for my waterheater on my motorhome blocked by mud dobbers to the extent it would not work at all...
i took the exhaust off an checked it for anything that could be restricting it
it was clean ,took off the right side cover an looked at the belt it seamed ok, a guy at the dealer told me that the rings maybe stuck ,but this thing revs like a chainsaw but when you try to take off its like your pulling a train
idels good starts instantly ,ive replaced gas oil sparkplug ,has a hot battery
check the choke ect ,,,,,,,,,,,,,,i finaly found new stock jets in gonna replace them all an see how that goes ,,,,,,,,,,,,,,,,,,,,thanks for your suggestions guys
harleyd3 is offline   Reply With Quote
Old 12-13-2009, 02:36 PM   #11
Brooktown Geezer
scooter guy
 
Brooktown Geezer's Avatar
 
Joined: Feb 2009
Location: Fallbrook, CA
Oddometer: 481
Keep us posted, Harley. I'd like to know how it runs after you change out the jets.
Brooktown Geezer is offline   Reply With Quote
Old 12-17-2009, 08:55 PM   #12
harleyd3 OP
jhunt
 
Joined: Jun 2008
Location: middle tennessee
Oddometer: 228
vespa help

called the dealer to check on the status of my jets today an they tell me that vespa doesnt offer stock jets for the webber carb any longer so sounds like its new carb time any body got any suggestions other than a stock 168.00 carb?
harleyd3 is offline   Reply With Quote
Old 12-18-2009, 12:04 AM   #13
Skippii
Hookers, my lad.
 
Skippii's Avatar
 
Joined: May 2008
Location: Richmond, Va
Oddometer: 6,506
Quote:
Originally Posted by gasandasphalt
...also wasps ....
If that's the case, the thread title also works in Italien.
__________________
"Umm be careful what you say, this is Skippii....
You may get it delivered in the form of a shake or some interperative dance routine that involves nakedness, pizza and a stuffed raccoon..." -DCrider
Skippii is offline   Reply With Quote
Old 12-18-2009, 07:17 AM   #14
pampine
Warrior
 
Joined: Oct 2009
Location: Austin, TX
Oddometer: 147
I wonder if it's the clutch. Have you tried it at higher speeds than starting off? Could it somehow be stuck in 2nd - 4th gear?

Pam
pampine is offline   Reply With Quote
Old 12-25-2009, 01:04 PM   #15
tuf2c
Adventurer
 
Joined: May 2009
Location: ABQ,NM
Oddometer: 54
Pissed

Quote:
Originally Posted by harleyd3
yep its 2002 ,,,,,,,,,,i cant get it to run for squat about 12 mph
an i have tried everything that i know to do to get this bike runnin
its been sitting for 7 years,,,,,,,,,so im gonna try new jets
That's weird. I bought a 2004 GT200L last year from a friend that was in pieces. Her husband disassembled it to build a "racer". After pulling it apart he let it sit in the garage. 4 years later they got divorced and she asked me to put it together for her. The cam, rockers, cylinders, variator, cylinder, drive belt and countless bolts were no where to be found. I assembled it with a Malossi 210 cylinder, Malossi cam, Malossi drive belt and a stock variator.
It did the same thing as yours does. Rev out to the moon on the center stand, but would not go over 50mph on the street. I thought it was jets at first. Being a Keihen carb the jets were easy to find. Stock was a 93. Tried every jet from 80 to 110 and speed, throttle, and acceleration were not affected much.
Then I pondered the exhaust being clogged(wasps, mice or gremlins). I found a Scorpion pipe for cheap and slapped it on. No difference at all, but it was hella louder! Went back to the jets... They didn't help either(even with the pipe).
Triple checked timing and valve adjustment, refilled the gas tank with 91 octane fuel, checked the function of the automatic fuel petcock and fuel pump, removed emissions canister(then reinstalled). Nothing changed.
I decided to try lighter roller weights from Dr. Pulley. The stock is about 10.7grams and I slapped in 9.5 gram weights. It actually now only goes 35. Front and rear variator have no grooves or abnormal wear.
I've cleaned and dunked the carb, checked tire pressure, checked electrical connections, tested the electric choke(ohm output, gasket condition and travel length), swore at it, talked nice to it and polished it. Nothing makes it run right! I have ridden quite a few of these. Every GT would easily do 50mph and have had a few zip up to 80mph on the speedo. This one slowly reaches it's top speed and will not go full wide open with out "staggering".
The last thing I have done with it was put the weight in it and I finally had enough! Put the scooter under a cover and have been riding my 1150GS.
When the spring comes along I am going to pull the wiring harness and see if any mice might have chewed it, replace the Malossi cam with a stock cam and try a different carb from PM Tuning.

Other forums have said to check the drive system after someone has cleaned the carb and no improvement. I would just hate for you to spend as much time and money as I have and be at the same spot as me.
I guess what I am saying is I feel your pain!
tuf2c is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 06:02 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014