ADVrider

Go Back   ADVrider > Bikes > Battle scooters
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 07-13-2010, 04:41 PM   #1
btcn OP
Beastly Adventurer
 
btcn's Avatar
 
Joined: Jul 2010
Location: Morgan Hill CA
Oddometer: 2,880
Elite 150 blown motor

I picked up a 1986 Elite 150 Deluxe last summer to replace my old chinese moped. It ran well in general and only had a couple of small problems, like a bad starter switch and a speedometer problem, which I expected from such an old bike. It had around 10,000 miles on it when I bought it and I put around 5,000 on it so far. I have taken very good care of it. I changed the oil every 900-1000 miles, changed the gaskets and other parts. Then I took it out for a ride on a nice sunny day on the back roads, and all of the sudden when I was cruising at about 45 mph the engine just died, as if the spark plug was cut. It would not even try and start, so I thought there was no spark. I walked it to my garage and tested the spark. It had perfect spark. Next I checked out the carburetor. It was fine and had gas, and the mixture seemed good.

So then I checked out a few other basic things and decided to get deep into the engine. Then I tested compression, which was extremely low at only around 30 PSI! It should be around 184 PSI. Usually compression problems have to do with valves, so I checked out the timing and it was fine. I took off the cover, and the valves were fine and not stuck. The rocker arms were also fine. The chain was good and so was the cam shaft. So then I was thinking it had to be either a worn cylinder, bad piston rings or a worn piston, or a bad cylinder gasket. So I took the whole engine apart and found that the all of these things were fine. The piston rings were good, the cylinder was perfect, the piston was good but could use some cleaning. I have experience with a lot of different engines and motorcycles, but I am still not sure about this engine.

Does any one have any ideas? In the mean time, I bought a lightly used 1987 elite 150 engine off of ebay to through in it. Ill post some pics of the engine soon.
btcn is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 07:22 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014