ADVrider

Go Back   ADVrider > Gear > Equipment
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 12-05-2011, 10:29 AM   #1
Jaimoto OP
Beastly Adventurer
 
Jaimoto's Avatar
 
Joined: Sep 2007
Location: Santiago, Chile
Oddometer: 1,205
New scala rider G4 won't turn on

I bought a scala rider G4 powerset a couple of weeks ago. Installed the latest software in both units and they were connected with a Blackberry (mine) and an Iphone (a friend). Everything was working fine and the only function that we didn't use was the Voice Dial.

Two days ago, both scala rider stopped working, no matter during how much time we press the Mobile button, they just don't turn on. Yep, both. Almost at the same time

They show a solid red light while charging but that's all they do.
It sounds stupid but .. both units stopped working after we use the Voice Dial function. it looks like a software failure but I just can't believe they won't work because of using one of its functions.

I already emailed Cardo so hopefully the'll take care of me. Meanwhile, I would like to know if any of you had a similar problem and how did you fix it.

Thanks!
__________________
Jaime

2007 KTM 990 Adventure
2012 Yamaha BWs 125
Jaimoto is online now   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 10:21 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014