ADVrider

Go Back   ADVrider > Bikes > Road warriors
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 01-29-2012, 10:08 AM   #11
keenerkeen
Adventurer
 
keenerkeen's Avatar
 
Joined: Mar 2009
Oddometer: 74
Quote:
Originally Posted by KEN PHENIX View Post
I read about it on the Suzuki forums - not all that common though. At around 74k my bandit started puffing a tiny bit of smoke upon cold startup - most likely valve stem seals. I'm sure it would have been fine but I had a trip planned and rather than do the seals and timing chain tensioner I found a 2k-mile Katana motor for $500 and dropped it in. Problem solved.
Not sure on the years but i think the 2000/2001 BANDIT 12 had a change made in the piston rings in a misguided effort from Suzuki to aid in cooling ...Many burned some oil because of this ..the fix was going back to the original rings used in the previous bikes 98,99, which ran a little tighter..
keenerkeen is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 12:06 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014