ADVrider

Go Back   ADVrider > Bikes > Hacks
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 08-25-2012, 04:38 PM   #11
pecos
BAM!!
 
pecos's Avatar
 
Joined: Jun 2006
Location: Big D, TX
Oddometer: 504
Glad to see this thread started. I just installed my dauntless mounts last night on my 06 t100.. Connected the california sidecar this morning. Just took my first trip around the neighborhood 30 minutes ago.

I am in the early stages of discovery. The bike has plenty of power to haul my big self.

Since I have nothing to compare it to I am trying to figure out if any furture alignment is needed. I am reading some manuals and watching youtube to understand the functionality. The main thing I do need to get is a steering dampner. I did experience a little head slap from the front wheel.

When my old man came over this morning to help connect the car one of the first things he pointed out was the bolts hanging low on the front mounts.
pecos is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 02:16 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014