ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 11-08-2012, 11:28 AM   #11
matloik
kludge
 
matloik's Avatar
 
Joined: May 2008
Location: PDX | Hood River
Oddometer: 1,225
Quote:
Originally Posted by pyoungbl View Post
Hummm, my '10 model went from a quick start (like maybe 1 revolution of the crank) to totally dead; three times. I never had a time when the starter was working hard. That's not to discount the 'decompression lever' issue but the OEM batteries have been an issue for at least 10 years, the lever...not so long. Full disclosure: I have upgraded the ground wire from battery to engine case because that is a critical part of the electrical system and appeared to me to be too small.
Yes, agreed, the OEM battery is not the best. But those replacing it with a stronger battery should be aware that that stronger battery MAY be hiding an underlying issue that should get resolved, if in fact they are also experiencing the "hot start issue". Coincidentally my '08 KTM EXCR also has a known issue with a faulty decompression mechanism, that is on the cam. The '09 cam fixes this. I have not fixed this (yet), but am getting by for now with a better battery that has more oomph to get past compressed TDC. But kickstarting is very difficult--that is what your battery/starter is working against, and may be the reason an OEM battery degrades quicker--and then when you bring it into BMW they replace the battery because it tests bad.
__________________
'08 Versys & '08 450 EXC-R / '11 G650GS & '06 KLX250S (wife's)
Portland Area Off Pavement Rides ~ Hood River Rides ~ Vancouver Island Trip
matloik is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 09:03 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014