ADVrider

Go Back   ADVrider > Gear > The Garage
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 11-08-2012, 04:25 PM   #1
jesse v OP
Motorcyclist
 
jesse v's Avatar
 
Joined: Apr 2011
Location: Sioux Falls, SD
Oddometer: 205
Brakes binding after I cleaned 'em

Just cleaned my front calipers as per this video:

http://www.youtube.com/watch?v=FNz00OTRLzM


I did this last week on my wife's 650 and everything went OK. Brakes feel better, engage more linearly, etc. Tried it with my 1k tonight, and now my brakes bind BAD. Prior to cleaning, there was a little bit of rubbing.

Any ideas? At one point in the cleaning, I accidentally pushed out one of the pistons so far it was crooked (almost fell out). Could this have caused something?

I'm planning on riding through the Loess Hills tomorrow so this is really bumming me. Hopefully I can fix it tonight. Your help is much appreciated
__________________
everybody lies
My band: June Embers
jesse v is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 04:32 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014