ADVrider

Go Back   ADVrider > Bikes > Trials
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-10-2012, 05:01 AM   #16
bads1buell OP
n00b
 
Joined: Jun 2011
Oddometer: 8
I was told by Scott at Moto Connection that the case problem was only on the 03-08 Rev3 models as they were made of magnesium. The Techno cases are made of aluminium, but who knows worth a look anyways.
bads1buell is offline   Reply With Quote
Old 11-10-2012, 05:13 AM   #17
lineaway
Beastly Adventurer
 
Joined: Oct 2011
Location: nm
Oddometer: 1,774
Quote:
Originally Posted by bads1buell View Post
I was told by Scott at Moto Connection that the case problem was only on the 03-08 Rev3 models as they were made of magnesium. The Techno cases are made of aluminium, but who knows worth a look anyways.
Yeah the zero`s had some mag cases too, with problems. Can`t recall any problem before that? Oh yeah, air cooling. Ha! Ha!
If you are having cooling problems never overlook the water pump. Have seen many a failed impeller and/or shaft.

Actually the techno had a small piece that held the return spring or something with the shifter pawl that would break off the left center case.

lineaway screwed with this post 11-10-2012 at 05:53 AM
lineaway is offline   Reply With Quote
Old 11-10-2012, 06:44 AM   #18
Happy Seal
Beastly Adventurer
 
Happy Seal's Avatar
 
Joined: Mar 2010
Location: CT.
Oddometer: 2,525
Quote:
Originally Posted by lineaway View Post
Before you check the case. Have you bypassed the thermostat? Hooked a battery to the fan to make sure it starts on it`s own. A lot of time when the fan is starting to go, it is intermitent. You can tell once it is getting warm , you can push start the fan with your finger.
But yes to check the waterpump, just drain the coolant(if there is any). There is a vent screw on top of the raditor, then just remove the water pump cover. It is usually pretty obvious from there. Hope you sort it out!
Thanks for the info.
__________________
with his videos I've been able to crash into trees even faster than before. ( Darius re Shane Watts)
Happy Seal is offline   Reply With Quote
Old 11-10-2012, 06:52 AM   #19
Happy Seal
Beastly Adventurer
 
Happy Seal's Avatar
 
Joined: Mar 2010
Location: CT.
Oddometer: 2,525
Quote:
Originally Posted by bads1buell View Post
I was told by Scott at Moto Connection that the case problem was only on the 03-08 Rev3 models as they were made of magnesium. The Techno cases are made of aluminium, but who knows worth a look anyways.
I know and trust Scott so that is good news I guess!

Bought a 2010 Beta RR from him.
__________________
with his videos I've been able to crash into trees even faster than before. ( Darius re Shane Watts)
Happy Seal is offline   Reply With Quote
Old 11-10-2012, 06:53 AM   #20
Happy Seal
Beastly Adventurer
 
Happy Seal's Avatar
 
Joined: Mar 2010
Location: CT.
Oddometer: 2,525
Quote:
Originally Posted by lineaway View Post
Yeah the zero`s had some mag cases too, with problems. Can`t recall any problem before that? Oh yeah, air cooling. Ha! Ha!
If you are having cooling problems never overlook the water pump. Have seen many a failed impeller and/or shaft.

Actually the techno had a small piece that held the return spring or something with the shifter pawl that would break off the left center case.
Great, do I have to check this now?
__________________
with his videos I've been able to crash into trees even faster than before. ( Darius re Shane Watts)
Happy Seal is offline   Reply With Quote
Old 11-12-2012, 03:44 PM   #21
Happy Seal
Beastly Adventurer
 
Happy Seal's Avatar
 
Joined: Mar 2010
Location: CT.
Oddometer: 2,525


Well, I found the overheat problem. The impeller is cracked and one fin is all the way gone. I don't see any holes or cracks in the housing but I really am not sure where to look exactly. Not trying to hijack OP's thread.
__________________
with his videos I've been able to crash into trees even faster than before. ( Darius re Shane Watts)
Happy Seal is offline   Reply With Quote
Old 11-12-2012, 05:25 PM   #22
lineaway
Beastly Adventurer
 
Joined: Oct 2011
Location: nm
Oddometer: 1,774
Yes you don not have a corrision problem, jst a little no flow problem. Did the impellor even sin properly?
lineaway is offline   Reply With Quote
Old 03-07-2013, 02:50 PM   #23
Qwik
Two Wheeled Addict
 
Joined: Apr 2008
Location: Sunnyvale, California
Oddometer: 5,814
Sorry to bring up an old thread but I am being offered a Beta Techno 290 in exchange for a set of KTM 950 Heads/cams. Its in Immaculate condition. Low Hours/Miles. Basically about $1,000 worth of parts.
__________________
Speed bumps never seem to make me go any faster
Qwik is offline   Reply With Quote
Old 03-07-2013, 03:18 PM   #24
joe cool
Studly Adventurer
 
joe cool's Avatar
 
Joined: Aug 2004
Location: southwest,ohio
Oddometer: 859
I would say that's a good deal. displacement should be 270 not 290.
__________________
"One more day I find myself alive
Tomorrow maybe go beneath the ground"
Garcia/Hunter
joe cool is offline   Reply With Quote
Old 03-07-2013, 03:33 PM   #25
DrKayak
Retro Rider
 
DrKayak's Avatar
 
Joined: Mar 2010
Location: Shingle Springs CA
Oddometer: 667
Only the 1999 Techno was available as a 270. All the older Techno were 250cc. I paid $1,000 for my 96 Techno with title and Green Sticker. Which is a good deal. If you watch CL most 90s well used trials bikes are listed closer to $1,500.

I have had a ton of fun with it for a fraction of the maintenance as a KTM.

Be adviced Beta did not follow DMV VIN number standards. It can be impossible to get a OHV sticker for one with no title.

I would be intereted in buying it if you want to make a quick buck .
__________________
2011 690 Enduro R
2013 Beta Evo
07 450 EXC
04 FZ1
DrKayak is offline   Reply With Quote
Old 03-07-2013, 07:07 PM   #26
Qwik
Two Wheeled Addict
 
Joined: Apr 2008
Location: Sunnyvale, California
Oddometer: 5,814
Thanks.
__________________
Speed bumps never seem to make me go any faster
Qwik is offline   Reply With Quote
Old 03-08-2013, 10:04 PM   #27
lineaway
Beastly Adventurer
 
Joined: Oct 2011
Location: nm
Oddometer: 1,774
The `98 beta came out with a 280. They were late, so the first order had a 250 with the 280 cylinder, piston and head included in the crate. I made a `96 with this kit `just because I had it`. So it is possible. Beta never had a 290 till the EVO.

lineaway screwed with this post 03-09-2013 at 07:07 AM
lineaway is offline   Reply With Quote
Old 03-19-2014, 09:33 AM   #28
cr37
n00b
 
Joined: Jan 2011
Oddometer: 1
Techno

I have a 97 Techno and the only way it starts if the throttle is wide open, and also when riding up a hill it will stall out? I'm thinking it's all connected? or may be a float level issue, does anyone know what the float level is?
Thanks
cr37 is offline   Reply With Quote
Old 03-21-2014, 03:51 PM   #29
DrKayak
Retro Rider
 
DrKayak's Avatar
 
Joined: Mar 2010
Location: Shingle Springs CA
Oddometer: 667
Quote:
Originally Posted by cr37 View Post
I have a 97 Techno and the only way it starts if the throttle is wide open, and also when riding up a hill it will stall out? I'm thinking it's all connected? or may be a float level issue, does anyone know what the float level is?
Thanks
http://www.mikuni.com/pdf/vmmanual.pdf


I does not sound like a float level issue to me. Too high of a float level and the carb overflows. Too low and you starve for fuel when you hold it wide open too long. I would pull the cab and clean it and check your jet sizes. Did it ever run right? I have had great luck running a 30 pilot and 145 main.
__________________
2011 690 Enduro R
2013 Beta Evo
07 450 EXC
04 FZ1
DrKayak is offline   Reply With Quote
Old 03-21-2014, 05:30 PM   #30
lineaway
Beastly Adventurer
 
Joined: Oct 2011
Location: nm
Oddometer: 1,774
The starting problem is likely a plugged pilot jet. But while you are in there check everything including the choke. Jet size will vary by elevation. 3000-5000 140. 5000-7000 135, 8000 = 130. Good luck!
lineaway is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 03:55 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014