ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 11-14-2012, 07:04 PM   #11
Shercoman
Gnarly Adventurer
 
Joined: Jul 2008
Location: Pine,Colorado
Oddometer: 457
Quote:
Originally Posted by Travrsx View Post
Love this thread... Not sure if I posted here before, but if not, I have a good excuse.

Look what followed me home today... BW200 with electric start. Of course it doesn't run, and is ratty as all hell. But, I paid next to nothing for it. It will be my third big wheel, I have two BW80's.

I was celebrating my victory, rolling it down my ramps out of the truck...... When the front brake seized up. The cable is so old that it won't move.

This is going to be fun!

That's in pretty good shape and it looks like all the parts are there.You're starting out much farther along than many on this thread!
Doesn't look like many miles either.That back tire looks pretty fresh if it's original.
You'll have a hoot with it!
Shercoman is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 08:30 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014