ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 01-03-2013, 05:34 PM   #1
travelin' light OP
Wannabe adventurer
 
travelin' light's Avatar
 
Joined: Jan 2012
Location: between Belgium & Spain
Oddometer: 15
Eh? Failed water pump seal opinions please

Hope that you guys will help me with a little problem I am pondering over.

Recently purchased an 06 990 adventure With 33k Kilometres. Service history was a bit patchy. Lots of receipts and warranty jobs done at a KTM dealer with a dodgy rep. It had its last major at 31k but as I plan to take it to Africa next week (no pressure) and even though the bike was running well, I thought I'd do some PM and do the usual stuff that may give problems. stripped her and did the valves, all were within spec. Then replaced the water pump shaft, seal, both bearings and impeller. When I took off the inner clutch cover it was apparent that there was coolant in the oil. To me it seems likely that the pump seal had weaped through to the oil, or at least this seems more likely than a head gasket. I haven't noticed any coolant loss, but have only done 600 Km's on the bike. So I drained the oil, but I did this when the engine was cold, as I really hadn't planned to change 2000 km old oil. The oil filter has slight waves in it, so I don't think this has been leaking for long, but there are large white globs from the coolant in the drained oil. So here is my question (if you read this far, thanks for your perseverance!). As I drained the oil cold and there is clearly going to be a fair amount of contaminated oil in the engine, should I;

Fill with cheap oil of the appropriate grade, run the bike to temp without an oil filter, drain the oil again and full with Motorex?

Or

Go with the Motorex straight off and run it for the next 7500 km's?

What do you think? Are there any alternatives to either of the above? Any guidance much appreciated.
travelin' light is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 11:23 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014