ADVrider

Go Back   ADVrider > Gear > The Garage
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-11-2013, 11:54 AM   #1
sparkymcgee OP
Gnarly Adventurer
 
sparkymcgee's Avatar
 
Joined: Aug 2008
Location: Southern California
Oddometer: 335
Grip Heater Fuse Blowing

I have these:



http://www.aerostich.com/arctic-grip-heaters.html

Installed on my KLR650 and my VFR800 via relays. I've never had issues on the VFR and use a 5 amp fuse (I think).

I installed them on the KLR with a 5 amp fuse and was fine for months, but now whenever I switch from off to high or low with power on, the fuse blows. I went up to a 10 amp fuse and still the same issue. As long as I don't toggle the switch while the bike is powered, I'm fine...so I have to choose my setting before starting the bike. I forgot yesterday and blew the fuse and had to ride home with chilly wittle fingers :(

Any ideas?
__________________
2008 VFR800
2012 Super Ténéré
sparkymcgee is offline   Reply With Quote
Old 01-11-2013, 12:23 PM   #2
OTB
Oh fer Chrissakes
 
Joined: Feb 2004
Location: Rio de Las Animas Perdidas
Oddometer: 7,279
Your switch is shorting out.
__________________
He not busy being born is busy dying
OTB is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 06:44 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014