ADVrider

Go Back   ADVrider > Gear > The Garage
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 01-24-2013, 10:03 PM   #1
dorkpunch OP
Oops...
 
dorkpunch's Avatar
 
Joined: Aug 2006
Location: Blackfoot, ID
Oddometer: 4,941
Power Steering Question...

So the return line on my wifes car ('92 Olds Cutlass Supreme) was leaking. Power steering has been working totally 100% fine, other than it marking its spot in the driveway... The return line is really long mostly metal tubing, with a short section of rubber. It was leaking at the rubber section. I put a "band aid" fix by cutting out the leaking section of rubber hose and putting some high pressure hose over the metal tubing with double clamps. Worked great, no leaks... BUT.

Now the power steering intermittently gets stiff- mainly at low speeds if you're trying to turn sharp. Sometimes its fine, sometimes its not. I've tried the whole bleeding thing- turning it back and forth a little, or a lot. Doesn't seem to change anything. Its fine one minute, then stiff the next. It does feel too hard to turn most of the time.

Any suggestions?!
__________________
http://www.mobilemrt.com http://www.dorkpunch.com

"I've been going to this high school for SEVEN YEARS. I'm no dummy!"
-Charles De Mar.
dorkpunch is online now   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 12:17 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014