ADVrider

Go Back   ADVrider > Gear > The Garage
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 03-17-2013, 09:29 AM   #1
Ducs2Dirt OP
Not quite all there
 
Ducs2Dirt's Avatar
 
Joined: Jul 2010
Location: CT
Oddometer: 168
Mounting Big Blocks help...

Im in the midst of "trying" to spoon on some Kenda Big Blocks on my R1100 rims. I got the old tourance off the rear rim in under 5 minutes....easy as pie.

I got the Big Block and got it halfway on with very little effort. But im completely stuck trying to get the last half of the tire on the rim. Initially I tried it yesterday in the garage, but it was cold here yet. So i brought the tires in for the night to warm up. I just gave it another go (indoors) and it is impossible. I dont have a tire changer, just the ole blood, spoons, sweat and tears method. It just seems that tire has NO give at all and is almost too small. ( yeah its the right size ) If i get the tire say 3/4's of the way on, the last bit of tire has like a solid inch and a half to go yet before it can even attempt to hop over the rim.

At this point, im thinking the tire is shot. It started to tear even from just trying to spoon it over the rim before. (not bad....ill get a pic) THe last attempt before i gave up just now i thought i heard tearing/stretching ( or maybe that was some muscle tearing in my arms).

I got the rim and tire lubed up with tire gobs of tire mounting lube, so it should just slip right on, like when i did my Anakee 3's on the 1200 GSA a few weeks back.

Any tips or should I just throw in the towel and bring em in someplace?
__________________
2011 1200 GSA
1995 1100 GS (sold)
2013 S 1000 RR
Ducs2Dirt is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 09:27 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014