ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 01-17-2008, 10:52 AM   #1
cjracer OP
AWD please!!
 
cjracer's Avatar
 
Joined: Sep 2005
Location: Mukwonago, WI
Oddometer: 3,951
950 S-new look, new mods, new year

It's 2008,

My 06 950 ADV has been a great bike for trips, commuting and misc screwing around. No regrets. Thanks to all the help from the great members on ADVrider my 950 has been transformed...some good, some not so good. Learning all the time, none the less. This WI winter season has been pretty poor for riding. We got dumped on w/ snow early in Dec. and we've been getting snow/sleet/rain off and on since then. Last year I was able to ride most of the winter, but this year the roads never dried up long enough to be safe from ice. My plan for this winter was to go through the bike and give it a once over. It's been through a lot this past year. It deserved some TLC. A week into it, the opportunity to head back to Mexico popped up again, so the complete tare down has been postponed, it's just getting a good look over now.

It started w/ an oil change. Then I figured I have the time and all the posts about water pump issues finally got to me. Last year at about 10,000 miles one of the coolant hoses sprung a small leak so the system has been drained and flushed under warranty. I went to order parts but the stuff was back ordered from KTM. Willnevergrowup came to the rescue w/ a full rebuild kit, so I took that on. Thanks.


Figured almost 30,000 miles, so what the heck. At least now it has the updated parts and I have some piece of mind.

The shaft was scored and the seal lip surface had some darkening to it, almost like it was burnt. Thanks to Pyndon's great rebuild report, that service was no problem. I checked the bearings and they were fine so I just swapped the shaft and seal. "If it ain't broke don't fix it" I'll change those in the next 30,000 miles...maybe.

BTW, We have a BMW 1999 F650 in the stable too. Last year it blew a head gasket so I looked it's entire cooling system over. Sure enough, at about 12,000 miles it's shaft was scored and need replacing too. Looked just as bad as the KTM's. The BMW parts were much more $$$ than the KTM replacements so I made my own shaft, we'll see how long that holds up. 3,000 miles and still going. So there...It's not just KTM's.

Next project I was into was adding the tripmaster switch, but I did my own kit from a post on ADVrider.

I used this one.

http://www.advrider.com/forums/showt...ht=mode+switch

But this one the most.

http://www.advrider.com/forums/showt...o+shack+switch

Post #7 Jaydee1445 mentions the smaller swtich from Radio Shack. That's these. Thanks Jaydee.
"radio shack PN 275-1571"

I don't like taking my hands off the bars to toggle through the functions, we'll see how this hold up in the long haul. So far so good. Looks stock.






UPDATE: 7-30-11
I now have 95,000 on the bike and these buttons are still working great. My MODE button on the Instrument no longer works though..... :/
__________________
My 2006 950S thread. 2006 950s update
New product updates here! Wordpress BLOG
click www.cjdesignsllc.com for the full line of products. FREE STUFF!!

cjracer screwed with this post 07-31-2011 at 10:26 AM
cjracer is offline   Reply With Quote
 

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 04:10 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014