ADVrider

Go Back   ADVrider > Bikes > Old's Cool
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-13-2004, 02:53 PM   #1
Jman OP
a.k.a. FUglyK
 
Jman's Avatar
 
Joined: Aug 2003
Location: Land of Flat and Straight EH !
Oddometer: 891
HELP - K75 Fuel Pump Hum ?

Help !!!

I was just riding home from work and noticed a hum (buzz ? mmmmmmm sound) coming from the front of the bike that was never there before. It is noticeable (to me at least) with the helmet on and going down the road. Speed does not seem to affect the intensity of the sound. If I stop the sound continues, nothing seems to alter this hum.

I put the bike up on the center stand and listened all over the bike and if I put my ear to the tank I hear it louder. The other thing that I notice which has never been there before is also a few drips on the driveway that smell like gas and seem to be coming from the vent hose that hangs down behind the right riders foot peg.

Is something clogged? Is my fuel pump shot? The bike only has 47,000km on it. The only reason I am peaked at the moment is I am scheduled to leave a week from today for five days on the Blue Ridge and I don't really have the cash to spend at the dealer to get this fixed. The fuel filter has about 8,000km on it.

Any help you could provide would be greatly appreciated.

Thanks.
__________________
I love scotch. Scotchy, scotch, scotch.
Here it goes down, down into my belly...
Jman is offline   Reply With Quote
Old 05-13-2004, 04:40 PM   #2
Davo
BMW Uber alles
 
Davo's Avatar
 
Joined: Feb 2004
Location: Melbourne, Australia
Oddometer: 142
Wicked The K75 pump is quite loud.

How long have you owned this bike for? Do you normally ride with plugs? Lets rule out the possibility that you have been unobservant in the past (its amazing the things I have been oblivious of and then suddenly notice and thought how the hell could you miss that (eg some of my spouses character traits (no really I love her))) and work with the likely cause. Without hearing the sound but with the way you describe it sounds like you have one of two things 1. Almost no fuel in the tank (which makes the pump very loud and resonate nicely in the fuel tank or 2. A chunk of crap which has not quite managed to choke the pump completely but is making its life difficult. Go by the manual as far as removing the tank, gas filler mouth then the pump itself. No smoking please and take care of the rubber on the bottom of the pump and the filter gauze. It’s easy to tear. When my 75 did this it blew the fuse so replaced it, did the above and connected the pump straight to the battery for a couple of seconds and lightly tapped the unit with filters off to get rind of the FOD. Worked well and on my way. Stress not on you trip as all this can be done in daylight hours on the side of the road in under an hour. Make sure you carry some spare fuses as they will give up before the pump will. P.S. the pumps are bloody expensive so unless you have deep pockets I would not think about carrying a spare pump. They are very robust units. P.S.S. replace the fuel filter while you are in there as getting petrol all over you sucks even if you feel rather blissful while you are doing it.
__________________
stone cold sober
Davo is offline   Reply With Quote
Old 05-13-2004, 07:03 PM   #3
Jman OP
a.k.a. FUglyK
 
Jman's Avatar
 
Joined: Aug 2003
Location: Land of Flat and Straight EH !
Oddometer: 891
Thanks for the hint Davo. I will take the pump out this weekend. I have had the bike just shy of 2 years. The tank is 2/3 full which is why the sound caught my attention.

Pump is expensive? What part on this damn thing isnt?

Thanks again.
__________________
I love scotch. Scotchy, scotch, scotch.
Here it goes down, down into my belly...
Jman is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 12:36 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014