ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-19-2009, 10:26 AM   #1726
MuddytheWaters
Petrol Burner
 
MuddytheWaters's Avatar
 
Joined: Jun 2009
Location: Austin
Oddometer: 8
Thumb Thanks Mates

Thanks to all for the shoulder slapping, mates. I told the boys about the foreign battery recalls and stuff that I read about here on AdvRider and they didn't seem to care; these blokes are quite daft ; I asked about a loaner bike and there was this silence on the other side of the line like I asked them for their friggen' car keys. But last I heard she was on the lift and getting attention. So I'll just wait until Tuesday to hear anything. I'm lucky my flat-mates and I all work at the same internship with pretty much the same hours.

Good luck OneMoreOkie. That is ridiculous, not even *I* was in that kind of situation. Where you ride outta of? I'm a Stilly boy myself before I moved down to Austin Tejas. I remember though when I was in HS in Broken Arrow going down to Atlas Motors in T-Town and drooling over the R1200C's.
MuddytheWaters is offline   Reply With Quote
Old 07-19-2009, 10:26 AM   #1727
5Chord
No Short-Term Memory
 
5Chord's Avatar
 
Joined: Jul 2008
Location: Westchester, NY
Oddometer: 1,037
Oh shit
Attached Images
 
5Chord is offline   Reply With Quote
Old 07-19-2009, 10:31 AM   #1728
5Chord
No Short-Term Memory
 
5Chord's Avatar
 
Joined: Jul 2008
Location: Westchester, NY
Oddometer: 1,037
Under view......Luckily for me, the secondary oil nut(?) was just loosened by its impact with the steel rail. A quick turn of a 22mm wrench (NOT included in my toy-tool pak) and I was on my way.
Attached Images
 

5Chord screwed with this post 07-19-2009 at 11:00 AM
5Chord is offline   Reply With Quote
Old 07-19-2009, 10:34 AM   #1729
plumber mike
Soaking up Son shine
 
plumber mike's Avatar
 
Joined: May 2009
Location: Right here, right now
Oddometer: 2,709
5Chord pulled a plumber mike

I can definitely relate. Mine is still in the shop. I would call your insurance company as a new engine case is expensive.
plumber mike is offline   Reply With Quote
Old 07-19-2009, 10:35 AM   #1730
5Chord
No Short-Term Memory
 
5Chord's Avatar
 
Joined: Jul 2008
Location: Westchester, NY
Oddometer: 1,037
Quote:
Originally Posted by onemoreokie
Well....after a relatively long spell of good luck the X left me stranded again. It wouldn't hold an idle. This problem has haunted the bike since delivery. Kept telling myself it was me touching the throttle during start up procedure but that is definately not the case. Today I even left the bike alone for 45 min and tried to fire her up again. The only way home was to keep RPM above 2500 or more or she'd die. That was a pain running through town.

It's back to the dealer on Monday but I'm guessing it may be the same response. It works for us and didn't throw any codes......
I love the bike but this is frustrating to have no confidence in it mechanically.

Ok done venting! I feel better now.
Unhook-rehook the battery and try it again. That should reset the computer and may solve the problem if you're lucky. Nothing to lose right?
5Chord is offline   Reply With Quote
Old 07-19-2009, 10:55 AM   #1731
onemoreokie
Adventurer
 
Joined: Dec 2008
Oddometer: 28
Well I just went back out an it fires and idles perfectly.
Now what....I don't want to take it to the dealer and hear the same thing.
Hmmm.
onemoreokie is offline   Reply With Quote
Old 07-19-2009, 10:57 AM   #1732
onemoreokie
Adventurer
 
Joined: Dec 2008
Oddometer: 28
Quote:
Originally Posted by MuddytheWaters
Thanks to all for the shoulder slapping, mates. I told the boys about the foreign battery recalls and stuff that I read about here on AdvRider and they didn't seem to care; these blokes are quite daft ; I asked about a loaner bike and there was this silence on the other side of the line like I asked them for their friggen' car keys. But last I heard she was on the lift and getting attention. So I'll just wait until Tuesday to hear anything. I'm lucky my flat-mates and I all work at the same internship with pretty much the same hours.

Good luck OneMoreOkie. That is ridiculous, not even *I* was in that kind of situation. Where you ride outta of? I'm a Stilly boy myself before I moved down to Austin Tejas. I remember though when I was in HS in Broken Arrow going down to Atlas Motors in T-Town and drooling over the R1200C's.
I'm in Edmond but a stillwater grad myself. I love Austin! The music seen there is insane.
onemoreokie is offline   Reply With Quote
Old 07-19-2009, 11:01 AM   #1733
5Chord
No Short-Term Memory
 
5Chord's Avatar
 
Joined: Jul 2008
Location: Westchester, NY
Oddometer: 1,037
Quote:
Originally Posted by plumber mike
I can definitely relate. Mine is still in the shop. I would call your insurance company as a new engine case is expensive.
Did you break an engine case too?? I thought it was just your frame. Could you post or PM me the link for the hard parts?
5Chord is offline   Reply With Quote
Old 07-19-2009, 01:07 PM   #1734
plumber mike
Soaking up Son shine
 
plumber mike's Avatar
 
Joined: May 2009
Location: Right here, right now
Oddometer: 2,709
Yeah! I do it up right PM MTDewX8 for the hard parts. I still need to order my skid thru Andrewgore.
plumber mike is offline   Reply With Quote
Old 07-20-2009, 10:25 AM   #1735
slide
A nation in despair
 
Joined: Jul 2003
Location: NM, USA
Oddometer: 21,122
Stranded Again

Well, my x-c stranded me again. this time far away making for a very exciting time sitting in the sun getting dehydrated roughly 140 miles from home.

I guess this time I get to see if BMW roadside assistance really works because this time I can't push it back. I'm pretty disgusted.

Same problem as last time - battery went dead flat and won't hold a charge. Thus no start after a stop. Bump unsuccessful. Ironically, the bump was supplied by two guys in a pickup who passed by & stopped. They had Hondas in their pickup bed & suggested that this sort of stuff doesn't occur with a Honda. That cheered me up. I saw the problem this time was the same as last time after after pulling the battery, hiking to a place which had a charger and watched as the second battery followed the first to Hell.

So my shiny BMW is now chained to a fence up on the CO / NM border. Great.
slide is offline   Reply With Quote
Old 07-20-2009, 10:41 AM   #1736
muddyrabbit
Lost Boy
 
muddyrabbit's Avatar
 
Joined: Aug 2007
Location: Fugawee Land.
Oddometer: 3,760
Well we went to DC for the weekend, left Thursday night. Got 7 miles from home and the bike dies going down the road, no warning. Sooo, WTF??? Turned out she was out of gas and the low fuel light has stopped working. So there we stood, out of gas, and my two 1.5L fuel bottles were both empty. We walked to the Amish farm we were in front of and bought a gallon from him. Hell of a start to a road trip...
muddyrabbit is offline   Reply With Quote
Old 07-20-2009, 10:58 AM   #1737
andrewgore
Team MGH
 
andrewgore's Avatar
 
Joined: May 2008
Location: NW Suburbs, IL
Oddometer: 3,335
My curiosity is peaking now. I've read many stories of xCountry guys being left stranded due to unknown electrical gremlins. I'm going to go back and read through the xChallenge thread to see if it is similar, or if there is something different between the bikes. Maybe it would be a good idea if we started a G650X Electrical Issue thread? Something with the following:

Model: (xCountry, xMoto, xChallenge)
Year:
Mileage at time of issue:
Modifications (if any):
Resolution (if any):
Description of Failure(s):

How would something like that sound? It'd be a good catalog for those to go through if they are having an issue, and what if any fix they or the dealer were able to come up with.

Andrew
andrewgore is offline   Reply With Quote
Old 07-20-2009, 12:27 PM   #1738
catdander
catdander
 
Joined: Sep 2008
Oddometer: 44
good idea gore. i've not had any prob but...interested in what's what with our bikes.
catdander is offline   Reply With Quote
Old 07-20-2009, 12:48 PM   #1739
5Chord
No Short-Term Memory
 
5Chord's Avatar
 
Joined: Jul 2008
Location: Westchester, NY
Oddometer: 1,037
Quote:
Originally Posted by andrewgore
My curiosity is peaking now. I've read many stories of xCountry guys being left stranded due to unknown electrical gremlins. I'm going to go back and read through the xChallenge thread to see if it is similar, or if there is something different between the bikes. Maybe it would be a good idea if we started a G650X Electrical Issue thread? Something with the following:

Model: (xCountry, xMoto, xChallenge)
Year:
Mileage at time of issue:
Modifications (if any):
Resolution (if any):
Description of Failure(s):

How would something like that sound? It'd be a good catalog for those to go through if they are having an issue, and what if any fix they or the dealer were able to come up with.

Andrew
I would certainly contribute! Oh and Andrew, I found out I REALLY need a bash plate (powder-coated black) Do you think my H&B enginge guards (or hard parts) are going to be an issue with it?
Attached Images
 
5Chord is offline   Reply With Quote
Old 07-20-2009, 01:15 PM   #1740
onemoreokie
Adventurer
 
Joined: Dec 2008
Oddometer: 28
Quote:
Originally Posted by andrewgore
My curiosity is peaking now. I've read many stories of xCountry guys being left stranded due to unknown electrical gremlins. I'm going to go back and read through the xChallenge thread to see if it is similar, or if there is something different between the bikes. Maybe it would be a good idea if we started a G650X Electrical Issue thread? Something with the following:

Model: (xCountry, xMoto, xChallenge)
Year:
Mileage at time of issue:
Modifications (if any):
Resolution (if any):
Description of Failure(s):

How would something like that sound? It'd be a good catalog for those to go through if they are having an issue, and what if any fix they or the dealer were able to come up with.

Andrew

I'll contribute as well.
onemoreokie is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 04:54 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014