ADVrider

Go Back   ADVrider > Riding > Regional forums > Southeast, The Lair of the Dragon - The Blue Ridge and Smoky Mountains
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-23-2014, 06:11 AM   #1
CH47Rider OP
Adventurer
 
CH47Rider's Avatar
 
Joined: Aug 2009
Location: Fayetteville, NC
Oddometer: 44
Buell Broke in West Atlanta-Need Mechanic

Hi guys,
Just moved to Atlanta (Mableton actually) and my Uly has that ignition relay buzzing and no starting problem. I'll wiggle some more wires before I take it in, but I'm not optimistic. Electricity scares me. Anyone got a good Buell mechanic in the area? Willing to drive to get someone that will get it right the first time.
Thanks,
Keith
__________________
Anything is better than the dead calm of indifference. Our souls may wisely desire the north wind of trouble if that alone can be sanctified to the drawing forth of the perfume of our graces.-C.H. Spurgeon
CH47Rider is offline   Reply With Quote
Old 10-23-2014, 07:43 AM   #2
dean-o
Dabs often
 
Joined: Sep 2005
Location: old hickory,tn
Oddometer: 819
Post over at badweatherbikers.com too

Good luck - I'm up in old hickory, tn - near Nashville .
Dean
615 545 1111 texts ok
dean-o is offline   Reply With Quote
Old Yesterday, 05:42 AM   #3
Dukerdr
New old guy
 
Dukerdr's Avatar
 
Joined: Jan 2013
Location: McKenzie, Tn
Oddometer: 135
I asked a friend of mine last night if he knew of anyone in Atlanta that was a good Buell mechanic, since he rides a Buell.

He messaged back overnight and said he couldn't help, but he could provide the name of a couple of shitty ones.

I know that doesn't help, but it was funny this morning...
.
__________________
Dukerdr - pronounced Duke-rider....
Dukerdr is offline   Reply With Quote
Old Yesterday, 06:30 AM   #4
NitroAcres
MotoBiggots Suck
 
NitroAcres's Avatar
 
Joined: Mar 2010
Location: A ChickenHouse in NorthGeorgia
Oddometer: 501
My S1 made that noise when the battery was low..hooked it to a charger, jumped it off and it worked a day or two...New battery fixed it good..YMMV
__________________
Britt Lynn
NitroAcres
Ball Ground Ga
NitroAcres is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 03:22 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014