ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-07-2009, 12:35 PM   #16
sidestand
bristol, uk.
 
sidestand's Avatar
 
Joined: Dec 2005
Oddometer: 273
07 990S, 12000mile pump failed, start up from cold, ride 30 sec to fuel pumps , fueled up, started her up, into gear clutch out started to roll, stopped dead . pump replaced under warranty. no probs since or before this.
sidestand is offline   Reply With Quote
Old 05-07-2009, 12:41 PM   #17
Venteuri
I don't give a shit
 
Venteuri's Avatar
 
Joined: Sep 2007
Location: Queretaro , Mexico
Oddometer: 14,216
Nov 07 990 - NO problems at all.
Have not cleaned or replaced the filters yet
All with Mexican red gas (some ocassional visits to Texas)
__________________
KTM 990 ADV 07 sold Member #68,893
Fishkens: Holy shit! Look at that little lizard. It's the Jesus Christ lizard...... Honey Badger don't give a shit.
Venteuri is offline   Reply With Quote
Old 05-07-2009, 12:54 PM   #18
Vicks
I love sand !!!
 
Vicks's Avatar
 
Joined: Oct 2006
Location: Abu Dhabi, UAE
Oddometer: 2,928
Quote:
Originally Posted by Taurkon
YES. Around 3500 km and mine died.

New one replaced on warranty, and I am now at 10500 km and beginning to wonder if the new one is bummed! Bike is sputtering, popping, stalls at idle once warm, and sometimes is only running on a single cylinder. Thing is, it does not happen all the time. Dealer can't find the problem... plugs are good, diagnostics comes up clean. I've run a few containers of injection cleaner through, and no luck. Starting to think it may be the pump.
a question for you and the others whose fuel pumps were replaced under warranty.

did u guys check with the dealer about the reason & nature of failure on the pumps ? are you sure it was the fuel pump or just the fuel filters ?
__________________
'07 KTM Adv990S - Gone to a good home
'10 KTM 530Exc-Rally
No myriad hues of laser lights, no bottles that are oozing with nectars from heaven
No beautiful body soft and warm to the touch but, i have a very small desire
Give me a dark... long... winding road, three gears to go and my Hellas on fire !!
Vicks is offline   Reply With Quote
Old 05-07-2009, 02:37 PM   #19
sidestand
bristol, uk.
 
sidestand's Avatar
 
Joined: Dec 2005
Oddometer: 273
They showed me the pump looked very new and clean [ including the large external sock filter]. They were sending it back to ktm as at that time, they knew of not one other failure. i'm sure he would have tested it though to make sure it was the pump and not just the filters.[ he's a very good bike mechanic]

If my pump would have failed Now, looking at the pics on this fourm, i would have ripped it a part for a closer inspection.
sidestand is offline   Reply With Quote
Old 05-07-2009, 03:06 PM   #20
duct tape
Lost
 
Joined: Jul 2007
Location: Colorful Colorado
Oddometer: 393
Quote:
Originally Posted by Gimme 2
For the record i have a 990 adv s 07 purchased in late 08 and yes the pump packed it in.
The bike had aprox 2500 k's on the clock.
Seems like you answered less than 50% of your own questions.....
__________________
950 SE
300 XC-W

Trails Preservation Alliance www.coloradotpa.org
Colorado OHV Coalition www.cohvco.org
duct tape is offline   Reply With Quote
Old 05-07-2009, 03:09 PM   #21
alphajory
Studly Adventurer
 
alphajory's Avatar
 
Joined: Mar 2008
Location: canada
Oddometer: 586
no problems
alphajory is offline   Reply With Quote
Old 05-07-2009, 03:14 PM   #22
Taurkon
Studly Adventurer
 
Taurkon's Avatar
 
Joined: Aug 2007
Location: Calgary, Ab
Oddometer: 600
Quote:
Originally Posted by Mr.Vicks
a question for you and the others whose fuel pumps were replaced under warranty.

did u guys check with the dealer about the reason & nature of failure on the pumps ? are you sure it was the fuel pump or just the fuel filters ?
Dealer stated: Faulty fuel pump.

I am dead positive it was the pump. I just left the tarmac and had stopped for a moment, turning the bike off. Tried to get it started again and zippo. I disconnected the fuel line and turned the bike over, and no fuel was being pumped through the line.
Taurkon is offline   Reply With Quote
Old 05-07-2009, 03:23 PM   #23
killurtv
free range moron
 
killurtv's Avatar
 
Joined: Aug 2008
Location: central oregon
Oddometer: 632
13500 miles on an 07 990- not a single problem.
__________________
one day I will learn, until that day... fuck it.
2001 HONDA XR650R
killurtv is offline   Reply With Quote
Old 05-07-2009, 06:00 PM   #24
azkiwi
message in a bottle
 
azkiwi's Avatar
 
Joined: Aug 2004
Location: Upstate AZ
Oddometer: 8,996
Quote:
Originally Posted by stimmer6253472
10,000 miles and no issues at all with the bike.
+1


Quote:
I think another question you should ask is how often you run the bike really low on gas. I live near a lot of gas stops and so I rarely go 5-10 miles past when the reserve light comes on.
I've run it pretty low a few times, I usually run it down to the last gallon. FWIW I make a point of filling up with Chevron.
__________________

azkiwi is offline   Reply With Quote
Old 05-07-2009, 10:02 PM   #25
jnyrav
Gnarly Adventurer
 
jnyrav's Avatar
 
Joined: Apr 2008
Location: Newport Beach
Oddometer: 335
16,000 miles, no problems with the fuel pump...
jnyrav is offline   Reply With Quote
Old 05-08-2009, 01:02 AM   #26
AUS CRUZER
Lets Cruz
 
AUS CRUZER's Avatar
 
Joined: Feb 2008
Location: Geelong
Oddometer: 2,409
NO @ 15000km
AUS CRUZER is offline   Reply With Quote
Old 05-08-2009, 01:10 AM   #27
Gimme 2 OP
Team slo ass
 
Gimme 2's Avatar
 
Joined: Mar 2009
Location: still looking
Oddometer: 1,830
Quote:
Originally Posted by Mr.Vicks
a question for you and the others whose fuel pumps were replaced under warranty.

did u guys check with the dealer about the reason & nature of failure on the pumps ? are you sure it was the fuel pump or just the fuel filters ?
Yep i did ask and he said the psi of the unit was running too low .
it's only now after reading some post on this site latley i realise there might be some fauty pumps out there thats what im trying to find out to see if im just the unlucky bastard or if there's a common thread to it all.

Gimme 2 screwed with this post 05-08-2009 at 01:30 AM
Gimme 2 is offline   Reply With Quote
Old 05-08-2009, 01:37 AM   #28
Gimme 2 OP
Team slo ass
 
Gimme 2's Avatar
 
Joined: Mar 2009
Location: still looking
Oddometer: 1,830
STATS SO FAR, 4 bikes out of the 21 that have put their hand up have had a fuel pump issue HANG ON NEW STATS COMING IN, ................yes i am bored
Gimme 2 is offline   Reply With Quote
Old 05-08-2009, 02:30 AM   #29
Vicks
I love sand !!!
 
Vicks's Avatar
 
Joined: Oct 2006
Location: Abu Dhabi, UAE
Oddometer: 2,928
Quote:
Originally Posted by Taurkon
Dealer stated: Faulty fuel pump.

I am dead positive it was the pump. I just left the tarmac and had stopped for a moment, turning the bike off. Tried to get it started again and zippo. I disconnected the fuel line and turned the bike over, and no fuel was being pumped through the line.
fair enough.

However, for the information of all concerned, please note that disconnecting the fuel line and turning the bike over is not the right test to check the healthiness of the fuel pump.

The quick disconnector is not so simple as you are expecting. There is a valve in there which opens only when the male & female sides of the disconnector have "mated". Once the disconnector is taken apart, the valve closes and fuel does not flow anymore into either sides.

If you look inside the disconnector, you will find a white colored valve. Now try to blow into this and you wont be able to. If you press the white colored valve and then blow, air will pass thru.

I found this when i dismantled the fuel pump on my 990 yesterday.
__________________
'07 KTM Adv990S - Gone to a good home
'10 KTM 530Exc-Rally
No myriad hues of laser lights, no bottles that are oozing with nectars from heaven
No beautiful body soft and warm to the touch but, i have a very small desire
Give me a dark... long... winding road, three gears to go and my Hellas on fire !!
Vicks is offline   Reply With Quote
Old 05-08-2009, 02:51 AM   #30
Vicks
I love sand !!!
 
Vicks's Avatar
 
Joined: Oct 2006
Location: Abu Dhabi, UAE
Oddometer: 2,928
here is a pic of the above said valve (see white plastic object insode the disconnector.....




__________________
'07 KTM Adv990S - Gone to a good home
'10 KTM 530Exc-Rally
No myriad hues of laser lights, no bottles that are oozing with nectars from heaven
No beautiful body soft and warm to the touch but, i have a very small desire
Give me a dark... long... winding road, three gears to go and my Hellas on fire !!
Vicks is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 10:58 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014