ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-17-2009, 06:09 PM   #46
Agave
El Corazón
 
Agave's Avatar
 
Joined: Aug 2007
Location: Portland,OR
Oddometer: 167
Quote:
Originally Posted by crashmaster
This is an interesting, and slightly disturbing thread.

I have about 10K on my 07 with no pump issues yet.

However, in light of this thread, it looks like I'm going to start carrying a spare pump and filters with me when I take off solo into the MOFN.
As I never ride this bike anywhere close to home, this issue is always in the back of my mind and freaks me out a little!07 990 ADV. 10K on the bike, no problems, lots of shady fuel. Fingers crossed
Agave is offline   Reply With Quote
Old 05-17-2009, 06:45 PM   #47
tahoeacr
Beastly Adventurer
 
tahoeacr's Avatar
 
Joined: Jan 2007
Location: Lake Tahoe
Oddometer: 2,209
Quote:
Originally Posted by Gimme 2
Thats eerrrr good to hear there mate, so no probs then?
Sorry, just a little humor. Never had a problem and I run the tank to reserve all the time. However, I only put chevron premium in it.
tahoeacr is offline   Reply With Quote
Old 05-18-2009, 06:01 AM   #48
Gimme 2 OP
Team slo ass
 
Gimme 2's Avatar
 
Joined: Mar 2009
Location: still looking
Oddometer: 1,830
Quote:
Originally Posted by dogsbody
Changed pump intake filter set at 28,000kms after experiencing surging under hard throttle.
Filter was dirty and tank had particulates in it. Rinsed tank out, fitted new filter and no problems since.
Filter was quite expensive. If I'd had access to an ultrasonic bath for cleaning it I think I could have reused the filter with no issues.
wtf's an ultrasonic bath, an icecream container and turps? i think a profilter prefilter is sounding all the better.
Gimme 2 is offline   Reply With Quote
Old 05-18-2009, 06:20 AM   #49
Vicks
I love sand !!!
 
Vicks's Avatar
 
Joined: Oct 2006
Location: Abu Dhabi, UAE
Oddometer: 2,928
Quote:
Originally Posted by Gimme 2
i think a profilter prefilter is sounding all the better.
+1 on the prefilter idea.

I had this thought in the noon.... Would it help if we install some kind of a prefilter to the fuel pump assembly similar to the UNI prefilters for the Air box snorkel ? would there by a filter available for this kind of application ?
__________________
'07 KTM Adv990S - Gone to a good home
'10 KTM 530Exc-Rally
No myriad hues of laser lights, no bottles that are oozing with nectars from heaven
No beautiful body soft and warm to the touch but, i have a very small desire
Give me a dark... long... winding road, three gears to go and my Hellas on fire !!
Vicks is offline   Reply With Quote
Old 05-18-2009, 06:28 AM   #50
dogsbody
Occasionally lucid
 
dogsbody's Avatar
 
Joined: Aug 2006
Location: Adelaide-South Oz
Oddometer: 300
Quote:
Originally Posted by Gimme 2
wtf's an ultrasonic bath, an icecream container and turps? i think a profilter prefilter is sounding all the better.
http://www.soniclean.com.au/ulc/faq.html

A few hours in one of these and the "pillow" filter looks like new. But I'd probably replace the pleated element filter rather than clean it. Just to be sure.

Pity they only come as a kit, not individually.........
__________________
dogsbody
dogsbody is offline   Reply With Quote
Old 05-18-2009, 09:48 AM   #51
Bonkers the Dog
Ned Catcher
 
Joined: May 2006
Location: S-West Coast Scotland
Oddometer: 167
Yes, got it back from the dealer a few days ago.

£480 for a new pump fitted! On top of a £450 service bill

FUCK!

A grand....you would think I drove a Porsche.

Not pleased.

Actually thinking of selling the bastard as it has had too many problems.
Bonkers the Dog is offline   Reply With Quote
Old 05-18-2009, 09:58 AM   #52
skier
genius or insanity?
 
skier's Avatar
 
Joined: Jun 2007
Location: Durango/Silverton, Colorado
Oddometer: 185
no problem

11,000 miles on an 07 990, not yet 2 years, no fuel problems
__________________
"When the going gets weird, the weird turn pro." HST
skier is offline   Reply With Quote
Old 05-18-2009, 10:48 AM   #53
flyingbeard
Beastly Adventurer
 
flyingbeard's Avatar
 
Joined: Apr 2006
Location: Ann Arbor, MI
Oddometer: 1,132
No Problems

13980 MI (22500 KM) on a 07 990 Adv and no problems at all after first FI re-mapping. Just oil changes and tires . Hard on the throttle all the time and run into reserve (20-30 miles) with high test gas.
__________________
Husky 11 TE630
HD 12 XR1200X
flyingbeard is offline   Reply With Quote
Old 05-18-2009, 05:16 PM   #54
azkiwi
message in a bottle
 
azkiwi's Avatar
 
Joined: Aug 2004
Location: Upstate AZ
Oddometer: 8,994
Shoulda made it a poll ... I tally 8 problems in 35 reports


azkiwi is offline   Reply With Quote
Old 05-27-2009, 09:05 AM   #55
duct tape
Lost
 
Joined: Jul 2007
Location: Colorful Colorado
Oddometer: 393
Quote:
Originally Posted by azkiwi
Shoulda made it a poll ... I tally 8 problems in 35 reports


And there seems to be a distinct lack of '08's and '09's (maybe too early for these) among the 8....?
__________________
950 SE
300 XC-W

Trails Preservation Alliance www.coloradotpa.org
Colorado OHV Coalition www.cohvco.org
duct tape is offline   Reply With Quote
Old 05-27-2009, 02:14 PM   #56
Adam990
Adventurer
 
Joined: Mar 2009
Location: Edmonton, Alberta
Oddometer: 35
I've got almost 2000 km on my 09 990 Adventure and no problems yet, runs like a dream !
Adam990 is offline   Reply With Quote
Old 05-27-2009, 04:30 PM   #57
unlokr
Gnarly Adventurer
 
unlokr's Avatar
 
Joined: Dec 2007
Oddometer: 139
No Problems

07 990 w/ 18,500 and not a single problem anywhere.
__________________
07 KTM 990 Adventure
02 Yamaha WR426F
06 Yamaha Kodiak 450
05 Yamaha TTR-125L (Daughter's Ride)
05 Yamaha TTR-90 (Son's Ride)
unlokr is offline   Reply With Quote
Old 05-27-2009, 08:48 PM   #58
Rideimal
Adventurer
 
Joined: Apr 2008
Location: Surrounded by Texas
Oddometer: 82
'08 990, 4500 miles, no problems
Rideimal is offline   Reply With Quote
Old 05-31-2009, 04:49 AM   #59
danceswithdeer
Space Wrangler
 
danceswithdeer's Avatar
 
Joined: Mar 2008
Location: Wyoming
Oddometer: 176
1400 miles...just got it back from the shop. Intermittent fuel pump. The thing is amazing now. I think the pump was weak from the get/go as the bike seemed kind of anemic in headwinds and passes, etc. I rode home through the Black Hills from Rapid City, and did a stretch between Necastle and Moorcroft (about 47miles) at a steady indicated 110mph all the way with lots of throttle left. Bike is way more fun now.

With the old fp, it felt wheezy at anything over 100 and would begin to cut-out and stall after about 50-80 miles. Again, most of the time, if I'd shut it off for five minutes or so, it would go another 50-80 miles. It also had a rougher idle with the old fuel pump.

And the fuel pump did not test bad. I took it over to the shop in Rapid and left it for a week; the tech said he did all the diagnostics, etc. but could not find a problem; he took it out for a ride and felt that it was fine. So I went back over and took it out for a 50 mile ride, and just like clockwork, it started acting up; I stayed close by the shop and went right back over, left it idling, and got the tech. He jumped on the bike, and it did its thing, bogged, popped, and lost power...then it stalled in traffic (like it's done to me - scary)...he came back wide-eyed and a believer, and put a new fuel pump in...and it's perfect now.

I'd be interested to know what's failing.
__________________
'08 990 Adventure

"No regrets. That's my motto...well that and everybody Wang Chung tonight."
danceswithdeer is offline   Reply With Quote
Old 05-31-2009, 09:13 AM   #60
Quietus
Mariner
 
Quietus's Avatar
 
Joined: Oct 2007
Location: N.Smirni - Athens - Greece
Oddometer: 448
'07 990 bought 11 months ago. 28000kms no problem till know!!
__________________
Dakar Team F5 proud member

Not all those who wander are lost..
KTM 990 Adv: "The Black Machine"
KTM 690 Enduro: "Agent Orange"
Quietus is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 03:11 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014