ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-23-2012, 04:05 PM   #526
DRONE
Dog Chauffeur
 
DRONE's Avatar
 
Joined: Oct 2007
Location: Tacoma, WA-ish
Oddometer: 3,577
Quote:
Originally Posted by daytona View Post
PS. It sure is strange that no site, inc BMW.. offer a battery for a G650X !!!! BMW needs to man up on these!!!!
What do you mean?
__________________
WUMPA
Sidecardogs.com
DRONE is offline   Reply With Quote
Old 09-23-2012, 06:57 PM   #527
Butters
. . . . . .
 
Butters's Avatar
 
Joined: Oct 2008
Location: NoVA
Oddometer: 2,478
On the BMW microfiche it lists part#61 21 7726563, which is a 10AH AGM battery. Although it doesn't list the brand, the screw set for that battery is listed as being YUASA. I would assume if you order that part number you would get a YUASA battery. Another dealer lists the manufacturer as "Genuine BMW." Of course BMW doesn't make batteries, but again I assume it is just a rebadged YUASA.

I would probably get an Odyssey battery if I wanted something different, although I have no issues with YUASA. But if I was planning on going somewhere really remote, I would probably keep a spare Shorai or similar in my luggage.
__________________
Marc
07 XChallenge
Butters is offline   Reply With Quote
Old 09-24-2012, 01:29 AM   #528
Tomdog
Mapaholic
 
Tomdog's Avatar
 
Joined: Sep 2008
Location: Kiwi on the Gold Coast. Australia
Oddometer: 316
Quote:
Originally Posted by Butters View Post
On the BMW microfiche it lists part#61 21 7726563, which is a 10AH AGM battery. Although it doesn't list the brand, the screw set for that battery is listed as being YUASA. I would assume if you order that part number you would get a YUASA battery. Another dealer lists the manufacturer as "Genuine BMW." Of course BMW doesn't make batteries, but again I assume it is just a rebadged YUASA.

I would probably get an Odyssey battery if I wanted something different, although I have no issues with YUASA. But if I was planning on going somewhere really remote, I would probably keep a spare Shorai or similar in my luggage.
Now you are talking; I've been thinking about carrying a Shorai as back up or even installing a two battery system using Lithium technology, with a change over switch.
__________________
07 X-Challenge
Tomdog is offline   Reply With Quote
Old 09-24-2012, 10:58 AM   #529
DRONE
Dog Chauffeur
 
DRONE's Avatar
 
Joined: Oct 2007
Location: Tacoma, WA-ish
Oddometer: 3,577
Quote:
Originally Posted by daytona View Post
Kinda what I said! Go to any site that sell batteries, U either won't find a BMW G650X in the list, or if they do have there won't be a choice (give a call they say) now list a KTM duke11 the same as we use is there! These bikes have been moved to the dark side!
I still don't get you. You said that BMW needs to "man up"--in giant red letters. What's that all about? And you say this because independent battery retailers don't list the G650XC in their online lists of bikes? What does this have to do with BMW?

As Butters points out above, if you want to buy a replacement battery from a BMW dealer, it has a part number like any other part. Just buy it.

Personally, I think BMW went above and beyond when it recalled ALL Exide batteries after the failure of a few on our bikes, instead of just replacing the ones that had failed. In my case, I replaced the Exide with an Odyssey before the recall. The next time I had the bike in for service, BMW handed me a brand new Yuasa battery in a box, even though I didn't need it or want it. What kind of crazy service is that? The service I get at my local dealer (South Sound BMW) is the best.
__________________
WUMPA
Sidecardogs.com
DRONE is offline   Reply With Quote
Old 09-24-2012, 01:56 PM   #530
satur9
angry black guy
 
satur9's Avatar
 
Joined: Mar 2009
Location: hfil
Oddometer: 488
really? I replaced mine with an odessy. and they told me to come in for recall I said I already changed it can I just have the new one they said no. bmwmoc.
__________________
seriously?.... is that what you ride?
Well, it took a lot of work to be the ass that I am
And I'm real damn sure that anyone can, equally easily f*ck you over ...(modest mouse).
satur9 is offline   Reply With Quote
Old 10-01-2012, 08:11 PM   #531
aprilian
Can I change this?
 
aprilian's Avatar
 
Joined: Feb 2009
Location: MinneSNOWta
Oddometer: 436
Quote:
Originally Posted by DaveyDave View Post
Yesterday I opened up the right hand side engine case to check out the sprog clutch for the 'fine white power' issue
I know it is an Arayan bike, but I didn't realize it ran on "white power"
__________________
There is no such thing as bad weather, only inadequate clothing.
aprilian is offline   Reply With Quote
Old 10-02-2012, 04:56 PM   #532
maltese
Adventurer
 
Joined: Jul 2012
Location: Oakland
Oddometer: 33
Wanted to check in about the Full Spectrum Power Pulse 2 battery (A123 type) I am running. The thing has been working without a hitch, except one funny thing... i guess the connections were old on the wires.. one snapped off after applying throttle really heavily and setting the front wheel down very ungracefully... easy fix and the bike has been starting up like a champ.
maltese is offline   Reply With Quote
Old 10-02-2012, 06:45 PM   #533
kito
Gnarly Adventurer
 
Joined: Mar 2009
Location: cheshire , England
Oddometer: 270
I have 2 problems with my x challenge . 1 MPG is getting worse somtimes as low as 40mpg I used to get over 70 mpg and the speedo is bugging me big time it started buy showing the speed I was traveling and then flashing to about 2/3 of the speed . now it just keeps changing everry few seconds and shows what ever speed it feals like . I have tryed dielectrode greese on the terminal and I have tryed opening the unit to spray some contact cleaning spray
kito is offline   Reply With Quote
Old 10-02-2012, 11:37 PM   #534
MTBiker78
ENDURO Wanabee
 
MTBiker78's Avatar
 
Joined: Apr 2008
Location: Poland
Oddometer: 184
Quote:
Originally Posted by kito View Post
I have 2 problems with my x challenge . 1 MPG is getting worse somtimes as low as 40mpg I used to get over 70 mpg and the speedo is bugging me big time it started buy showing the speed I was traveling and then flashing to about 2/3 of the speed . now it just keeps changing everry few seconds and shows what ever speed it feals like . I have tryed dielectrode greese on the terminal and I have tryed opening the unit to spray some contact cleaning spray
for a speedo problem just check condition of abs/speedo sensor located under left side of swingarm, and an ring on rear wheel hub. distance from sensor to ring must be constant and ring itself must be ideal (you can take it out and lay on flat surface to check if it was not bend anywhere). sensor connectior is placed under seat - you can check contact there also
__________________
Regards
Lucas

----------------
I have a new challange ..... X-Challenge ....

www.vimeo.com/mtbiker
http://picasaweb.google.com/lukasz.lechowicz/XChallenge
MTBiker78 is offline   Reply With Quote
Old 10-03-2012, 10:35 AM   #535
kito
Gnarly Adventurer
 
Joined: Mar 2009
Location: cheshire , England
Oddometer: 270
Quote:
Originally Posted by MTBiker78 View Post
for a speedo problem just check condition of abs/speedo sensor located under left side of swingarm, and an ring on rear wheel hub. distance from sensor to ring must be constant and ring itself must be ideal (you can take it out and lay on flat surface to check if it was not bend anywhere). sensor connectior is placed under seat - you can check contact there also
thanks for the tip ill look at those things but the funny thing is the speed display is all over the place but the odometer reading seams to be ok
kito is offline   Reply With Quote
Old 10-06-2012, 12:25 AM   #536
Colebatch
"Moto Porn"ographer
 
Colebatch's Avatar
 
Joined: Jul 2006
Location: Schmocation
Oddometer: 3,965
Quote:
Originally Posted by kito View Post
I have 2 problems with my x challenge . 1 MPG is getting worse somtimes as low as 40mpg I used to get over 70 mpg and the speedo is bugging me big time it started buy showing the speed I was traveling and then flashing to about 2/3 of the speed . now it just keeps changing everry few seconds and shows what ever speed it feals like . I have tryed dielectrode greese on the terminal and I have tryed opening the unit to spray some contact cleaning spray
Yeah sounds like you dented the speedo ring putting the rear wheel back in --- that makes the speedo fluctuate
__________________
*** New Sibirsky Extreme Trail DVD Trailer HERE ***
Moroccan Extreme 2011 DVD available HERE
World Motorcycle Altitude Record video HERE
Sibirsky Extreme - The Home of Adventure Motorcycling in Siberia and Mongolia - On Facebook
Colebatch is offline   Reply With Quote
Old 10-07-2012, 06:01 PM   #537
kito
Gnarly Adventurer
 
Joined: Mar 2009
Location: cheshire , England
Oddometer: 270
looked at the ring today and the is a small dent in it i will sort it out in a few days time . hope that sorts it out
kito is offline   Reply With Quote
Old 01-06-2013, 09:21 AM   #538
HH060g
Adventurer
 
Joined: Oct 2012
Location: Dirtona FL
Oddometer: 18
I have a 2007 Xmoto. 8,000 ish miles. i just bought it used a little bit back. It has the starting, then stalling out issue. I have taken the Idle actuator out and cleaned it until it was spotless. After i reassembled it, the bike started great for the first 3 times, then it went back to its old ways... tried resetting the throttle position using the method mentioned several times through out this thread to no avail. But this problem isnt my biggest issue. My bike is also, blessed with the hot start or hot wont start issue. I know it isnt my battery. I have read in a few places that it is the decompression lever, or it could be the vavles, or the camshaft.. I am looking for any one that has a solid answer on what it could be, before i start ripping into the bike. I am leaning towards the decompression lever, since when i try to start it, the starter sounds like it is fighting against the motor.. i have no experience with BMW's but i am hoping it isnt anything too complex.... Any words of wisdom from some of you folks that have dealt with this issue would be greatly appreciated.. Thanks!!
HH060g is offline   Reply With Quote
Old 01-07-2013, 11:28 AM   #539
aprilian
Can I change this?
 
aprilian's Avatar
 
Joined: Feb 2009
Location: MinneSNOWta
Oddometer: 436
Load test the battery if you don't know its age. Or you can charge it and see if the bike starts easier immediately after coming off the charger.
__________________
There is no such thing as bad weather, only inadequate clothing.
aprilian is offline   Reply With Quote
Old 01-08-2013, 05:16 PM   #540
HH060g
Adventurer
 
Joined: Oct 2012
Location: Dirtona FL
Oddometer: 18
It has a yuasa battery but i dont know how old it is. I will play with it and report back.
HH060g is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 02:34 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014