ADVrider

Go Back   ADVrider > Bikes > Battle scooters
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-23-2010, 02:06 PM   #1
Tim-Rodriguez OP
Gnarly Adventurer
 
Tim-Rodriguez's Avatar
 
Joined: Mar 2008
Location: London, UK Honda CB500 S
Oddometer: 233
Oil water pump seal gone on scooter...tips on how to fix?

Hello fellow riders.

Well my scooter is leaking oil from the tell tale hole under the water pump and was wondering if anyone has ever fixed this problem.

I have tried emailing Honda and they are not very helpful.

I manage to order a new oil seal but I think I will still need to get couple more things like a gasket, engine oil, coolant, circlip pliers.

If anyone has done this work I would appreciate some help on how to fix this.

__________________
"Every journey begins with a single step"
Tim-Rodriguez is offline   Reply With Quote
Old 07-23-2010, 07:18 PM   #2
fullmetalscooter
Let me take this duck off
 
fullmetalscooter's Avatar
 
Joined: Apr 2009
Location: BC
Oddometer: 2,770
ether by a use one or look up how People DYI it on old golwings gl 1000 or 1100. About the same if the impeller is gone.
__________________
Life's journey is not to arrive at the grave safely in a well preserved body,but rather to skid in sideways totally worn out shouting WHAT A RUSH, WHAT A RIDE.
"Life is a tragedy when seen in close-up, but a comedy in long-shot." Charlie Chaplin
fullmetalscooter is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 11:06 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014