ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-19-2011, 07:17 AM   #196
Gordy
Team Listo
 
Gordy's Avatar
 
Joined: Dec 2001
Location: NM
Oddometer: 21,706
Quote:
Originally Posted by crankshaft View Post
You mean the vector files my wife sold you for $10? The Vector files she spent hours and hours getting the fit correct? Don't forget about the material used in adjusting the fit? Just wanted to be sure I'm understanding it correctly.

Are your sponsored by Redbull? Do they know you're using their image?



Winter is near.
Gordy is offline   Reply With Quote
Old 09-19-2011, 07:21 AM   #197
Albie
Kool Aid poisoner
 
Albie's Avatar
 
Joined: Mar 2004
Location: NWA
Oddometer: 8,759
Quote:
Originally Posted by Gordy View Post


Winter is near.
Which thankfully means no more 100 deg days!!!!!!!!! Prime riding season coming up for some of us.
Albie is offline   Reply With Quote
Old 09-19-2011, 07:26 AM   #198
giodog2000
Gnarly Adventurer
 
Joined: Apr 2009
Location: Montreal , Quebec
Oddometer: 252
Quote:
Originally Posted by Albie View Post
Which thankfully means no more 100 deg days!!!!!!!!! Prime riding season coming up for some of us.
For me it's more like prime-storage. Arggggg!
__________________
First one out..last one in.

2011 KTM 690 Enduro R
2009 KTM 530 XC-W
giodog2000 is offline   Reply With Quote
Old 09-19-2011, 08:33 AM   #199
Velociraptor
TrackBum
 
Joined: Apr 2005
Location: Seattle
Oddometer: 1,021
Quote:
Originally Posted by andykeck View Post
OK, I have to admit it now; my SMC has officially kicked my ass. I'm about two inches away from picking up the phone and ordering the Vortex ECU, but I'm not 100% convinced my problem is in the tune, so I'm hoping someone here will have some insight. I never got to read all of the megathread before it got sent to live on a farm, so I'm sorry in advance I'm going over old ground.

I recently replaced my fuel pump (it was making odd noises and appeared to be filling the filter and injector with a fine black gritty sludge), and the last piece of the puzzle was the new fuel injector that I picked up this weekend. After fitting the fuel injector, adjusting the throttle sensors, and loading fresh maps with the tweaks as per this Code Orange post, I did the throttle reset and the 15 minute idle.

The result was just about perfect. I would never complain again if the bike ran that way all the time. It was just great. But sadly, just like every other time I've gotten the bike to run really well, it only lasted maybe 5-10 miles before it began to get very jerky again, this time with a side of unsteady idle. It's just as if it's forgetting whatever compensation it made during the 15 minute reset in the course of everyday riding after just a short while.

I guess I could just go on only five mile rides and do the 15 minute reset each time, but that's not all that appealing. Does anyone have any idea what could be going on here?

This time I used the 4031 Akra map as a base, but I've had the same issue with the 4132 Evo 1 map. SAS and O2 sensor disabled in every case.
Probably zero chance its your problem but check the coil connections to make sure they are tight. Pretty easy to do just to eliminate that possibility. As others have said, maybe there is still crap in your fuel system that is partially plugging your injector. You can pull the injector with all electrics connected and see if it is spraying out of all holes when you hit the starter. I assume that all the sensor settings have not changed after the bike starts running poorly again.
__________________
2014 KTM EXC 500
2014 KTM 1290 Superduke R
2009 KTM 690r Enduro SOLD
2002 RC51 SOLD
2010 KTM 990 Supermoto R SOLD

Velociraptor screwed with this post 09-19-2011 at 08:41 AM
Velociraptor is offline   Reply With Quote
Old 09-19-2011, 08:52 AM   #200
blakrj
Need to ride
 
Joined: Aug 2009
Location: Cloggland via Borneo, TX, UK, Oz and S.Africa
Oddometer: 187
Quote:
Originally Posted by giodog2000 View Post
For me it's more like prime-storage. Arggggg!
I'm with you on that one. Non stop pissing rain and cold weather. Oh no, that was the so called summer we just had!
__________________
2011 KTM 690 Enduro R, 2010 KTM 690 Enduro R (stolen)
2008 Yamaha YZ450, 2002 Yamaha YZ426
www.bruneibikers.com
www.airborneriders.com
blakrj is offline   Reply With Quote
Old 09-19-2011, 09:08 AM   #201
bobzilla
Dirty Old Man
 
bobzilla's Avatar
 
Joined: Apr 2006
Location: Lost & Found again in the Great Basin
Oddometer: 874
andykeck
my experience is that after being inside the fuel line ,especially down stream of the filter you will have contamination in the injector. i have never been able to tell by looking at the spray if it was clogged but after cleaning it worked again. the new injector number includes a screen that goes infront of the injector in the holder. this would solve most of the injector problems i would think.
search u tube for how to to clean the injector
__________________
Ride the DEZ
05 FE 550 Husaberg plated
08 FE 650 Husaberg plated
01 DR Frankenbike 650
76 CB750
bobzilla is offline   Reply With Quote
Old 09-19-2011, 09:26 AM   #202
andykeck
Adventurer
 
Joined: Mar 2011
Location: Santa Barbara, CA
Oddometer: 98
Thanks all for the suggestions so far. I'll be cleaning the injector tonight and hope it's as simple as that. I flushed the lines when I replaced the pump and again yesterday when I put in the new injector, so I'll be surprised if there's that much crud still in there. I also plan to replace the quick-disconnect with the inline filter mentioned a few posts back. The little in-hose filter that came with the new injector doesn't give me a lot of confidence.

If I have the time, I'm going to do the 15 minute reset first just as an experiment. My dim recollection is that the bike has been good after the reset after just loading maps, even when I've touched nothing in the fuel system at all. It sure feels the ECU is losing it's adaptations over time, but that may just be me over thinking it.

To look at this positively, I just could not have been more pleased with how the bike ran tearing out of my neighborhood yesterday. So I know it can do what I want. Just gotta get that to stick.

ETA: I have a 5v power supply that I use to cycle the injector while I back flush it. That's how I found all the black crud in the old injector the first time. I think that ought to do the trick if that is indeed the problem.

andykeck screwed with this post 09-19-2011 at 10:41 AM Reason: Can't spell, can't write, can't think.
andykeck is offline   Reply With Quote
Old 09-19-2011, 10:49 AM   #203
Barman
Way Offline
 
Barman's Avatar
 
Joined: Apr 2011
Location: Saratoga Springs, NY
Oddometer: 1,166
New injector.....

Where are you guys getting them? Mines been backordered for 2 freaking months now. Just wondering if I should call my supplier and crank them up a bit.
__________________
I am at one with my duality.
Barman is offline   Reply With Quote
Old 09-19-2011, 11:39 AM   #204
andykeck
Adventurer
 
Joined: Mar 2011
Location: Santa Barbara, CA
Oddometer: 98
Quote:
Originally Posted by Barman View Post
New injector.....

Where are you guys getting them? Mines been backordered for 2 freaking months now. Just wondering if I should call my supplier and crank them up a bit.
I've been waiting months too. Mine just came in Friday.
andykeck is offline   Reply With Quote
Old 09-19-2011, 11:59 AM   #205
Barman
Way Offline
 
Barman's Avatar
 
Joined: Apr 2011
Location: Saratoga Springs, NY
Oddometer: 1,166
Quote:
Originally Posted by andykeck View Post
I've been waiting months too. Mine just came in Friday.
Cool. Mine should be here soon then.
I'm glad it's just for a spare or I'd be pretty pissed right now. I'm thinking of ordering all of the common bits that are prone to failure ahead of time to avoid this huge delay in the parts chain.
__________________
I am at one with my duality.
Barman is offline   Reply With Quote
Old 09-19-2011, 12:09 PM   #206
bobzilla
Dirty Old Man
 
bobzilla's Avatar
 
Joined: Apr 2006
Location: Lost & Found again in the Great Basin
Oddometer: 874
munn racing , I called and had it the next day
dealer near here will not make an order until they have a lot of parts to order. helps me a lot.......thats why i spend my $$ with business that care about customer service.

Quote:
Originally Posted by Barman View Post
New injector.....

Where are you guys getting them? Mines been backordered for 2 freaking months now. Just wondering if I should call my supplier and crank them up a bit.
__________________
Ride the DEZ
05 FE 550 Husaberg plated
08 FE 650 Husaberg plated
01 DR Frankenbike 650
76 CB750
bobzilla is offline   Reply With Quote
Old 09-19-2011, 12:14 PM   #207
andykeck
Adventurer
 
Joined: Mar 2011
Location: Santa Barbara, CA
Oddometer: 98
Quote:
Originally Posted by bobzilla View Post
munn racing , I called and had it the next day
dealer near here will not make an order until they have a lot of parts to order. helps me a lot.......thats why i spend my $$ with business that care about customer service.
Interesting. When I ordered mine, I ordered at the dealer and one of the big online sites. Both were backordered, and both had exactly the same delivery estimate. Even better, both contacted me mid-wait to revise the date to the same new, farther out date. The dealer even did an online inventory check with other dealers and couldn't find one.
andykeck is offline   Reply With Quote
Old 09-19-2011, 12:59 PM   #208
Barman
Way Offline
 
Barman's Avatar
 
Joined: Apr 2011
Location: Saratoga Springs, NY
Oddometer: 1,166
Quote:
Originally Posted by bobzilla View Post
munn racing , I called and had it the next day
dealer near here will not make an order until they have a lot of parts to order. helps me a lot.......thats why i spend my $$ with business that care about customer service.
Quote:
Originally Posted by andykeck View Post
Interesting. When I ordered mine, I ordered at the dealer and one of the big online sites. Both were backordered, and both had exactly the same delivery estimate. Even better, both contacted me mid-wait to revise the date to the same new, farther out date. The dealer even did an online inventory check with other dealers and couldn't find one.
It started with a torn O-ring when I was doing the injector purge.
I started making phone calls for the $8+shipping O-ring and no one had one anywhere. So then I figured I'd order the injector kit that has the O-ring in it and have a spare injector in the bag with the filter upgrade. Another bunch of calls with no luck so I just went ahead and had them backordered in case I had an issue finding another O-ring. A few measurements and a quick browse through the Mcmaster-Carr selection and I came away with a pack of 25 Viton rings that work really well. Lifetime supply now for ten bucks or something.

Now I'm just playing it safe for a few hundred bucks and start a small parts stockpile. They won't go to waste and hell, it's only money right?
__________________
I am at one with my duality.
Barman is offline   Reply With Quote
Old 09-19-2011, 01:18 PM   #209
andykeck
Adventurer
 
Joined: Mar 2011
Location: Santa Barbara, CA
Oddometer: 98
Quote:
Originally Posted by Barman View Post
It started with a torn O-ring when I was doing the injector purge.
Funny how these things snowball, right. That's what happened to me, too.
andykeck is offline   Reply With Quote
Old 09-19-2011, 01:58 PM   #210
The Letter J
lost in the 690 mega
 
The Letter J's Avatar
 
Joined: Aug 2010
Location: Santa Maria, CA
Oddometer: 747
Quote:
Originally Posted by CHRIS_D View Post
Just to double check it's the Hammerhead KTM #1 that will fit our bikes? The reason I ask is that the OEM part # doesn't match what they say it will replace. Thanks!!
Yes sir, KTM1 fits the 690 , mine is a +15mm with the narrow, knurled tip:

The Letter J is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 06:55 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014