ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-07-2012, 05:24 PM   #5461
Mudguts
when in doubt GAS IT
 
Mudguts's Avatar
 
Joined: Jan 2006
Location: Some were in , lostralia
Oddometer: 1,999
krank with throttle wide open and or Pull the fuel line up stream from everything and see if it is spitting fuel?
Mudguts is offline   Reply With Quote
Old 09-07-2012, 06:30 PM   #5462
Buzztail
NMBBMFBK
 
Buzztail's Avatar
 
Joined: Sep 2007
Location: BUZZTOPIA
Oddometer: 10,774
Anybody clean one of these injectors in an ultrasonic?



Spray pattern was sketchy after a CA Cycleworks fuel pump, but I didn't see what it looked like before. 5k miles on the bike. Runs, but cuts out and dies at speed like it's not fueling. Pump runs, lots of fuel upstream all the way to the injector. Replaced QD with the NAPA filter. I'll reinstall it in the AM and see what the pattern looks like. Is it worth carrying a spare on the bike? What's the rate of failure for the injectors?
__________________
When there is no way out - Find a way further in.
DL650 DR350 MMS Edition KDX Past bikes ...and an airhead vvv
Quote:
Originally Posted by Mugwest
Quote:
Originally Posted by Buzztail
You shoulda told me to do this a long time ago
My bad
Buzztail is offline   Reply With Quote
Old 09-07-2012, 06:35 PM   #5463
Ryman
Studly Adventurer
 
Joined: Apr 2008
Oddometer: 743
That's how I do mine. I've changed the injector 3 times in 11k miles. They work like new after the ultrasonic bath.
__________________

Utards in Baja
http://www.advrider.com/forums/showthread.php?t=674444
Ryman is online now   Reply With Quote
Old 09-07-2012, 07:01 PM   #5464
Gros Buck
Beef = Packed Vegetables
 
Gros Buck's Avatar
 
Joined: Jun 2006
Location: Quebec City, Canada
Oddometer: 847
Quote:
Originally Posted by Ryman View Post
That's how I do mine. I've changed the injector 3 times in 11k miles. They work like new after the ultrasonic bath.
What is the best interchange to a KTM Injector ??? OEM is awfully expensive here.... $400

Paul Jr
__________________
KTM690r 2011
Gros Buck is offline   Reply With Quote
Old 09-07-2012, 07:13 PM   #5465
Ryman
Studly Adventurer
 
Joined: Apr 2008
Oddometer: 743
Quote:
Originally Posted by Gros Buck View Post
What is the best interchange to a KTM Injector ??? OEM is awfully expensive here.... $400

Paul Jr
Good question.....? So far I just have two OEM units that I switch up and keep clean with the jewelry cleaner.

A better question might be. How is cranks conversion going....????
I like his Ideas. Simple system. Readily available parts. Bomber wiring harness. I'd pay for this setup.
__________________

Utards in Baja
http://www.advrider.com/forums/showthread.php?t=674444
Ryman is online now   Reply With Quote
Old 09-08-2012, 12:54 AM   #5466
Beer'o'clock Baz
?
 
Beer'o'clock Baz's Avatar
 
Joined: Feb 2011
Location: Toowoomba
Oddometer: 1,688
Another problem fellas sorry I changed my fuel filter and screen today and i still have the stalling issue it actually blew the boot off for the first time does this leave me with a fuel pump issue under warranty ?
thanks
__________________
Remembering games and daisy chains and laughs
Beer'o'clock Baz is offline   Reply With Quote
Old 09-08-2012, 01:15 AM   #5467
.chris
690 Advenduro
 
.chris's Avatar
 
Joined: Feb 2009
Location: Auckland, NZ
Oddometer: 74
Trying to remove my rear shock, not had much luck with the top mount.



Any tips for removing that bolt? only has torx45 inside, not a nice convenient bolt I could get a good trip on.
__________________
I am interested in the future, because it's where I am going to live
.chris is offline   Reply With Quote
Old 09-08-2012, 01:18 AM   #5468
beaney
rally racer
 
beaney's Avatar
 
Joined: Jul 2009
Location: uk, or on a rally.
Oddometer: 124
Quote:
Originally Posted by .chris View Post
Trying to remove my rear shock, not had much luck with the top mount.



Any tips for removing that bolt? only has torx45 inside, not a nice convenient bolt I could get a good trip on.
Buy a decent torx socket set
__________________
690 enduro/ rally
350 exc
RALLY-RAIDPRODUCTS.CO.UK
beaney is offline   Reply With Quote
Old 09-08-2012, 02:03 AM   #5469
Mudguts
when in doubt GAS IT
 
Mudguts's Avatar
 
Joined: Jan 2006
Location: Some were in , lostralia
Oddometer: 1,999
Bit of heat and WD will help and yeah good tools worth there weight in gold
Mudguts is offline   Reply With Quote
Old 09-08-2012, 02:23 AM   #5470
Brute
Melbourne , outer east .
 
Brute's Avatar
 
Joined: Dec 2007
Oddometer: 1,007
Quote:
Originally Posted by Night Crawler View Post
while were on the topic. I am trying to do the throttle stop adjustment for the Vortex install and was wondering how you get the threaded aluminum cover off the top of the adjustment screw.
With a good pair of pliers . Mine had a lot of loctite.
Brute is offline   Reply With Quote
Old 09-08-2012, 04:04 AM   #5471
Xmoto
Death Race
 
Xmoto's Avatar
 
Joined: May 2010
Location: Schodack,NY
Oddometer: 2,107
Quote:
Originally Posted by Buzztail View Post
Anybody clean one of these injectors in an ultrasonic?



Spray pattern was sketchy after a CA Cycleworks fuel pump, but I didn't see what it looked like before. 5k miles on the bike. Runs, but cuts out and dies at speed like it's not fueling. Pump runs, lots of fuel upstream all the way to the injector. Replaced QD with the NAPA filter. I'll reinstall it in the AM and see what the pattern looks like. Is it worth carrying a spare on the bike? What's the rate of failure for the injectors?
What fluid to you use in the cleaner.
__________________
Opinions are like butt holes. Everyone has one and there's is the only one that doesn't stink.
Xmoto is offline   Reply With Quote
Old 09-08-2012, 04:16 AM   #5472
Buzztail
NMBBMFBK
 
Buzztail's Avatar
 
Joined: Sep 2007
Location: BUZZTOPIA
Oddometer: 10,774
Quote:
Originally Posted by Xmoto View Post
What fluid to you use in the cleaner.
Just warm water and a bit of mild detergent (pine sol, or Mr. Clean) I clean all kinds of shit in them (brass when reloading, etc.)

Last night I used straight water the first run and it still smelled like fuel inside so I added a cap full of Mr. Clean you could see the crap coming out and off of it.

A little vinegar works well too
__________________
When there is no way out - Find a way further in.
DL650 DR350 MMS Edition KDX Past bikes ...and an airhead vvv
Quote:
Originally Posted by Mugwest
Quote:
Originally Posted by Buzztail
You shoulda told me to do this a long time ago
My bad
Buzztail is offline   Reply With Quote
Old 09-08-2012, 04:48 AM   #5473
RoninMoto
Wanderer
 
RoninMoto's Avatar
 
Joined: May 2010
Location: Australia
Oddometer: 1,553
Quote:
Originally Posted by Buzztail View Post
Anybody clean one of these injectors in an ultrasonic?



Spray pattern was sketchy after a CA Cycleworks fuel pump, but I didn't see what it looked like before. 5k miles on the bike. Runs, but cuts out and dies at speed like it's not fueling. Pump runs, lots of fuel upstream all the way to the injector. Replaced QD with the NAPA filter. I'll reinstall it in the AM and see what the pattern looks like. Is it worth carrying a spare on the bike? What's the rate of failure for the injectors?
You want to put an electric pulse to the injector to get it to open and close. Just sitting there in the cleaner will not clean it completely. A 9 volt pulse of some sort would be ideal.
__________________
Noah 08 KTM 690 ADV. 111,000 km. 42 countries. 5 continents and counting.
RTW Ride Report --> http://advrider.com/forums/showthread.php?t=781893
Blog ------------------> http://rtwwithnoah.blogspot.com/
Facebook------------> https://www.facebook.com/RtwWithNoah
RoninMoto is offline   Reply With Quote
Old 09-08-2012, 05:06 AM   #5474
Buzztail
NMBBMFBK
 
Buzztail's Avatar
 
Joined: Sep 2007
Location: BUZZTOPIA
Oddometer: 10,774
Quote:
Originally Posted by RoninMoto View Post
You want to put an electric pulse to the injector to get it to open and close. Just sitting there in the cleaner will not clean it completely. A 9 volt pulse of some sort would be ideal.
Yeah, that's my next step. I feel like the bike should run as it is, but it just will not start. Once I get that figured out (no codes showing) I'm going to build a small 9v power supply to cycle the injector on and off while in the ultrasonic.
__________________
When there is no way out - Find a way further in.
DL650 DR350 MMS Edition KDX Past bikes ...and an airhead vvv
Quote:
Originally Posted by Mugwest
Quote:
Originally Posted by Buzztail
You shoulda told me to do this a long time ago
My bad
Buzztail is offline   Reply With Quote
Old 09-08-2012, 05:09 AM   #5475
RoninMoto
Wanderer
 
RoninMoto's Avatar
 
Joined: May 2010
Location: Australia
Oddometer: 1,553
Quote:
Originally Posted by Buzztail View Post
Yeah, that's my next step. I feel like the bike should run as it is, but it just will not start. Once I get that figured out (no codes showing) I'm going to build a small 9v power supply to cycle the injector on and off while in the ultrasonic.
Once you make the power supply, just connect a hose with a jug of desired solvent and have it gravity feed through the injector as it is cycling. It will be slow/nonexistent at first but should become a stream when it is clean.
__________________
Noah 08 KTM 690 ADV. 111,000 km. 42 countries. 5 continents and counting.
RTW Ride Report --> http://advrider.com/forums/showthread.php?t=781893
Blog ------------------> http://rtwwithnoah.blogspot.com/
Facebook------------> https://www.facebook.com/RtwWithNoah
RoninMoto is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 08:49 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014