ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-25-2013, 02:58 PM   #9466
Baja Dad
Beastly Adventurer
 
Baja Dad's Avatar
 
Joined: Jan 2011
Location: Norco California
Oddometer: 1,847
I am 6'3 275lbs and my 690 is great!!!
__________________
2014 support: GPR,IMS Aurora Rally Kriega, Raiden LS2,100Goggles,SIDI,Seat Concepts, Rally Raid Products UK,Precision Concepts, MX1West,Dunlop
Baja Dad is offline   Reply With Quote
Old 06-25-2013, 04:11 PM   #9467
gen
Studly Adventurer
 
gen's Avatar
 
Joined: Mar 2002
Location: Tokyo
Oddometer: 706
Quote:
Originally Posted by tacomodo View Post
Are there higher seats to be bought?
I'm not sure how high the tallest bar risers are, but is there enough cable length to raise them considerably?
Has anyone tried the swmotech footpegs that can be lowered by 25mm?
Are there links for the rear suspension to be bought that raise the bike perhaps?
Seats? Yes custom via Renazco or others who do custom seats.

You can get longer cables which are used when owners install rally fairings.

Kouba makes lowering links so it stands to reason that rising links could be made? Not sure by how much.

If this bike does not fit a tall rider, what would... ?
__________________
DoD#1458 | GaijinRiders | 2010 KTM 690 Enduro
gen is offline   Reply With Quote
Old 06-25-2013, 04:50 PM   #9468
Seth S
Safari Scramble!!!!!
 
Seth S's Avatar
 
Joined: Jul 2004
Location: sanity?
Oddometer: 4,087
Quote:
Originally Posted by bruceca2002 View Post
I tried to and lower my pegs with Fastway pegs but they did not fit my 2013 690E
The fastways don't fit the 2008 either but I made them fit. I had to remove a little of the aluminum on the peg mount to get them to go on but it had no effect on the mounts strength.
__________________
Seth S

My intuition nearly makes up for my lack of good judgement. Just installed my new trolling motor
Seth S is offline   Reply With Quote
Old 06-25-2013, 04:59 PM   #9469
sprouty115
Beastly Adventurer
 
sprouty115's Avatar
 
Joined: May 2012
Location: Providence, RI
Oddometer: 1,045
Quote:
Originally Posted by tacomodo View Post
Are there any tall guys here that can tell me how the seating position is? Do you sit like a jockey? I'm just over 2 meters, which google tell me is:
203 centimeters = 6.66010499 feet (6 feet 759⁄64 inches)
This site can be useful...
http://cycle-ergo.com/
sprouty115 is offline   Reply With Quote
Old 06-25-2013, 07:18 PM   #9470
Just_P_Dirty
Its more fun when Dirty!
 
Joined: Nov 2008
Oddometer: 272
i went from 625 sxc to a 2013 690e and i found it strange right off the bat. the seat is more even or in line with the front end. the wind seemed to be hitting me in my lower ribs instead of my chest and i am only 6 ft tall. so i gotta change something- seat/small windshield because i will do alot of on road riding and offroad. i barely flat foot but stand to one side at a light- the side without the exhaust...the seat still sucks anyway or i just have no butt so i will be looking to change it anyway...
__________________
Dirty
Just_P_Dirty is offline   Reply With Quote
Old 06-25-2013, 07:40 PM   #9471
MrHix
Gnarly Adventurer
 
MrHix's Avatar
 
Joined: Mar 2012
Location: MO
Oddometer: 385
Quote:
Originally Posted by bruceca2002 View Post
I tried to and lower my pegs with Fastway pegs but they did not fit my 2013 690E
What was the fit problem? I put my Moose pegs on my '12 690 and only had to grind the inside radii of the mounts a little to allow them to pivot enough.

Maybe?

Cheers,

MrHix
MrHix is offline   Reply With Quote
Old 06-25-2013, 08:01 PM   #9472
Hoots
Beastly Adventurer
 
Hoots's Avatar
 
Joined: May 2011
Location: Gundaroo NSW OZ
Oddometer: 1,227
Quote:
Originally Posted by sprouty115 View Post
This site can be useful...
http://cycle-ergo.com/
This is how it turns out if 6'8" (203cm) ...

Includes a 1.4" bar raiser ...

It would be great to be able to plant your feet like that in difficult country ...

But seated looks a bit cramped ...

Hoots is online now   Reply With Quote
Old 06-26-2013, 07:15 AM   #9473
DirtJack
Adventurer
 
DirtJack's Avatar
 
Joined: Aug 2007
Location: San Antonio, Texas
Oddometer: 1,098
Quote:
Originally Posted by tacomodo View Post
Sad to hear, I really had my heart set on a 690 :(

Couple more questions, though

Are there higher seats to be bought?
I'm not sure how high the tallest bar risers are, but is there enough cable length to raise them considerably?
Has anyone tried the swmotech footpegs that can be lowered by 25mm?
Are there links for the rear suspension to be bought that raise the bike perhaps?
I'm 6'4" (210 lbs) and have a 2008 690e since June 2008. I have a Renazco seat which is built up 1" - 2" and run 2" bar risers (2" doesn't require cable changes) on my Scott's mount. Bike fits me well. The Renazco seat is one of the best changes I made.
__________________
Remember, you're reading this on the Internet and it was written by a guy who can remember stuff which never happened.
2014 KTM 1190 Adventure R
2008 KTM 300 XC (plated)
2008 KTM 690 Enduro
DirtJack is offline   Reply With Quote
Old 06-26-2013, 02:22 PM   #9474
tacomodo
Trailblaze
 
Joined: Oct 2010
Location: Norway
Oddometer: 59
Thanks guys! 690 it is :)
__________________
That may be true, sir. But I have a hammer
tacomodo is offline   Reply With Quote
Old 06-26-2013, 02:51 PM   #9475
Seth S
Safari Scramble!!!!!
 
Seth S's Avatar
 
Joined: Jul 2004
Location: sanity?
Oddometer: 4,087
Quote:
Originally Posted by MrHix View Post
What was the fit problem? I put my Moose pegs on my '12 690 and only had to grind the inside radii of the mounts a little to allow them to pivot enough.

Maybe?

Cheers,

MrHix
I don't remember exactly. i will have to look at them again to see where I relieved. Something with the radius interfering with the pedal.
__________________
Seth S

My intuition nearly makes up for my lack of good judgement. Just installed my new trolling motor
Seth S is offline   Reply With Quote
Old 06-26-2013, 08:47 PM   #9476
blueillusion10
goodtimesgreatoddies
 
Joined: Oct 2004
Location: canada
Oddometer: 103
Question trouble

Has anyone had trouble with the auto decompression?

Over an 8hr ride my bike got harder and harder to start. The starter wouldnt turn the engine over well, sometimes not at all. The starter would make sound, more like it was trying to turn the engine but couldnt. I would rock the bike while in gear to move the piston and it would eventually start. Near the end it wouldn't turn it over at all. I charged the battery and still have the problem, even while boosting the bike it cant turn the engine over. It is now acting like a dead battery, even while boosting.

I pulled the starter and it spins and sounds fine. tested with the bike connections to confirm they are working. Not sure how to test it under load? The solenoid is working.

Any ideas?

PS. I have a 690 for sale, great price! Has trouble starting though.
blueillusion10 is offline   Reply With Quote
Old 06-26-2013, 08:53 PM   #9477
Bigbugberg
Meatbucket Supreme
 
Bigbugberg's Avatar
 
Joined: Feb 2010
Location: 1313 Mockingbird Lane
Oddometer: 291
Sounds like valve clearances to me.
__________________
I can explain it to you but I cannot understand it to you

2013 Guzzi Stelvio
2010 KTM 690 Enduro
2009 KTM 400XCW Plated
Bigbugberg is offline   Reply With Quote
Old 06-26-2013, 09:21 PM   #9478
The Letter J
lost in the 690 mega
 
The Letter J's Avatar
 
Joined: Aug 2010
Location: Santa Maria, CA
Oddometer: 747
Why not just pull the valve cover and have a look? It should only take 10-15 minutes to find out.
__________________
I can ride my bike with no handlebars, no handlebars, no handlebars - Jamie Laurie
The Letter J is offline   Reply With Quote
Old 06-26-2013, 10:06 PM   #9479
pirate277
Earl of Leisure
 
pirate277's Avatar
 
Joined: Jan 2005
Location: Calgary Alberta
Oddometer: 16
Same problem on my old 2009

Quote:
Originally Posted by blueillusion10 View Post
Has anyone had trouble with the auto decompression?

Over an 8hr ride my bike got harder and harder to start. The starter wouldnt turn the engine over well, sometimes not at all. The starter would make sound, more like it was trying to turn the engine but couldnt. I would rock the bike while in gear to move the piston and it would eventually start. Near the end it wouldn't turn it over at all. I charged the battery and still have the problem, even while boosting the bike it cant turn the engine over. It is now acting like a dead battery, even while boosting.

I pulled the starter and it spins and sounds fine. tested with the bike connections to confirm they are working. Not sure how to test it under load? The solenoid is working.

Any ideas?

PS. I have a 690 for sale, great price! Has trouble starting though.
I had same problem on my old 2009 just before my exhaust rocker bearing failed. The loose bearing causes valves to go out spec and then the decompression system will not work.
pirate277 is offline   Reply With Quote
Old 06-27-2013, 03:58 AM   #9480
saintfish
Adventurer
 
Joined: Feb 2013
Location: Adelaide
Oddometer: 12
Quote:
Originally Posted by pirate277 View Post
I had same problem on my old 2009 just before my exhaust rocker bearing failed. The loose bearing causes valves to go out spec and then the decompression system will not work.
I've also had the exhaust rocker bearing collapse on my 2012 with 30000kms. It had no compression braking and when I turned it off after a 700km day it couldn't turn itself over. Once fixed, the shims didn't need adjusting (but were technically out of spec when the bearing was loose)
saintfish is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 11:35 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014