ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-28-2012, 11:08 AM   #1
Lydcor1 OP
n00b
 
Joined: Dec 2007
Oddometer: 1
640 Adventure Throttle issues

I have 07 640 Adventure with 18000 miles on it. Last week the throttle started acting up. At times it will only twist 1/4 way back and then stop. If you let off the gas and try again it will open up. Other than the throttle stop, the bike is running great. Any thoughts?
Thanks
Jerry
Lydcor1 is offline   Reply With Quote
Old 09-28-2012, 11:27 AM   #2
bisbonian
Studly Adventurer
 
bisbonian's Avatar
 
Joined: Nov 2007
Location: Bisbee, AZ & Banamichi, Sonora
Oddometer: 982
Check around the linkage on the carburetor for something blocking the throttle action.
__________________
My 2009 Alaska Adventure

bisbonian is offline   Reply With Quote
Old 09-28-2012, 11:56 AM   #3
Sparrowhawk
Beastly Adventurer
 
Sparrowhawk's Avatar
 
Joined: Sep 2005
Location: Eastern Washington, USA
Oddometer: 1,834
Check the throttle cables.
Sparrowhawk is offline   Reply With Quote
Old 09-28-2012, 12:00 PM   #4
smokeeater495
Studly Adventurer
 
smokeeater495's Avatar
 
Joined: Oct 2008
Location: N.E. Indiana
Oddometer: 587
+1 on throttle cables. Either out of adjustment or worn.
__________________
Harley, been there done that. Don't want to be a pirate.
smokeeater495 is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 07:43 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014