ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-13-2012, 04:33 AM   #1
D0dja OP
Sandwurm
 
D0dja's Avatar
 
Joined: Feb 2003
Location: South Africa
Oddometer: 36
Best way to clean out oil after fixing coolant leak

I was having coolant leaking into my oil through the waterpump seal on my '02 KTM 640 Adv. Using the handy guide at http://www.advrider.com/forums/showt...55#post2599155 I rebuilt the pump with new seals, resealed the vale cover and top exhaust bolt. Waited 48 hours.

Tonight is the first fire up. Holding thumbs that I (a) diagnosed the right problem (b) fixed it right.

There's a lot of viscous white mayonnaise-looking contaminated oil - it's pretty sticky. What's a good way to flush out the oil system? Don't want to use one of those auto engine flush products - prob no good for the clutch, etc.

Was thinking to fire it up (please, please start...) and let it warm up, check for leaks, etc, then drain the oil, and refill with fresh.

Then ride for a couple hours to get it good and hot (which will hopefully drive some of the moisture out), and then do a full oil and filter change.

Any advice?
__________________
-- Ride it hard! Harder! HARDER! --
D0dja is offline   Reply With Quote
Old 11-13-2012, 05:13 AM   #2
Indy Unlimited
Beastly Adventurer
 
Indy Unlimited's Avatar
 
Joined: Jan 2007
Location: Parker, CO
Oddometer: 1,262
I just do 4 oil changes with cheap oil. run the bike each time for a few minutes and then drain oil and filter area.
Oil will be milky white first time and won't look normal until the final oil change it will have removed all water and glycol.
Then do one more oil change with good oil and new filter.
__________________
Current Stable:

2013 Ducati Hypermotard SP, 2011 Husaberg FE570S, 2011 BMW S1000RR, 2010 BMW F800GS
2007 Husqvarna TE610 , 2003 KTM 525 MXC
Indy Unlimited is online now   Reply With Quote
Old 11-13-2012, 07:24 AM   #3
AustinJake
TE450-KLE-FXDWG
 
AustinJake's Avatar
 
Joined: Aug 2010
Location: Austin, TX
Oddometer: 3,655
When I did my Husky, like Indy said, I used cheap oil from the clearance table at the auto store, got some 99 cent quarts, I also mixed in some ATF, high in detergents. The first pass, I ranit for 10 minutes, up and down the neighborhood streets, got it hot enough to drain well. The second fill, I ran it for 30 minutes, and dumped it. The third pass, I did an hour long ride and looked at it and decided for one more dump and fill, at which time I filled with my regular synth oil, and new filter. That was at 7000 miles, Husky has 11,000 miles now and running great.

__________________
____________________________________
Get fit. Stay safe. Enjoy life. Learn something to help someone in need.
AustinJake is offline   Reply With Quote
Old 11-13-2012, 12:05 PM   #4
D0dja OP
Sandwurm
 
D0dja's Avatar
 
Joined: Feb 2003
Location: South Africa
Oddometer: 36
Cool, thanks gents.

Fired it up this evening, seems to be running pretty good.

Will feed it some cheap oil tomorrow. Hopefully that's the last I'll see of the inside of my engine for a good long while.

Now it's time to replace the rear plastics and front fender and make it look prettier :)
__________________
-- Ride it hard! Harder! HARDER! --
D0dja is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:21 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014