ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-11-2012, 01:21 AM   #1
Tidsy OP
n00b
 
Joined: Aug 2011
Location: Urenui, New Zealand
Oddometer: 8
990 using water

I have a 2007 990 Adventure and has travelled about 60,000k. It has just started using a bit of water. Its not getting into the oil and not pooling on the ground. Anyone else had any similar problems and what was the out come. It seemed to start after we boiled the bike a couple of times in the sand towards the end of the TAT.
I look forward to torrent of information.
Tidsy is offline   Reply With Quote
Old 12-11-2012, 04:31 AM   #2
1stiski
Ride that nasty thing
 
1stiski's Avatar
 
Joined: Oct 2003
Location: Elizabethville, PA
Oddometer: 1,594
Time for a pump rebuild my friend. Thats all.
Be sure your rad cap is up to snuff too, check for cracking in the rubber seal and replace cap if it isn't up to snuff.
__________________
"04" 950 Adventure S 36,000+ miles
2003 Harley XL883 converted to CAFE (2013-14)
"Grim Brother" #1
1stiski is offline   Reply With Quote
Old 12-11-2012, 02:34 PM   #3
snowhawk jockey
Slack Jaw Gaper
 
snowhawk jockey's Avatar
 
Joined: Jul 2005
Location: The other Center of the Universe: Bend, Oregon
Oddometer: 1,093
I too, thought my coolant loss was related to the WP. No milkshake, no collapsed filter, no cam chain rattle, no crap in the overflow...

Turns out, some of the clamps on the coolant hoses closest to the motor, were not holding back water and letting a drop or two out every few minutes. Not enough to be seen, however, just to moisten the pipe joints and attract dust. So, upon thorough cleaning of that side of the motor and careful inspection after a ride, I found the weeping connections! Clamps away from happyness!
snowhawk jockey is offline   Reply With Quote
Old 12-11-2012, 03:52 PM   #4
Tidsy OP
n00b
 
Joined: Aug 2011
Location: Urenui, New Zealand
Oddometer: 8
Thanks guys will check these things out . I guess its a matter of elimination. Cheers T
Tidsy is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 08:15 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014