ADVrider

Go Back   ADVrider > Bikes > Thumpers
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 02-28-2013, 05:20 AM   #1
Bullamakanka OP
Adventurer
 
Joined: Jun 2011
Location: Roma Qld Australia
Oddometer: 24
Indicator/turn signal help - KLX 450R

Fitted a set of LED indicators to my 2008 KLX450R. Also fitted a Kawasaki LED flasher relay as the led's were not drawing enough current to work.

Now the rear LED indicators work fine however the front indicator just lights up and doesn't flash. Does the same left or right.

Worked fine when original indicators were fitted before the were forcibly removed

Searched online but not much luck so far.

Any ideas?
Bullamakanka is offline   Reply With Quote
Old 02-28-2013, 05:01 PM   #2
Bullamakanka OP
Adventurer
 
Joined: Jun 2011
Location: Roma Qld Australia
Oddometer: 24
Anyone?
Bullamakanka is offline   Reply With Quote
Old 02-28-2013, 05:30 PM   #3
YAHBO
Grip and rip since 1983
 
YAHBO's Avatar
 
Joined: Nov 2004
Location: Eastern Long Island, NY
Oddometer: 787
Do they begin to flash when you rev the motor?

If so, ride faster.
__________________
I'm an asshole and I approve this message.
YAHBO is offline   Reply With Quote
Old 02-28-2013, 05:36 PM   #4
Bullamakanka OP
Adventurer
 
Joined: Jun 2011
Location: Roma Qld Australia
Oddometer: 24
makes no difference
Bullamakanka is offline   Reply With Quote
Old 02-28-2013, 05:45 PM   #5
CSF
Gnarly Adventurer
 
CSF's Avatar
 
Joined: Mar 2012
Location: Ontario, Canada
Oddometer: 164
Do you have LED resistors on the wire to the blinkers? Like these:

http://www.ebay.com/itm/2X-6ohm-50W-...d14999&vxp=mtr

Are all four blinkers LEDs?
CSF is offline   Reply With Quote
Old 02-28-2013, 05:46 PM   #6
Bullamakanka OP
Adventurer
 
Joined: Jun 2011
Location: Roma Qld Australia
Oddometer: 24
Quote:
Originally Posted by CSF View Post
Are they LEDs?
LED's and also have fitted a LED flasher relay for Kawasaki bikes.
Bullamakanka is offline   Reply With Quote
Old 02-28-2013, 05:50 PM   #7
CSF
Gnarly Adventurer
 
CSF's Avatar
 
Joined: Mar 2012
Location: Ontario, Canada
Oddometer: 164
what about resistors?
CSF is offline   Reply With Quote
Old 02-28-2013, 05:54 PM   #8
Bullamakanka OP
Adventurer
 
Joined: Jun 2011
Location: Roma Qld Australia
Oddometer: 24
Quote:
Originally Posted by CSF View Post
what about resistors?
Apparently shouldn't need resistors with the LED flasher relay fitted. May have to just rewire the front on each side direct to the rear and see if that changes. Rear flash nicley while the front glows. Wiring diagrams in the manual doesn't show indicators existing at all from what I can see.

May have to visit an auto electrician I'm thinking.
Bullamakanka is offline   Reply With Quote
Old 02-28-2013, 07:20 PM   #9
Beezer
Beastly Adventurer
 
Joined: Oct 2004
Location: Anchorage, formerly Spenard (hub of the universe)
Oddometer: 5,372
no resistor needed. wire the front to the same place as the rear indicator if it isn't that way already
Beezer is online now   Reply With Quote
Old 02-28-2013, 07:29 PM   #10
Bullamakanka OP
Adventurer
 
Joined: Jun 2011
Location: Roma Qld Australia
Oddometer: 24
Quote:
Originally Posted by Beezer View Post
no resistor needed. wire the front to the same place as the rear indicator if it isn't that way already
Thanks mate, that's the plan now
Bullamakanka is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 11:41 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014