ADVrider

Go Back   ADVrider > Bikes > Orange Crush
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 08-20-2013, 12:09 AM   #1
katanarama OP
riding > posting
 
Joined: Aug 2008
Location: Vancouver BC
Oddometer: 182
Someone stole the time

My clock disappeared from my 990 instruments. It's weird as hell. I scroll thru' the odometer, trip one, trip two and KMs since reserve started but the clock is no where to be seen. No matter how many times I push mode the clock is gone.

2008 990 adventure and possibly TARDIS.
katanarama is offline   Reply With Quote
Old 08-20-2013, 03:25 AM   #2
Sumi
Beastly Adventurer
 
Sumi's Avatar
 
Joined: Mar 2010
Location: Hungary
Oddometer: 1,755
Quote:
Originally Posted by katanarama View Post
My clock disappeared from my 990 instruments. It's weird as hell. I scroll thru' the odometer, trip one, trip two and KMs since reserve started but the clock is no where to be seen. No matter how many times I push mode the clock is gone.

2008 990 adventure and possibly TARDIS.
It's because you don't need a clock when you're on an adventure ... so looks like the bike is telling you to take her around the world ;)
__________________
2005.5 950 Adventure (with 265mm travel suspension)
Sumi is offline   Reply With Quote
Old 08-20-2013, 05:36 AM   #3
Hipster
Beastly Adventurer
 
Hipster's Avatar
 
Joined: Aug 2004
Location: Mpls, Mn.
Oddometer: 1,740
You may have blown the fuse, check the glove box fuses.
__________________
2008 KTM 990 Adv & 2007 KTM 640 Adv
Hipster is offline   Reply With Quote
Old 08-20-2013, 05:45 AM   #4
Orangecicle
Beastly Adventurer
 
Orangecicle's Avatar
 
Joined: Apr 2007
Location: West Des Moines, IA
Oddometer: 2,214
Weak battery??? Odd stuff happens when the battery starts to go.

TARDIS.

__________________
"I'd like to meet the joker who had the nerve to call this a road!" -- Walter Sigmann
"Gravity is a very fickle mistress." -- Unknown
Facebook Page: https://www.facebook.com/brad.horn.9
Orangecicle is offline   Reply With Quote
Old 08-20-2013, 09:07 AM   #5
Vicks
I love sand !!!
 
Vicks's Avatar
 
Joined: Oct 2006
Location: Abu Dhabi, UAE
Oddometer: 3,010
The clock and ACC fuse has blown. If you were trying to install / connect a load to the ACC (i dont remember if it is ACC1 or 2) then there is a chance of intermittent connection happening which would have led to the blown fuse. Replace it and you will get your time back.
__________________
GO !!! Berglund brothers
GO !!! CS Santosh
Vicks is offline   Reply With Quote
Old 08-20-2013, 01:59 PM   #6
katanarama OP
riding > posting
 
Joined: Aug 2008
Location: Vancouver BC
Oddometer: 182
yep, it was the fuse. Thanks all.

Hopefully the replacement wont blow after 5 minutes.

Just had some KTM heated grips installed, hopefully that is not upsetting things.
katanarama is offline   Reply With Quote
Old 08-21-2013, 11:33 AM   #7
Questor
More Undestructable
 
Questor's Avatar
 
Joined: Oct 2005
Location: Diamond Bar, CA.
Oddometer: 4,130
My 950 is doing the same thing.
Checked all the fuses.
No clock, just "F".
But the clock did come back once, briefly.
But it left again.

Strange.
Q~
Questor is offline   Reply With Quote
Old 08-21-2013, 10:48 PM   #8
katanarama OP
riding > posting
 
Joined: Aug 2008
Location: Vancouver BC
Oddometer: 182
Blew again as soon as I started her up.
katanarama is offline   Reply With Quote
Old 08-25-2013, 12:03 PM   #9
Zuber
Zoob
 
Zuber's Avatar
 
Joined: Sep 2004
Location: Main Street, Shedd, Oregon
Oddometer: 1,846
I hate heated grips. Not the warmth, just the normal shitty install and weak parts. They typically increase service problems by 2x.

Electric gloves are a way better solution.
__________________
"Dad, can I get a motorcycle when I grow up?"
"Son, you can't do both"
Zuber is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 04:16 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014