ADVrider

Go Back   ADVrider > Gear > The Garage
User Name
Password
Register Inmates Photos Site Rules Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-04-2013, 04:15 PM   #1
rdhj OP
NJ Dual Sport Rider
 
rdhj's Avatar
 
Joined: Mar 2008
Location: Browns Mills, NJ
Oddometer: 191
can anyone help me with a hydraulic clutch issue..see link

http://www.cafehusky.com/threads/te4...-needed.35533/
rdhj is offline   Reply With Quote
Old 09-05-2013, 06:24 PM   #2
CycleDoc59
Wrench Rider
 
CycleDoc59's Avatar
 
Joined: May 2006
Location: East Virginia
Oddometer: 884
Clutch slaves are self-adjusting, just like
brake calipers. As brake pads or clutch plates wear,
the piston(s) move out -or in, to take up the slack.

If there is no air in the system
and adequate fluid, the piston will move out
farther with each lever stroke till it reaches
something to stop it, or it's pushed all the way
out of it's bore, or all the way in (see next paragraph)

With clutches that are rod operated thru the
clutch basket, clutch wear gradually moves the
rod toward the slave, so the rod effectively gets
longer, not shorter. And, as the clutch wears, master
cylinder fluid level increases. So, if fluid becomes too high,
clutch operation is affected; there must be air space
in the master.

I check the operation of rod-type clutches (either
cable or hydraulic) by pulling off the cover to see if
the clutches open/close adequately/smoothly.
Warped steel plates, grooved baskets,
gummy oil, improper assembly/etc can cause
neutral to be elusive....
CycleDoc59 is offline   Reply With Quote
Old 09-06-2013, 06:41 PM   #3
rdhj OP
NJ Dual Sport Rider
 
rdhj's Avatar
 
Joined: Mar 2008
Location: Browns Mills, NJ
Oddometer: 191
Is it possible that adaquate but not enough fluid in the master could cause an issue....what is weird is it seemed to have plenty in there, but I filled it up so the it was close to the top of the right side...some squeezed out when i put the cover on, but there was probably still room for air....i didnt changed the rod any, but now the neutral seems to be working
rdhj is offline   Reply With Quote
Old 09-07-2013, 01:45 PM   #4
barnyard
Verbal tactician
 
barnyard's Avatar
 
Joined: Sep 2007
Location: central Mn
Oddometer: 10,680
Your post does not mention what year your bike is, but clutch master cylinder issues are a known issue with some years. I would rebuild it and be done with it.
__________________
all around good guy
barnyard is offline   Reply With Quote
Reply

Share

Thread Tools Search this Thread
Search this Thread:

.
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


Times are GMT -7.   It's 05:17 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ADVrider 2011-2014