1190 EDS Failure

Discussion in 'Ridiculous streetbikes with 6 CPUs and too much HP' started by AdvIvan, Jun 19, 2013.

  1. AdvIvan

    AdvIvan Rock on!

    Joined:
    Jun 10, 2013
    Oddometer:
    112
    Location:
    Stockholm, Sweden
    It seams, that all the Adventure R-owners, who say that the EDS (Electronic Dampening System) on the normal (T) version means nothing but trouble, may have been right :deal

    Yesterday my bike started up with an EDS Failure message. Tried to restart etc, nothing helped. Drove down to the KTM dealer who connected their computer and ran some analysis. The fault codes were sent to KTM for further analysis. Nothing more could be done. This morning the Failure message was all gone. :1drink

    Anyone else had this issue already?
    I'll keep you posted, to see what they find out.
    #1
  2. Tancakar

    Tancakar Been here awhile

    Joined:
    May 16, 2013
    Oddometer:
    370
    Location:
    London , UK
    electronics some times can do things like this but i am sure it isnt major
    #2
  3. Bundu

    Bundu KTM 1290SA

    Joined:
    Aug 5, 2010
    Oddometer:
    892
    Location:
    Pretoria, South Africa
    since I had my software updated and other recalls done, I can't change my "LOAD" setting from "1 person" to any of the other settings without getting the "EDS FAILURE" warning

    Will have to see what the dealer says
    #3
  4. ebrew

    ebrew Motorcycle A.D.D.

    Joined:
    Nov 4, 2005
    Oddometer:
    1,472
    Location:
    Denver colo
    Same shit was going on with the ducati MTS 1200. They did work it all out
    #4
  5. PatSmith

    PatSmith Been here awhile

    Joined:
    Aug 12, 2011
    Oddometer:
    391
    Location:
    Sacramento
    I'm thinking this a software issue.
    A re-load might solve the issue. Good luck
    #5
  6. Bundu

    Bundu KTM 1290SA

    Joined:
    Aug 5, 2010
    Oddometer:
    892
    Location:
    Pretoria, South Africa
    I was also thinking that - I wonder if the R and the standard Adv have the same software and if not, what would happen if the R software is loaded to the standard model
    #6
  7. ADVill

    ADVill Been here awhile

    Joined:
    Sep 9, 2013
    Oddometer:
    611
    Location:
    West Tn, USA
    Damping. Sorry. Pet peeve. :rofl
    #7
  8. Espada

    Espada Been here awhile

    Joined:
    Aug 21, 2013
    Oddometer:
    121
    Location:
    The Ol' PW Co., VA
    Yup yup.
    #8
  9. Bundu

    Bundu KTM 1290SA

    Joined:
    Aug 5, 2010
    Oddometer:
    892
    Location:
    Pretoria, South Africa

    Ok, my EDS problem has been resolved by another dealer - the dealer that did my recall stuff, forgot a plug under the rider seat near the tank :huh

    They just plugged it in, reloaded the software and all is fine again :clap
    #9
  10. DfnsMn69

    DfnsMn69 Adventurer

    Joined:
    Nov 23, 2013
    Oddometer:
    78
    Location:
    Hillsboro, OR
    My turn evidently... EDS failure today at lunch... Take it in to the shop on Tuesday...SMH I'm starting to wonder if I got a bike assembled on Friday at 4pm... FFS how many more problems do I have to look forward to AFTER the warranty runs out?
    #10
  11. Jensdccom

    Jensdccom Adventurer

    Joined:
    Oct 20, 2013
    Oddometer:
    66
    Location:
    Belgium, Europe
    Had this error too. It got it after connecting some extra buttons, and my GPS system, to the switched ACC connector. After doing some research I found that this plug could only handle 2A before it shuts down.
    Everything was ok when you are riding but if the engine stalls and you try to restart you get all sorts of errors. Disconnecting the buttons solved the issue. Seems like you should only use the switched ACC for GPS and you should connect all other extra's directly to the permanent ACC connector.
    #11
  12. DfnsMn69

    DfnsMn69 Adventurer

    Joined:
    Nov 23, 2013
    Oddometer:
    78
    Location:
    Hillsboro, OR
    So I just heard back from the shop after 3 days and over 4 hours of trouble shooting they have determined...... wait for it...... That plugging a cell phone charger into the 12Acc port caused the EDS Failure to pop up...
    #12
  13. kten

    kten Been here awhile

    Joined:
    May 5, 2015
    Oddometer:
    880
    Location:
    QLD Australia
    And no explanation of why?? Is it a KTM dealer?
    #13
  14. DfnsMn69

    DfnsMn69 Adventurer

    Joined:
    Nov 23, 2013
    Oddometer:
    78
    Location:
    Hillsboro, OR
    They said that the system is susceptible to voltage and current issues... And yes they are a KTM dealer. I'm a bit baffled at their trouble shooting so I'll be calling the Orange Mothership Monday
    #14
  15. Shifty722

    Shifty722 Adventurer

    Joined:
    Jun 17, 2015
    Oddometer:
    26
    Location:
    Great N.W. Oregon

    Biggest load of bullshit I have heard from a dealer in quite awhile. I run a gps, phone charger, and a radar detector at the same time off my 12V port without issue.

    I would check the electrical connection at the shock.
    #15
  16. DfnsMn69

    DfnsMn69 Adventurer

    Joined:
    Nov 23, 2013
    Oddometer:
    78
    Location:
    Hillsboro, OR
    YEP pretty much where I'm at the actual tech wasn't available on the phone when they called to tell me my bike was ready. I'm going in tomorrow to have him actually explain his reasoning.
    #16
  17. Shifty722

    Shifty722 Adventurer

    Joined:
    Jun 17, 2015
    Oddometer:
    26
    Location:
    Great N.W. Oregon
    That should be an interesting conversation.
    #17
  18. Mototard1

    Mototard1 Adventurer

    Joined:
    Apr 18, 2015
    Oddometer:
    89
    Location:
    Alabama
    Monday I went for a ride and about 130 miles from the house I got a EDS Failure message. Then about 5 miles further I got a MTC Failure message. I turned the bike off and the messages would clear. About a mile down the road both messages would pop back up. I did make it home with no issues other than the dash lit up like a Christmas tree. The traction control still worked as did the shock adjustments. Guess its back to KTM. Bike is a 2014 with right under 16k miles on it. First issue I've had with this.
    #18