1190S shift light going on at 6500

Discussion in 'Ridiculous streetbikes with 6 CPUs and too much HP' started by mhpalin, Jun 26, 2014.

  1. mhpalin

    mhpalin Hippy

    Joined:
    May 4, 2014
    Oddometer:
    84
    Location:
    Lamont AB Canada
    Hi guys My shift light started going on at 6500 just like during brake in the bike has 8000kms on it.I took it to the dealer on Vancouver Island they don't have a clue has any one had this to them.The Dealer contacted KTM Canada but they have not got back to them.It's running good should I just put a piece of tape over it and not worry about it till I get home to Alberta.
    Thanks Mike:rofl
    #1
  2. Black Hills

    Black Hills Long timer

    Joined:
    Apr 7, 2011
    Oddometer:
    1,559
    Location:
    Western South Dakota
    the instructions to set it are in then manual. it's pretty simple, did you try that yet?
    #2
  3. mhpalin

    mhpalin Hippy

    Joined:
    May 4, 2014
    Oddometer:
    84
    Location:
    Lamont AB Canada
    Yes I turned every thing off this is just like when the bike is new and the light comes on at 6500 and stops automatically at 1000kms now it comes on again.It started as I was riding.
    Mike
    #3
  4. Harold Waikiki

    Harold Waikiki oldfatdumbbrokeoutofshape

    Joined:
    Dec 11, 2011
    Oddometer:
    537
    Location:
    Kirkland, WA
    Mine does that before it's warmed up. After it reaches temp it goes back to normal. HW.
    #4
  5. mhpalin

    mhpalin Hippy

    Joined:
    May 4, 2014
    Oddometer:
    84
    Location:
    Lamont AB Canada
    Mine does it all the even after 2hrs on the road:rofl
    Mike
    #5
  6. Bluesilver

    Bluesilver Been here awhile

    Joined:
    Aug 6, 2013
    Oddometer:
    757
    Location:
    South Africa
    +1
    #6
  7. MarchHare

    MarchHare Been here awhile

    Joined:
    Sep 22, 2009
    Oddometer:
    116
    Location:
    Home Counties, UK
    But have you followed the instructions in the handbook to adjust the point at which the shift light comes on?
    #7
  8. OrangeV

    OrangeV Long timer

    Joined:
    Nov 24, 2013
    Oddometer:
    1,122
    Location:
    Oztralia
    Page 58 of the manual, go to the Settings screen, then go to where the shit light is, there you set your shift light, simple as..:D
    #8
  9. Black Hills

    Black Hills Long timer

    Joined:
    Apr 7, 2011
    Oddometer:
    1,559
    Location:
    Western South Dakota

    is the engine temp gauge working properly?
    #9
  10. mhpalin

    mhpalin Hippy

    Joined:
    May 4, 2014
    Oddometer:
    84
    Location:
    Lamont AB Canada
    Okay guys first the shift light is off.I have the owners manual in hand for the 1190S on page 66 I followed the instructions and turned the shift light off.The bike was hooked up to the comp, at the dealer and showed no faults or codes.
    When the light turns on at 6500 rpm it is steady does not flash.The temp guage shows 4 bars when warmed up.So what it looks like to me is that the cluster has reverted back to brake in mode and I will see if it stops after another 1000kms witch should happen on the ride home.
    Mike
    #10
  11. Xphile1999

    Xphile1999 Adventurer

    Joined:
    Jan 5, 2014
    Oddometer:
    10
    The light will come on until you have completed the break in period, after that the shift light will automatically go to it's default. I believe the period to be 1000km.

    Edit: Also found this reference in another thread
    "Go to your owners manuel to page 72 part 9.2
    Running in the engine

    Guideline:
    During the first 1,000km (620mil) 6,500 rpm
    After the first 1,000km (620mil) 10,25 rpm"
    http://www.advrider.com/forums/showthread.php?t=951265
    #11
  12. mhpalin

    mhpalin Hippy

    Joined:
    May 4, 2014
    Oddometer:
    84
    Location:
    Lamont AB Canada
    The bike has over 8000 klms on it
    #12
  13. Xphile1999

    Xphile1999 Adventurer

    Joined:
    Jan 5, 2014
    Oddometer:
    10
    Ooops, sorry, misread that as 800km....coffee, need coffee.
    #13
  14. mhpalin

    mhpalin Hippy

    Joined:
    May 4, 2014
    Oddometer:
    84
    Location:
    Lamont AB Canada
    Okay guys I got a phone call from the dealer this morning he programmed my service interval wrong so I went back and he did it right this time.I guess when you go past your service interval the light goes on at 6500 rpm to tell you to take it easy.Well anyways it is still doing it so I will have to take it to my home dealership and maybe they can figure it out.:rofl
    Mike
    #14
  15. mhpalin

    mhpalin Hippy

    Joined:
    May 4, 2014
    Oddometer:
    84
    Location:
    Lamont AB Canada
    Okay finally figured it out the oil temp sensor has gone out of adj. just by chance when I started the bike today I checked the oil temp. 0C and the air temp was 21C. So I guess the bike thinks it's cold all the time and the light goes on at 6500.So will take it to the dealer for them to confirm this.Does any one think I am hurting the bike by taking it over 6500 rpm.
    Mike:rofl
    #15