1987 ch150 power loss & return... skipping? popping?

Discussion in 'Battle Scooters' started by herman7196, Jun 12, 2014.

  1. herman7196

    herman7196 Adventurer

    Joined:
    Nov 13, 2013
    Oddometer:
    27
    I've read up on this issue I'm having with my 3600 mile, 1987 ch150 and found that the cdi can go bad.

    So, I bought a new one on ebay (chinese clone for around $10 shipped). I put it in and the scooter still goes into these phantom and very random power losses where the engine cuts out and seems to run at 1/2 power.

    Eventually & and also very randomly, it'll come back to full power. Sometimes it'll stay at 1/2 power for the entire 2-3 mile inner city ride. Other times it'll stutter for 3-10 seconds and come right back to full power. Other times it';; feel like it's threatening to go into the 1/2 power mode but it never does.

    It sounds and feels like an ignition issue.

    I say this because it feels & sounds as if while riding, I've shut the kill switch off while keeping the throttle open... like a backwards, light popping but the engine still has 1/2 power and runs.

    I have lost some top end. I used to be able to jump on the highway and run up to 60mph pretty easy but now I'm struggling to hit 55mph.

    I removed the carb and cleaned it. It's fine. I currently have no air filter on it. The issue did still happen when I had a K&N pod filter on it. I'm pretty certain it has nothing to do with air filtration. I also adjusted the valves.

    The only thing I haven't checked it the fuel filter and that's because I changed it 2 years ago. The fuel tank has been por 15'ed so it's clean inside. The gas is fresh and new.

    I'm at a loss. :deal
    #1
  2. k-moe

    k-moe Long timer

    Joined:
    Jun 27, 2012
    Oddometer:
    3,272
    Have you checked for an air/ exhaust leak?
    #2
  3. baloneyskin daddy

    baloneyskin daddy bikaholic

    Joined:
    Oct 21, 2009
    Oddometer:
    2,177
    Location:
    southcentral PA.
    Chec k for cracked intake manifold or pinhole or holes in throttle carb slide diaphragm.
    #3
  4. herman7196

    herman7196 Adventurer

    Joined:
    Nov 13, 2013
    Oddometer:
    27
    The way the problem happens... randomly and infrequently... I don't think its an air or exhaust leak but I will look it over closer for those things.

    If there was a crack allowing an air or exhaust leak, I'd think it would always be leaking... not leaking off and on, randomly?
    #4
  5. tortoise2

    tortoise2 Been here awhile

    Joined:
    Dec 29, 2007
    Oddometer:
    593
    Location:
    Nevada
    Might try running the engine in darkness and look for any electrical arcing.
    #5
  6. Warney

    Warney Been here awhile

    Joined:
    Jun 6, 2010
    Oddometer:
    568
    Location:
    Omaha, Ne
    Won't run right without an air filter. Put on a clean Honda OEM paper filter. Throw out the Chinese CDI. Sounds like a piece of junk is intermittently plugging the main jet or some other part of the carb. Remove, disassemble, soak in 49-state Berryman B-12 Chemtool or other decent carb cleaner overnight. Blow it out with high pressure air. That Gumout with a straw doesn't work. As others mentioned carefully examine the rubber insulator boot between the carburetor and cylinder head.
    #6
  7. herman7196

    herman7196 Adventurer

    Joined:
    Nov 13, 2013
    Oddometer:
    27
    thanks for the advice guys
    #7