2003 KTM 640 ADV (Creeper HELP)

Discussion in 'Thumpers' started by DSM8, Apr 16, 2006.

  1. DSM8

    DSM8 Where fun goes to die....

    Joined:
    Aug 1, 2005
    Oddometer:
    4,464
    Location:
    Glendora, Ca
    Creeper or somone please help.

    I have a problem with my ADV. When I let off the throttle and it returns to the closed position at the bars (I.E. the throttle tube returns to the closed position) the RPM's either increase or remain at a high RPM.

    Does someone have a diagram that shows the proper routing of the throttle cables.

    :ear
    #1
  2. meat popsicle

    meat popsicle Ignostic

    Joined:
    Feb 9, 2004
    Oddometer:
    14,339
    Location:
    Circumlocution Office of Little Dorrit

    For how long? And it varies due to what? Meaning why does it sometimes surge and othertimes just stay high? Whatever it is, that sure will make your clutch hand busy (and wear out the clutch faster eh?)...

    I don't know if such a diagram exists. Why do you think it's cable routing? Perhaps they just need to be lubed?

    More info?
    #2
  3. creeper

    creeper Still alive...

    Joined:
    Dec 13, 2003
    Oddometer:
    10,718
    Location:
    Puget Sound
    Hummmmm,

    The cables in the stock position route across the back of the bars, down and along the upper left side of the frame backbone, then over the top and into the carb cable bracket. The stock cables are pretty beefy and not easily crushed, so I have a hard time believing they could be squeezed hard enough to bind them.
    I suppose if they are miss-routed and in a bind right from the start, this could affect your return to idle.

    Assuming they are not miss-routed, I'm more inclined to believe they are miss-adjusted. Remember that you have a pull-open and a pull-closed cable, plus the spring tension on the throttle plate bell-crank... so those areas are your most likely suspects.
    The idea of a pull-closed cable is to be able to force the throttle shut, no matter what... a safety device.

    The way I adjust throttle cables is to first slacken them up completely, then adjust the pull-open enough to turn the throttle bell-crank to it's stop and no more, then adjust the pull-closed cable to give me about 1/16" to 1/8" of free play at the throttle grip.

    Then, with the bike running, you turn the bars to center, full left and right lock. At each of these positions, blip the throttle to make sure it returns to a regular idle. If not, back off the pull-closed cable adjustment a bit.
    This is a whole bunch easier if you have a auxiliary fuel bottle, so you can run the bike with the tank off.
    If you have a good ear, you can forgo the running test and just listen for the throttle bell-crank to "click" against its stop when you let the throttle grip go.

    As an aside, I currently have my cables running on top of the frame backbone and up to the right side of the steering head. Works better with the SUB mount damper set-up.

    Good luck sorting it out,
    C
    #3
  4. DSM8

    DSM8 Where fun goes to die....

    Joined:
    Aug 1, 2005
    Oddometer:
    4,464
    Location:
    Glendora, Ca
    :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup :thumbup
    THANKS!!
    Will check that first thing.



    #4
  5. nikoktm

    nikoktm Been here awhile

    Joined:
    Jul 10, 2007
    Oddometer:
    368
    Location:
    Brisbane (QLD)
    Hi everybody!!!!!
    I just sent the frame to be painted (orange and looks great!), but i miss the pictures that i took of the electrical system...
    I couldn't find any information about how I can rewire and plug everything again!
    If anybody can give me some information or even better, some pictures i will be your friend forever!!!!!!!!!
    By the way, It's a ktm lc4 enduro 03!!!!

    Thanks :eek1
    #5
  6. bmwktmbill

    bmwktmbill Traveler

    Joined:
    Jul 16, 2005
    Oddometer:
    5,594
    Location:
    Traveler
    Make sure you have play in the choke cable and that the carb connections to the engine are tight.
    b.
    #6
  7. Zerodog

    Zerodog Long timer

    Joined:
    Jun 9, 2006
    Oddometer:
    1,233
    Location:
    SLC, UT

    Man this is totally off topic. It isn't even relevant to the original question in any way shape or form. Post a new thread on the topic please. You will get lots of answers for YOUR question.

    It is a good plan to take pictures of stuff and have a plan for reassembly before you take it apart. It will be a tough deal plugging everything in. I would start with the parts manuals you should have in your KTM briefcase thing. They might show your harness and the electrical assemblies.




    As for the original question,

    Check the throttle cables. I bet they are pinched by the tank. It is easy to do. I did it myself once. It is pretty exciting!
    #7
  8. Motobrandt

    Motobrandt Free Opinions Here

    Joined:
    Sep 13, 2002
    Oddometer:
    630
    Location:
    Los Angeles
    Yeah but.... Does anyone have any ideas who's going to run for president in 2008?

    I know it's a long ways off... But I'm feeling the something other then the typical white male politician... :ear






















    :pot
    #8
  9. DIRTYNIDGE

    DIRTYNIDGE Adventurer

    Joined:
    Apr 27, 2008
    Oddometer:
    25
    Location:
    Brisbane
    Just incase there is still an issue with the original question.

    If there arent any trapped cables to be found and the carby slide is free; try pointing steering staight and giving it a rev, if it doesnt settle back to idle quickly it could be your idle mixture running too lean.

    Depending on what carb you have, there may be an idle mixture adjusting screw, on my Dellorto it is just to the right (engine side) of the normal Idle (air) adjusting screw, screw it all way in then back 1.5 turns as a starting point, may need fine tuning, if it bogs down when revving - too rich, If it keeps revving after throttle shut - too lean, may have to be tuned in conjunction with Idle Air Screw.

    Apologies if Im barking up the wrong tree here, have just had a similar issue with my bike.
    #9
  10. ChrisC

    ChrisC Amal sex?

    Joined:
    Feb 25, 2003
    Oddometer:
    6,317
    Location:
    Prescott, Arizona USA Earth
    Fuckin' n00bs these days... :norton
    #10