276C reliability

Discussion in 'Mapping & Navigation' started by Jellyrug, Jan 28, 2009.

  1. Jellyrug

    Jellyrug Been here awhile

    Joined:
    Jun 22, 2008
    Oddometer:
    157
    Location:
    Pinehurst NC
    Are everyone enjoying their 276C Garmins?

    Mine was great, got the auto kit and the lady told me where to ride.

    First time I put it on my Husky, using the best Touratech mount, my Husky scared the s^^ out of the lady, she no longer talks.:eek1

    Since the lady stopped talking, I don't know where to go with my car.:huh

    Anyone else having reliability issues?
    #1
  2. nyc_gs

    nyc_gs Lurker

    Joined:
    May 30, 2005
    Oddometer:
    241
    Location:
    NYC
    I've had mine for 3+ years now and it has taken quite a lot in terms of vibration, etc and I have had no issues.

    Are you certain you didn't just turn the voice off in the prefs? You can turn it on and off.

    I would double-check that.

    -- Jason
    #2
  3. Jellyrug

    Jellyrug Been here awhile

    Joined:
    Jun 22, 2008
    Oddometer:
    157
    Location:
    Pinehurst NC
    Thanks Jason, thats reassuring, techie here checked it out, lady just buzzes, tried a different speaker, same thing. Must be the growl of that Husky.:D She sounded like a bit of a smoker in the beginning,:evil now she just hums. Garmin has an exchange on its way, I should be good.
    #3
  4. Gummee!

    Gummee! That's MR. Toothless

    Joined:
    May 13, 2004
    Oddometer:
    28,878
    Location:
    NoVA for now...
    I turned that annoying bitch off soon after I got my 276c. :nod I couldn't tell you whether she talks or not anymore! :D

    I upgraded to a 512 card finally! and its nice having the southern half of the country on my GPS. Which reminds me! I need to take off the eastern portion and add more in CA and northwards to UT/ID 'just in case.'

    M
    #4
  5. Solo Lobo

    Solo Lobo airhead or nothing

    Joined:
    Mar 16, 2004
    Oddometer:
    9,171
    Location:
    Shoreline, WA
    On a similar note, by 276c seems to have a hard time connecting with satelites... moch more so than my old 176c did... I have used both the stock antenna as well as a remote Glisson that should bring much more db gain (think that's what it is called)

    Is there any way to check, reset or do something to the 267c to see if it is working as it should?

    Thanks!
    #5
  6. Jellyrug

    Jellyrug Been here awhile

    Joined:
    Jun 22, 2008
    Oddometer:
    157
    Location:
    Pinehurst NC
    Curious, are you using the uncompressed map "City Navigator", or the compressed software "City Navigator NT"?
    #6
  7. Jellyrug

    Jellyrug Been here awhile

    Joined:
    Jun 22, 2008
    Oddometer:
    157
    Location:
    Pinehurst NC
    The antenna must face up to the sky, is this how you have it mounted?
    #7
  8. nyc_gs

    nyc_gs Lurker

    Joined:
    May 30, 2005
    Oddometer:
    241
    Location:
    NYC
    I have never had this issue, but it is my understanding that if you do have this, you can select the 'Stored w/o Batteries' option when the menu pops up asking if you want to start the simulator. That does a sort of 'reset' and may help you.

    -- Jason
    #8
  9. Solo Lobo

    Solo Lobo airhead or nothing

    Joined:
    Mar 16, 2004
    Oddometer:
    9,171
    Location:
    Shoreline, WA
    #9
  10. Solo Lobo

    Solo Lobo airhead or nothing

    Joined:
    Mar 16, 2004
    Oddometer:
    9,171
    Location:
    Shoreline, WA
    Thanks Jason, I will give that a shot tonight!
    #10
  11. jdaniele

    jdaniele Been here awhile

    Joined:
    Oct 5, 2007
    Oddometer:
    949
    Location:
    Now residing in Queens
    #11
  12. BWalker

    BWalker Been here awhile

    Joined:
    Dec 16, 2003
    Oddometer:
    176
    Location:
    Pittsburg,Tx
    I recently had some issues with trying to load maps from Mapsource NT on my 276c but after I downloaded a device software update everything works great. If you don't have software ver 5.3 you might try the free download from Garmin.
    #12
  13. bandera

    bandera Adventurer

    Joined:
    Jan 1, 2006
    Oddometer:
    17
    My 276C was just replaced with a new Zumo and now I am using it in the car. The unit is 5 years old and has 70,000+ moto miles on it. I've never had a problem with the 276C--bullet proof.
    #13
  14. ebbo

    ebbo Been here awhile

    Joined:
    Feb 20, 2003
    Oddometer:
    148
    Location:
    England
    My first 276c developed an intermittent fault were the audio output turned to a really nasty buzz instead of words. I put up with it for quite a while then chopped it in for a refurb when it couldn’t find satellites anymore. The second one’s a year old and ok so far.

    PS, fault was on speaker and audio out to Autocom...
    #14
  15. ObiWanJak

    ObiWanJak Been here awhile

    Joined:
    Oct 29, 2004
    Oddometer:
    234
    Location:
    Monterey, CA
    A common problem with the 276 is the backup battery going dead. This will cause the GPS internal clock to drop out and dramatically increase satellite acquisition times. Turn your GPS on and see if the time on the satellite status page is up to date. If the time starts counting up from the last time it had a satellite fix, then your backup battery is dead (should keep counting forward even when turned off). Seach this forum for 276c battery and you'll find a thread on replacement - costs about $5 and about 90 minutes w/ a soldering iron. Questions shoot me a PM.

    Loren
    #15
  16. Solo Lobo

    Solo Lobo airhead or nothing

    Joined:
    Mar 16, 2004
    Oddometer:
    9,171
    Location:
    Shoreline, WA
    Tried this on on the weekend and it seemed to work! Real test this week when I ride to work.
    #16
  17. nyc_gs

    nyc_gs Lurker

    Joined:
    May 30, 2005
    Oddometer:
    241
    Location:
    NYC
    Sweet! Good luck.

    -- Jason
    #17
  18. Solo Lobo

    Solo Lobo airhead or nothing

    Joined:
    Mar 16, 2004
    Oddometer:
    9,171
    Location:
    Shoreline, WA
    Acquisition was faster today then it has been in a year, all seems much better!
    #18
  19. Mountain Cruiser

    Mountain Cruiser Banned

    Joined:
    Mar 10, 2006
    Oddometer:
    1,204
    Location:
    Just Pass'n Through....
    I recently purcased a 276c. How do you turn the "voice" on. I did find where it says the speaker is "on".

    Thanks,
    Riceman
    #19
  20. 9Dave

    9Dave Bazinga!

    Joined:
    Aug 4, 2005
    Oddometer:
    13,526
    Location:
    Central Ohio
    There is no internal voice speaker on a 276c
    #20