640 Idiot Lights..Year by Year

Discussion in 'Thumpers' started by Badmunkie, Dec 27, 2005.

  1. Badmunkie

    Badmunkie ...and needing spanked!

    Joined:
    Feb 21, 2003
    Oddometer:
    181
    Location:
    Central Arkansas
    I'm planing to rework the idiot lights on my '01 640e. I like the TT 100R300 IMO but it's a bit pricey.

    I know that the 640 ADV's have had several different arrangements for idiot lights over the years but I really don't know what functions were monitored.

    Please chime in with with the different years and models and what idiot lights were included. Pics if ya 'ave 'em.

    To start, my 640e has the following:

    High H2O Temp (red)
    Turn Signals (yellow)
    Neutral (green)
    High Beams (blue)

    This is the TT Rallye Bracket with included faceplate and idiot lights that I've fitted to mine.
    [​IMG]


    'munkie
    #1
  2. markjenn

    markjenn Long timer

    Joined:
    Nov 9, 2003
    Oddometer:
    10,633
    Location:
    Bellingham, WA
    My 00 Adv has the same four lights from top to bottom: signals, high beam, neutral, high temp.

    - Mark
    #2
  3. Arch

    Arch Incurable Gearhead

    Joined:
    Dec 30, 2001
    Oddometer:
    11,706
    Location:
    Katy, TX
    Ditto for my '01, 'munkie...

    [​IMG]
    #3
  4. wadventure

    wadventure Mellow Adventurer

    Joined:
    May 3, 2004
    Oddometer:
    221
    Location:
    Lakewood Colorado
    Speaking of '01's Arch, have you ever replaced the light bulb in the computer? Mine died!
    #4
  5. CountPacMan

    CountPacMan Been here awhile

    Joined:
    May 22, 2004
    Oddometer:
    106
    Location:
    Portland, OR - USA / Oltenita, ROMANIA
    I'm not Arch, but I had the same thing happen to my 2000 model year. When I took the IMO apart, it was a really thin and badly soldered wire that went from the circuit board on the bottom to the display that had broken connection. Easy fix.
    #5
  6. wadventure

    wadventure Mellow Adventurer

    Joined:
    May 3, 2004
    Oddometer:
    221
    Location:
    Lakewood Colorado
    Thanks Count,

    I'll give it a look on my next tear down (in the next few weeks.)

    wadventure
    #6
  7. Badmunkie

    Badmunkie ...and needing spanked!

    Joined:
    Feb 21, 2003
    Oddometer:
    181
    Location:
    Central Arkansas
    Don't some of the 640 ADV's have an indication of low fuel level?

    'munkie
    #7
  8. cwk

    cwk n00b

    Joined:
    Sep 3, 2004
    Oddometer:
    0
    Location:
    Copenhagen, Denmark
    Do I understand correctly that non of the Adventure models had any low oil pressure lights???

    chris
    #8
  9. Arch

    Arch Incurable Gearhead

    Joined:
    Dec 30, 2001
    Oddometer:
    11,706
    Location:
    Katy, TX
    Mine's still working and the parts manual doesn't show any individual parts inside the actual Tripmaster, so I dunno about the bulb. Time for a look inside!
    #9
  10. Arch

    Arch Incurable Gearhead

    Joined:
    Dec 30, 2001
    Oddometer:
    11,706
    Location:
    Katy, TX
    The low fuel indicator (and mileage countdown) arrived in '02, I believe.
    #10
  11. Loadedagain

    Loadedagain making chips

    Joined:
    Jan 1, 2003
    Oddometer:
    26,749
    Location:
    West Vancouver, BC
    my 02 has low fuel level. no warning lamps. everything is intergrated into the imo.

    [​IMG]
    #11
  12. PASSMORE

    PASSMORE Just the last name...

    Joined:
    Apr 9, 2004
    Oddometer:
    4,276
    Location:
    The Texas Embassy in Sloughhouse, CA
    How ya got that GPS mounted up there Loady?
    #12
  13. Arch

    Arch Incurable Gearhead

    Joined:
    Dec 30, 2001
    Oddometer:
    11,706
    Location:
    Katy, TX
    Oops! Forgot about the different computer thingie.
    #13
  14. Badmunkie

    Badmunkie ...and needing spanked!

    Joined:
    Feb 21, 2003
    Oddometer:
    181
    Location:
    Central Arkansas
    So the KTM IMOs have the standard lights (Blinkers, High beam, Neutral, High H2O Temp) built in?

    And from '02 they include the Low Fuel Warning.

    It must be some other make with indications for Low Oil Pressure and Low Battery.


    'munkie
    #14
  15. meat popsicle

    meat popsicle Ignostic

    Joined:
    Feb 9, 2004
    Oddometer:
    14,366
    Location:
    Circumlocution Office of Little Dorrit
    I didn't think about this before munkie, but the parts fiche online have the parts listed, including lights in some cases :evil

    2000 model
    http://www.ktminfo.com/partscat/Parts.asp?Page=00582140&Cat=320497&CatID=231
    HIGH BEAM INDICATOR LIGHT BLUE 58011021200
    NEUTRAL INDICATOR LIGHT GREEN 58011023200
    TEMPERATURE WARNING LIGHT RED 58011022200
    FLASHER INDICATOR LIGHT GREEN 58011024200
    listed separately; must not be part of the IMO?

    2003 model
    http://www.ktminfo.com/partscat/Parts.asp?Page=03582140&Cat=320899&CatID=555
    no indicator lights listed; part of the IMO assembly
    #15
  16. Loadedagain

    Loadedagain making chips

    Joined:
    Jan 1, 2003
    Oddometer:
    26,749
    Location:
    West Vancouver, BC
    touratech super mvg mount on the bars. works real nice like. would work for your 376 too! no pics of just the mounting right now, but i'll get you some if you wish... in oregon right now. will be home tonight.

    [​IMG]
    #16
  17. Badmunkie

    Badmunkie ...and needing spanked!

    Joined:
    Feb 21, 2003
    Oddometer:
    181
    Location:
    Central Arkansas
    So what color is the Low Fuel Warning light on the KTM IMO?
    #17
  18. potatoho

    potatoho Cheese and Rice!

    Joined:
    Aug 3, 2004
    Oddometer:
    4,709
    Location:
    Sea-level
    Did your OEM mirror snap off too? I've had both of mine do that at the same spot. Was that a duke ii mirror?
    #18
  19. meat popsicle

    meat popsicle Ignostic

    Joined:
    Feb 9, 2004
    Oddometer:
    14,366
    Location:
    Circumlocution Office of Little Dorrit
    (diggin thru my memory...) I think it is a flashing yellow on my 03 KTM 640 Adventure. Pretty sure badmunkie; I have seen it a few times unfortunately :doh
    #19
  20. 666

    666 Agnostic and Orange

    Joined:
    Feb 23, 2005
    Oddometer:
    1,346
    Location:
    San Francisco, CA
    Is high temp light supposed to be on with ignition on? It never lights up on my 00 640 adv. Usually lights like that come on to indicate functionality.
    #20