690 Starting issues

Discussion in 'Thumpers' started by 777, Jan 9, 2013.

  1. Maurizio

    Maurizio 2 smoker

    Joined:
    May 24, 2003
    Oddometer:
    163
    Location:
    Turin, Italy
    Check the ignition key switch.
    #21
  2. yuu

    yuu Been here awhile

    Joined:
    Oct 14, 2011
    Oddometer:
    127
    Location:
    Southie, Arlington like
    I went flipped switches on mine last night. The fuel pump primes when the kill switch is set to 'run' and the bike is powered on. So the pump will prime if it's already in the run position and your turn the key, or the switch is off, the key is turned and then the switch set to 'run'.

    So the pump should run through the prime cycle regardless of the order of operation you do the switches in to get it to a state where the bike will run
    #22
  3. It'sNotTheBike

    It'sNotTheBike Banned

    Joined:
    Jul 20, 2011
    Oddometer:
    704

    It is obvious that most of the people who have made guesses in this thread don't
    understand fuel injection systems. Of course lack of knowledge doesn't prevent
    people on the internet from pretending to know something, but it does impede the
    search for the solution if you follow the false trails they create when they make their
    clueless suggestions. ( throttle body boot disconnected ? WRONG. )


    I've worked with mechanical and electronic fuel injection systems for over 20
    years. Based on my hands-on experience, here is MY guess :


    I believe your fuel injector is leaking ( when it should not be emitting fuel ) and this
    is the source of your hard-start problem as you have described it. When you switch on
    the ignition switch, the pump cycles and the fuel injector then leaks fuel and creates an
    over-rich fuel mixture which when the bike is warmed up makes starting difficult.
    In layman's terms, the engine is being "flooded" with fuel.


    The simple test to determine whether this is the case is to remove the injector
    from the throttle body and leave it connected to the bike wiring harness and fuel
    lines, and place the injector in a clear fuel resistant container.

    *****You should have a fire extinguisher handy during this procedure, and ideally
    it would be best to do it outdoors rather than inside a building ********

    ****** WEAR SAFETY GOGGLES or SAFETY GLASSES ( fuel in the eyes hurts ) **********

    Then, cycle the ignition switch and when the fuel pump cycles, you should watch the fuel
    injector closely and determine whether fuel leaks from the injector. Fuel is NOT supposed to
    emerge from the injector unless the engine is being started or the engine is running.

    If you DO see fuel come from the injector when you switch the ignition key on, you
    need to either clean or replace the injector such that when the test above is repeated using
    the cleaned or new injector, fuel no longer leaks when the ignition switch is
    turned on. It is difficult to diagnose a problem remotely but nonetheless I am 99%
    sure that your problem is caused by a leaking injector.


    Please be a responsible internet citizen and report back in this thread when
    you solve the problem, so that others who have a similar hard-start condition
    can benefit from your experience.

    Good luck !

    And by the way, if your shop couldn't figure this out, you need to find a different shop.
    This is basic stuff, not rocket science, and a mechanic who could not immediately
    know what to check after hearing your description of the symptoms is quite simply
    incompetent. Of course there are a lot of pretenders out there.




    .
    #23
  4. MORT666

    MORT666 Been here awhile

    Joined:
    Aug 2, 2009
    Oddometer:
    214
    Location:
    U.K
    Plug cap.:norton
    #24
  5. It'sNotTheBike

    It'sNotTheBike Banned

    Joined:
    Jul 20, 2011
    Oddometer:
    704

    :rofl:rofl:rofl:rofl:rofl:rofl:rofl:rofl:rofl:rofl:rofl:rofl:rofl

    Like I said, there are a lot of people pretending to have knowledge in this thread.
    #25
  6. 777

    777 Adventurer

    Joined:
    Jan 25, 2011
    Oddometer:
    98
    Location:
    Durban South Africa
    #26
  7. 777

    777 Adventurer

    Joined:
    Jan 25, 2011
    Oddometer:
    98
    Location:
    Durban South Africa
    What product or solution can I use to clean the injector ?
    #27
  8. Albie

    Albie Kool Aid poisoner

    Joined:
    Mar 31, 2004
    Oddometer:
    10,205
    Location:
    NWA
    I use Berrymans Chemtool.
    #28
  9. 777

    777 Adventurer

    Joined:
    Jan 25, 2011
    Oddometer:
    98
    Location:
    Durban South Africa
    Txs I in South Africa, will try and find it
    #29
  10. MORT666

    MORT666 Been here awhile

    Joined:
    Aug 2, 2009
    Oddometer:
    214
    Location:
    U.K
    Plug cap.
    #30
  11. 777

    777 Adventurer

    Joined:
    Jan 25, 2011
    Oddometer:
    98
    Location:
    Durban South Africa
    New plug and plug cap
    #31
  12. 777

    777 Adventurer

    Joined:
    Jan 25, 2011
    Oddometer:
    98
    Location:
    Durban South Africa
    Ok i thought i would remove and clean the injector today, but with a Safri tank on , it is too much of a mission, so i wil ask dealer to check on next servcie, txs for all your =help
    #32
  13. 777

    777 Adventurer

    Joined:
    Jan 25, 2011
    Oddometer:
    98
    Location:
    Durban South Africa
    Just some feedback, I rode a full tank out with injector cleaner in the tank, went well today, starting on the turn, seems to have sorted the problem out.
    #33