950 Adventure Water Pump Seal

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by JUNAC, Sep 1, 2013.

  1. JUNAC

    JUNAC Straight Shooter

    Joined:
    Jun 30, 2009
    Oddometer:
    669
    Location:
    Tecumseh, Ontario
    I'm wondering if anyone has had problems getting their water pump seal to seat properly. Before disassembly I could rock the impeller slightly back and forth. Ive got all the new parts installed, bearings, snap rings, seal, and impeller. However, I was not able to get the seal flush with the face of the water pump housing. I lubed the shaft with lithium grease first and I used a large socket to drive it in, gently of course. There is friction now when I try to rock the impeller. I believe the seal is touching the back of the impeller. The inner bearing was seated against the back of the water pump housing. The seal seemed to be the same thickness with no difference in back spacing either way it was installed. I know if it has to come apart I will need a new seal. Any suggestions? The rebuild kit I used is from KTM Twins. Thanks.
    #1
  2. Orangecicle

    Orangecicle On a "Quest"

    Joined:
    Apr 24, 2007
    Oddometer:
    4,106
    Location:
    West Des Moines, IA
    When I installed the grey seal, it did not go all the way flush. It stuck up just a little. I had the same thought, but I've been running mine for 3K miles so far -- no problems. I think as long as the shaft is still able to spin without massive drag, the pump should be fine. It may be that the extra lip of the seal just wears down after running a bit.
    #2
  3. JUNAC

    JUNAC Straight Shooter

    Joined:
    Jun 30, 2009
    Oddometer:
    669
    Location:
    Tecumseh, Ontario
    Mine is sticking out about 1/16"
    #3